Service Pack 4 Causes Problems

I was doing some work for a new client over the weekend.  I downloaded and installed Metaframe's Service Pack 4 and installed it.  Now, the client are no longer able to load any application from the Program Neighborhood.  When the clients double-click a program, it looks like it is loading, and even brings up the application window, but the application window is a solid blue background and no application.  It doesn't matter which application you try to load, because they all give the same result.  Office products, third-party apps, etc.

So...two questions:

1.  What the heck is the problem???  How do I fix it?

2.  If it can't be fixed, how do I roll back the Service Pack?  When I try, it tells me to insert the Citrix MetaFrame XP Server for Windows Feature Release 3 CD.  I don't have one, and the link to download it from the Cirtix support website is bringing up a page not found error.

I need to resolve this before they return to work Tuesday.  Any help would be appreciated!

James
LVL 9
jamesreddyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ellandrdCommented:
roll back

http://www.tokeshi.com/modules.php?op=modload&name=News&file=article&sid=3847


I would unistall the client and reinstall latest clinet then check before doing roll back

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jamesreddyAuthor Commented:
I already figured out last night how to roll back.  Now that I did, I have another problem.  No one can access the server farm, not even the farm.  On the servers, I get an error:

"Pass-through authentication failed, failed to connect to server ssapp2
Error Code:457"

According to the Citrix website, this can happen if the two servers are not properly aligning with the data store local cache.  But I'm not sure where to go from here.
ellandrdCommented:
can open an other question please s the one abov has been aswered

Thanks
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

jamesreddyAuthor Commented:
"Now, the client are no longer able to load any application from the Program Neighborhood."

The original problem remains....clients can still not open programs from the Program Neighborhood.  As far as I'm concerned, the question has not been answered.  You stated to roll-back, presumably to fix the no access problem.  Well, the clients still have no access.

The question has not changed.  How do I fix this?  The question has not been answered.  Sorry.
ellandrdCommented:
jamesreddyAuthor Commented:
Yes...I'm back to 3 again, which is where I started.  Now the server farm is not working, and therefore, no one can yet connect to programs via the Program Neighborhood.

I'm stuck....
jamesreddyAuthor Commented:
Now I have partial connectivity.  The WMI service was not started.  Once I started it, the server farm again functioned normally.  Now, Windows XP clients have no problems connecting to the published apps, but all of my 2000 clients recieve blue screens.  I am closing this and opening a new problem.  Thanks for trying to help.

James
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.