java.lang.NoClassFoundError

I have a simple program.

import java.io.*;
class Test3
{
   public static void main(String [] arg)
   {
      System.out.println("Hello");  
   }
}

When I run the program, I get the error:
Exception in thread "main" java.lang.NoClassFoundError: Test3.




mncbcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CEHJCommented:
Try

java -classpath %classpath%;. Test3

(assuming Windows)
CEHJCommented:
>>class Test3

should be

public class Test3

too

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mncbcAuthor Commented:
Thanks! I never had to add these commands before - is there something wrong with my XP environment?
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

CEHJCommented:
:-)

You can try the second answer alone first
mncbcAuthor Commented:
Thanks.
CEHJCommented:
No problem
kvj83Commented:
hi where to try this 1 solution in the cpmmand prompt or in the program itself.In my program class is public class as stated in solution 2 but then also same error is coming.java.lang.noclassfounderror
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java

From novice to tech pro — start learning today.