Cisco 5300 remote access users can not access Internet

Dear ,
 I have a 5300 router, use for Remote access, users can connect through modem and access both  Local network and Internet. About 5 days before, router route everything to gateway server in Local, and gateway server NAT for remote access users access internet. But now, router is configured as gateway to access Internet, and we use PPPoE Protocol in access internet through a FastEthernet port. From Local, all users can suffuring internet. But with Remote access users can access Local website,...in local , they even can ping, telnet,.... to Internet , but when use Internet Explorer to acess website from internet, the connection is disconect imediately, and I can not resolve it.

Log from Router when client is droped :
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61FB1754, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61FAD434, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61E617BC, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=62016D84, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %ALIGN-3-SPURIOUS: Spurious memory access made at 0x6028F8DC reading 0xA04
4d18h: %ALIGN-3-TRACE: -Traceback= 6028F8DC 603027CC 60291F3C 60CBD3E8 60269968 6048F72C 6026A428 6026D1B8
4d18h: %ALIGN-3-TRACE: -Traceback= 6028F8F0 603027CC 60291F3C 60CBD3E8 60269968 6048F72C 6026A428 6026D1B8
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61EA0C34, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61EC791C, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: As1/52 DDR: re-enable timeout
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=6207E278, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61F11830, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61EC0670, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61F64B80, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=62035C90, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61F7FA38, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58
4d18h: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=61E77558, count=0
-Traceback= 603D32C4 6026E070 6026C5D0 6048D064 8044BC58

LOD config :

AS5300# show running-config
Building configuration...

Current configuration : 2233 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname AS5300
!
no boot startup-test
aaa new-model
!
!
aaa authentication ppp default group tacacs+ local
aaa accounting network default start-stop group tacacs+
aaa accounting connection default start-stop group tacacs+
aaa session-id common
enable secret 5 $1$nWRe$dP5TQ/vGvzs4k9GcwBMH5/
!
username admin password 7 101F5B4A514244
!
!
resource-pool disable
dial-tdm-clock  priority 1 3/0
!
!
!
!
ds0 busyout-threshold 12
ip subnet-zero
ip cef
ip name-server 10.1.0.1
!
vpdn enable
!
async-bootp gateway 10.1.0.3
async-bootp dns-server 10.1.0.1
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
dial-control-mib max-size 100
!
controller E1 3/0
 framing NO-CRC4
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani
!
controller E1 3/1
 framing NO-CRC4
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani
!
!
!
interface FastEthernet0/0
 ip address 10.1.0.252 255.255.255.0
 ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 clockrate 2000000
!
interface Serial0/1
 no ip address
 shutdown
 clockrate 2000000
!
interface Group-Async0
 ip unnumbered FastEthernet0/0
 ip nat inside
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 180
 dialer wait-for-carrier-time 60
 dialer-group 1
 async default routing
 async mode interactive
 peer default ip address pool RAS
 ppp authentication pap
 group-range 1/00 1/59
!
ip local pool RAS 192.168.1.1 192.168.1.254
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.0.3
no ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
tacacs-server host 10.1.0.2 key tacacsserver
!
call rsvp-sync
!
voice-port 3/0:0
 compand-type a-law
!
voice-port 3/1:0
 compand-type a-law
!
!
mgcp profile default
!        
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 025756085F5359
 login authentication admin
line 1/00 1/59
 modem InOut
 autoselect during-login
 autoselect ppp
!
scheduler allocate 10000 400
end

AS5300#

Current Config :

AS5300#
AS5300#sh run
Building configuration...
Current configuration : 2772 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname AS5300
!
no boot startup-test
aaa new-model
!
!
aaa authentication ppp default group tacacs+ local
aaa accounting network default start-stop group tacacs+
aaa accounting connection default start-stop group tacacs+
aaa session-id common
!
username admin password 7 101F5B4A514244
!
!
resource-pool disable
dial-tdm-clock  priority 1 3/0
!
!
!
!
ds0 busyout-threshold 12
ip subnet-zero
ip cef
ip name-server 10.1.0.1
!
vpdn enable
!
vpdn-group pppoe
 request-dialin
  protocol pppoe
!
async-bootp gateway 172.16.0.2
async-bootp dns-server 10.1.0.1
!
!
!
!
!
!        
!
fax interface-type fax-mail
mta receive maximum-recipients 0
dial-control-mib max-size 100
!
controller E1 3/0
 framing NO-CRC4
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani
!
controller E1 3/1
 framing NO-CRC4
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani
!
!
!
interface FastEthernet0/0
 ip address 172.16.0.1 255.255.0.0
 ip nat inside
 ip tcp adjust-mss 1452
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 pppoe enable
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface Serial0/0
 no ip address
 clockrate 2000000
!
interface Serial0/1
 no ip address
 shutdown
 clockrate 2000000
!
interface Group-Async0
 ip unnumbered FastEthernet0/0
 ip nat inside
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 180
 dialer wait-for-carrier-time 60
 dialer-group 1
 async default routing
 async mode interactive
 peer default ip address pool RAS
 ppp authentication pap
 group-range 1/00 1/59
!
interface Group-Async1
 physical-layer async
 no ip address
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp pap sent-username Lsl-040416-03 password 7 03550958525A77
!
ip local pool RAS 192.168.1.1 192.168.1.254
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.1.0.0 255.255.0.0 172.16.0.2
ip route 210.245.61.160 255.255.255.224 172.16.0.2
no ip http server
!
access-list 1 permit 172.16.0.0 0.0.255.255
access-list 1 permit 10.1.0.0 0.0.255.255
access-list 1 permit 192.168.1.0 0.0.0.255

dialer-list 1 protocol ip permit
!
tacacs-server host 10.1.0.2 key tacacsserver
!
call rsvp-sync
!
voice-port 3/0:0
 compand-type a-law
!
voice-port 3/1:0
 compand-type a-law
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 025756085F5359
 login authentication admin
line 1/00 1/59
 modem InOut
 autoselect during-login
 autoselect ppp
!
scheduler allocate 10000 400
end
AS5300#


Now , anyone can help me to solve that, to make users can connect to the Router, access both Local website and surfing Internet with dialup connection, and will not be kicked out from router.

Thanks !
Epymol
epymolAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
Try changing the gateway to .1
>async-bootp gateway 172.16.0.2

to
async-bootp gateway 172.16.0.1

epymolAuthor Commented:
I have changed, but no thing happen, the connection still is kicked when browse a website .
lrmooreCommented:
The specific errors that you've posted show a serious bug in the IOS. I would call Cisco TAC and get an updated IOS version..

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pseudocyberCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:
Accept a comment - lrmoore

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Pseudocyber
EE Cleanup Volunteer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.