Windows can not start because of VMM.VXD, Shell.VXD, VTD.VXD, VXDLDR.VXD and VWIN32.VXD

Hi,

I was loading a usb driver and when I reboot the following message came up:  Configuration Manager cannot load because one of the following files is either not present or has an invalid version number:  VMM.VXD, Shell.VXD, VTD.VXD, VXDLDR.VXD or VWIN32.VXD

I press any key to continue and the computer shuts off.  
I tried to reinstall Windows - as advised here - unfortunately Windows can not be reinstalled on top of itself. The installation never finishes (actually when it is checking the free space and so on, the screen turns black with a cursor that does not move :-(
I can boot in DOSmode with the floppy. All my important files (not backed-up yes I'm stupid) are still there...
The CD drive behaves a bit funny too. When I do 'dir d:' it gives me all the time the same list of files, no matter the CD-Rom in it... Though it can read whatever disc is in it because I could start Windows installation by typing "setup" (though setup.exe did not appear on the list of d: after I did "dir d:"

Any advice would be welcome (except the one I know: back-up your files. But I was exactly doing that but the USB didn't work so I needed to load a driver again... then craaaash...)
In the last resort I will copy 600 mega of photo one by one on floppy discs but I will lose my digicam movies :-(

I've asked many comuter savvy friends of mine, to no avail, hence the points for this question
Thanx
gemini10961096Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

blue_zeeCommented:

Tap F8 at startup, select command prompt and proceed.

At the C:\ prompt type:

SCANREG /RESTORE (note space between G and /)

Press enter, select a date just BEFORE the problem started and reboot when finished.

See if that helps.

Zee
nobusCommented:
if you want to backup your data, you can hook up the drive to another PC as slave, and copy ot burn the files you need to cd.  This gives you the opportunity to format the drive, and reinstall windows again too.
BillDLCommented:
vmm32.vxd is not just a single file, it is one into which a whole lot of other vxd files are packed into during the original installation depending on your hardware setup, etc.  It is updated in stages as you add or remove hardware and software.  There are ways to rebuild it, but the best method is probably to reinstall Windows right back on top of itself into the C:\WINDOWS folder again.
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

☠ MASQ ☠Commented:
Also check this KB article
http://support.microsoft.com/?kbid=296579
Although a rebuild is not out of the question it could simply be a faulty file

gonzal13RetiredCommented:
Another suggestion for the future is:
Purchase Norton Ghost and another hard drive the same size or greater than you have.
Make the new drive a slave.
Now you can do a back up to the new drive in a compressed form and then scheduled incremental back ups.
The incremental backups are done while you are on the PC.

I did this since I crashed my xp pro thre times. I am a novice with the program
BillDLCommented:
Have you tried the  scanreg  /restore  command suggested by blue_zee yet?
If you have, and it didn't work, then try  scanreg  /fix

Just one thing.  When you say:

"I tried to reinstall Windows - as advised here - unfortunately Windows can not be reinstalled on top of itself. The installation never finishes (actually when it is checking the free space and so on, the screen turns black with a cursor that does not move".

I assume that you booted to a Windows 98 boot floppy (with the CD-Rom Support option), and tried reinstalling Windows from the CD.  Is that correct?

Well, that being the case, the reason why you are seeing the same list of files from the DIR D: command is that your CD will NOT be the D:\ Drive.  You see, the Windows 98 boot floppy creates a temporary drive letter that points to some files unpacked from a .CAB file on the floppy into memory.  This will always be the next letter up from the drive letter of your hard drive (or last partition letter if your hard drive is split into more than one partition).

I would be curious to see that list of files that you assume has been displayed from your CD, because I believe you are seeing the list of files unpacked into the temporary "RamDrive" that will be D:\  It's the only logical thing I can think of.

try the command:

DIR  %RAMD%:

and compare it to the results of the command

DIR  D:

Setup.exe didn't appear in the DIR D:  results???  For the above reason, I suspect, but how did you manage to run setup.exe to arrive at the stage where it hangs?

Try the command:

dir /on /a-d /b e:\win98\*.*

Does it show a list of .cab files and other files including setup.exe?  If so, then use the command:

e:\win98\setup

You say that it seems to hang up at the "checking for free space" process, so why not try disabling that process by adding the relevant options to the command?

Firstly though, I have to wonder if this is a problem not with the check for disk space, but with scandisk finding bad areas on your hard drive.  IF the bad areas happen to be in areas where some of those .vxd files were stored, than that would certainly account for the .vxd errors for a start.

I recommend booting to your win98 boot floppy again and running scandisk with a full hard drive scan and tell it to automatically fix problems.  When scandisk runs at the start of the Windows 98 setup, it doesn't do a surface scan.

SCANDISK c: /autofix /surface

This will take a long time, so be patient.

After that, try and reinstall Windows again and see what happens.  If it fails again, and if it definitely is while checking free disk space, then perhaps it IS because you are low on disk space.  Windows 98 needs to create a temporary setup folder into which it extracts a whole bunch of files to use during the installation.  This folder is deleted after installation completes successfully.

Have you tried booting into SAFE MODE?  Repeatedly jab the F8 key as the system starts to boot, and you should see a Boot menu.  If so, then arrow down to Safe mode and press Enter.  From there you would be able to open Windows Explorer and you would probably be able to uninstall a few fairly large programs or applications that wouldn't be crucial to backing up your data eg. Paint Shop Pro, Adobe Photoshop, any secondary Office application like Open Office, in fact any program you can easily reinstall and configure again, but NOT Internet Explorer, Outlook Express, or MS Office at this stage.

Also empty recycle bin, delete your browsing history and temporary internet files, C:\Windows\Temp folder, your Microsoft messenger Received files, etc.

If you know for certain that you DO have a lot of room free on your hard drive, then run the following options for setup:

e:\win98\setup /ID /IM /IS /IV

/ID       Ignores the DIsk Space check
/IS       Ignores the routine System check
/IM       Skips the memory check
/IV       No billboards during setup

Safe mode might also be a way to run WinZip to compress a number of important documents into a single file on floppy and it will allow you to "span" it over as many floppies as it needs.  A bit primitive, but better than nothing.  You can also access and write to an Iomega Zip Drive connected to the printer port if you load the DOS Driver (guest.exe).  Do you have a zip drive?  Even a 100 MB disk would be a lot more convenient than multiple floppies.

You can't normally access CD-Rom or CD-RW drives from Safe mode, but there is a set of tools that you can use to burn CD's from DOS that would be a good last resort to be ready for.

http://www.freeweb.hu/doscdroast/

Let us know what happens.
BillDLCommented:
Some of the Linux "Live" bootable CD's that load into memory and run from the CD allow you to access your normal folders and burn CD-R's.  Is this something that might interest you to have a go with?
gemini10961096Author Commented:
Thanx everybody for your effort.
I could solve this by myself so here is the report:
- The registry had nothing to do with it, so restoring it didn't change anything.
- The KB suggested by Masqueraid was of no help since my Autoexec.bat file is empty and does not show the lines in question
- BillDL, thank you very much. You did notice the thing about the D: drive. Actually the computer is my wife's laptop and has a Japanese OS, so I let that slipped, but on a closer look it did say it (but in japanese :-). The D: drive was indeed the image of the floppy, the Cd-rom being the E: drive. I' m just so used to my old French Windows 95 (I know I need an upgrade :-)
- Why windows did not reinstall itself? I have no clue. I can only guess. Actually the laptop's recovery discs are pain in the ass because none of them were Win98 per se, only a ghost image of the Pc out of the factory that would have wiped the drive clean... So I borrowed my sister-in-law Win98, which is actually a Gateway version... The content seems perfectly basic but maybe the CD contains some kind of lock that prevents any installation on other computers (the wife's is a Toshiba).

- So the fix... Thank you http://malektips.com/ubb/Forum1/HTML/000265.html
I reproduce this. Better two versions than one.


Follow these instruction exactly:
1 - When you start your computer hold down F8 just before the windows 98 logo comes on. You'll get up a "Boot Options" screen. (Keep trying till you get there.)
2 - Choose "Step-by-step confirmation"
[note: since it could not boot the last time, you may go through some other options first, but eventually you'll get there]
3 - Follow this exactly:
When it asks you to "create a startup log" press "y"
4 - When it asks you to "process startup device drivers" press "n"
5 - Keep pressing "y" for each question until it asks you to "process your startup command file" press "n"
6 - At "load "windows graphical user interface" press "y"
7 - At "load all windows drivers" press "y"
WAIT
8 - Now, for any other question, press "y" EXCEPT - SHELL, NTKERN, VMM, VPICD, VTD, VWIN32 and VXDLDR, for these press "n"
[my problem was only VMM since I don't have the other drivers... VMM is the first to come up and you are asked if you want to replace the standard config. I answered no]
**WAIT - windows should now load.**
9 - If you reset the computer after windows loads you will get the same problem, so DON'T! (Or else you have to repeat the steps all over again!) You have to try to find the driver you installed which caused the system to not load then uninstall it.
10 - I found that the file which caused the failure on my computer was "USB Supplement to OSR2"
[note my problem is also a USB driver. Can not uninstall it - it is not in the list - and when I delete it in the Control Panel/system window, my PC freezes. So I let it there and proceded to save my data]
11 - Try this incase you have the same problem.
12 - Open the control panel (Start menu, then settings, then Control Panel) Go to "Add/Remove programs", then see if "USB Supplement to OSR2" is in the list, if it is, press "Add/Remove" to uninstall it.

The computer works pefectly fine except of course the USB. I hooked up my CD burner on the PCcard slot and it is working hard right now. Once I'll have saved my data, there will be a nice formatting :-)

Thanx everyone
☠ MASQ ☠Commented:
Well found!

This has ended up a really useful thread for people with a similar problem in the future.
Suggest you post a free question in the Community Support area (http://www.experts-exchange.com/Community_Support/askQuestion.jsp) asking for the question to be retained but also reclaiming your points as you found the solution yourself.

M :o)
gonzal13RetiredCommented:
Hi:
I have one further comment.

I bought about 4 months ago windows XP PRO, I really could do with the Home edition but I like complicated programs.

Anyway, due to my inexperience with the program I had to reload it three times.

Finally what I did is to buy Norton Ghost and another HD the same size I have now. I then did an ISO image to the slave drive and set Ghost to update it once a week.

Joe

BillDLCommented:
Well diagnosed and solved.

How on earth did you end up with the USB supplement for Windows 95 OSR2 on your Windows 98 system?

It looks to me as if the originally installed OS must have been some kind of stage in between the last version of Win95 and Win98 First Edition, or perhaps the factory install set up the system with a slimline version of OSR2 and then performed an update to Win98.  Strange one that.

You have to use OEM CD's designed for other systems with great care.  For the most part, the core Win98 stuff will be much the same, but there are also usually machine-specific treaks and you could end up with some undesirable results.

Seeing as you are about to format and reinstall, now might be the time to install a full retail operating system and lose the ties to an OEM "recovery CD".  Download all chipset and other hardware drivers in advance and burn them to CD so you are ready.  I still like my Win98SE, but if your system is fast enough and compatible, then maybe Windows XP would be a logical step.
gemini10961096Author Commented:
The guy who posted the solution on the other website had the USB supplement for OSR2, not me. I just copied his step by step procedure.

My problem came from usb.sys
It actually started with a kernel problem that messed up the USB and the LPT1...

I realized the OEM win98 CD was probably the cause of my not being able to reinstall it.

I didn't format anything indeed. I just used the Toshiba recovery disc. I have now a Win98 up and running (not completely but this because I'm not able to read the final steps in japanese  so I just guessed :-] and I can now use the USB.
Since I had burnt everything I needed (thank god for all the combini open 24H/24 here in Tokyo, I could find a lot of CD-R at 4am :-) I'm good. This thing only cost me a lot of time... and a few euros...  Seriously, at one point a shop thought it would cost 70,000 yen ($500) to recover the data... right...

Next time I'll be carefull about the drivers I load (I never thought a driver could create so much problem). But again, if these were readily available on Microsoft's site, there wouldn't be so many problems...

Thanx again
DarthModCommented:
PAQed with points (500) refunded

DarthMod
Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.