IP Aliases

I want to use two aliases on my adapter. I set the IP to I want to add as an alias

So I added it in /etc/sysconfig/network-scripts/ifcfg-eth1:0 and restarted the network service but now the 192 address has been dropped for the 10.0 address.

How do you set this up properly?

Thanks in advance, you guys are great!
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

You propably didn't configured the DEVICE= parameter properly for the alias.
Should be something like:


Or if it does not work, send us both ifcfg-eth1* scripts.

And BTW: You don;t have to restart whole network service.
Its enought to
ifdown eth1:1
ifup eth1:1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LorangerGAuthor Commented:
Yes, of course! You are absolutely right, I forgot the :0! Thank you!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.