Static IP verse DHCP for internet browsing.

This is my situation I have Windows 2003 Server running DHCP and assigning out IP address, my workstation is getting the IP address but it is not able to browse the internet, when I put a static IP address in it will then browse the internet but only if I put a static IP address in. This is worth 500 points if someone can give me the correct answer to why this is happening.

Thank you

CJ
cjlocyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
When using DHCP type "IPCONFIG /ALL" and copy and paste the output here.

Then post your settings when you set it to static.
cjlocyAuthor Commented:
Dont want to give out my private information over the internet what are you looking for? I can answer it for you.

mattisflonesCommented:
First of all.. the info from your IPCONFIG is a standarized non public setup, and it will not reveal anything to anyone..
I`m assuming that you can get on the net from the server....!
#1: Do a ipconfig/renew.. If it does not report an error in the event log it will tell us if you have a good connection to the DHCP.
#2: Check if the gateway IP points to the server, and that the DNS IP`s are right. (either your own, or external)
#3: Check if your internet connection sharing is set up right..
#4: Pay the DSL bill... ;-P
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

mattisflonesCommented:
BTW: What errors are you getting when you try to get on the net? and can you open http://servername ?
Lee W, MVPTechnology and Business Process AdvisorCommented:
If you want help, you need to post information.  

I'm looking for your settings so I can see if you've set something incorrectly.  A Default gateway, an IP Address, a DNS server, a subnet mask.

Does your IP start with 192.168..y.z or 10.x.y.z or 172.16-31.y.z?  If so, you have non-routable info and it's pointless to hide it.
adamdrayerCommented:
true, leew.  But don't scare the guy =)

so if your static addresses work, and your leased addresses don't, then you obviously aren't getting the same settings from your dhcp server.  IPCONFIG /ALL will tell you all the information you need to figure this out, and you may be able to look at it and discover the answer.  It's obviously gonna be different then if you would have put a static address in, but how so?  is the gateway and subnet mask the same?  How much of the IP address is the same?

You can post your ipconfig /all here if you like, as leew says.  It's not dangerous and will help solve this fairly quickly.  But you can probably also email leew with the info if you are frightened.  His email address is in his profile.
Lee W, MVPTechnology and Business Process AdvisorCommented:
cjlocy,

I'm a Page Editor here for several topic areas (not this one though).  If you want, you can e-mail me the info at leew(at)experts-exchange.com and I will repost it here, edited to ensure accuracy for me and the other experts and your privacy.
meverestCommented:
there are two main reasons for dhcp failing when manual will work:

1.  bad, or undefined gateway
2.  bad, or undefined, dns

in either case, a good place to start is ipconfig /all (as already mentioned)

set up the interface manually and check that it really does work, then from a dos shell do "Ipconfig /all" and note *all* the results.

now check it to server assigned (make sure that DNS is also server assigned), and do the same.  compare the ipconfig results.

if you want to, you can set the dns manually, and let just the ip address be dhcp assigned.

and yes, it is true - if the ip addresses are 192.168.anything, then there is no drama to announce them.

most commonly, they will be somethinbg like "192.168.0.x" or thereabouts.  if they are in that range, then feel comfortbale to state them exactly.

Cheers!
cjlocyAuthor Commented:
I thank all of you for trying to help me out after about a hour playing with some settings I came across Scope options under DHCP and turned off 003 Router and 006 DNS and then my workstation was able to browse the internet with out having to put a static IP in- not sure how those settings got changed on me, possible update of service pack one could have changed them. But thanks for all your input and advice I was able to get it resolved on my own.

meverestCommented:
agreed
moduloCommented:
PAQed with points refunded (500)

modulo
Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.