Can't remove public folder store

I am having problems removing the default public folder store from our Exchange 2003 SP1 Front-end server.  I managed to remove the mailbox store fine, but when trying to move the public folder store I get the following message:

"An invalid ADSI Pathname was passed"

I've checked on the M$ KB and googled it, but I cannot find anything that speaks to this specific problem.

I have not done anything special at all to this store - it's just the default setup when Exchange was first installed.  Following best practices, I'd like to delete the stores and storage groups as it is a front-end server, but I cannot.

The only thing that I have done that was not set up by default is to ensure that relevant system folders (the OAB for example) replicate between two back end servers to provide redundancy.  I can't see how this would affect the front-end server public folder store though.

What else might be different?  Well, I had a problem in opening up the 'folders' view on the front-end server.  I tracked that down to the fact that the exadmin virtual directory had an SSL certificate defined on it that did not match the FQDN of the server (Q324345).  I resolved that issue, but it made no difference to my main problem.  (As an aside, it almost seems to be assumed that the SSL certificate *should* be the same as the FQDN of the server - why is that????  My understanding is that SSL certificates are by design independent of the server name or IP address - setting them the same would seem very poor security design and in many cases make little sense??)

Oh, one last thing.  This is currently a test rig in a Virtual Server 2005 world - about to be implemented for real.  As such, I know M$ don't support it.  However, unless this has a functional relevance to this particular problem, I don't care overmuch :-)

Any help on the main question and/or the aside would be most welcome.

Thanks,

Peter
LVL 1
CCSINCOMETRUSTAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NiclasHCommented:
I've seen this twice before and I've solved it differently. The first time it was an attribute value missing, legacyexchangedn I think, so I added the value manually and could remove the store. You and use ldp.exe or adsiedit and dump all attributes for the public store, compare with another public folder store and you may find an attribut missing. The second time I didn't find an attribut missing so I simply use adsiedit and remove the public folder store, worked fine.

Thanks
Niclas

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CCSINCOMETRUSTAuthor Commented:
Hi Niclas,

Yes, that worked fine.  I was in the second case so I just killed it from ADSI Edit.  

Any thoughts on whether there are any Exchange issues if the SSL certificate is not the same as the FQDN of the server?

Thanks for your help,

Peter
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.