permanent error 5.1.1 sending to certain external addresses

hello:

I run an exchange 2003 enterprise edition server behind a firewall (m0n0wall) on a high speed ADSL server connection.  I have absolutely zero issues.  therefore i figured that i should be able to duplicate my efforts for one of my clients.  First mistake.

my client is running MS SBS 2003 with exchange as well.  they only have a SOHO ADSL package with the same ISP.  this package blocks port 25, for obvious SPAM related issues.  they can send internal messages fine and also messages to the outside world seem to be OK as well, but anything sent to an address with their ISP's extension (ie...***@TELUS.NET) comes back with the 5.1.1 permanent error message.

what i would like to know is this,  would upgrading their ADSL package to the same one that I have, be enough or am I missing something?  I am open to any suggestions here seeing as i already look like a fool to these clients and would like to close the book on this one rather ASAP (hence the points)

TIA

cashcomp
LVL 3
cashcompAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SembeeCommented:
Are they using their own domain or the ISPs domain?
Have you used message tracking to see whether the messages are actually leaving the server?

Simon.
cashcompAuthor Commented:
they are using ********.LOCAL for their internal domain.  unfortunately message tracking has not been turned on.  I will do that today and see what the logs tell me later in the day.  As I am not the brightest out there, i will post it ASAP.

thanks,

cashcomp
SembeeCommented:
What are they using for their external domain? How do people send email to them?

Simon.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

cashcompAuthor Commented:
their external is TELUS.NET and people send email to them at their *@TELUS.NET email addresses (these come through fine, although they are sometimes in duplicate)
SembeeCommented:
What is the Exact NDR that comes back when they send to addresses at the ISP?

Has the option in Recipient Policy for "exchange is responsible for all email on this domain" been disabled?

Anything set on the SMTP VS for "forward unresolved recipients to host:"?

Simon.
cashcompAuthor Commented:
Your message did not reach some or all of the intended recipients.

      Subject:  New Test

      Sent:     6/28/2005 8:56 AM

The following recipient(s) could not be reached:

      BOGUSUSER@telus.net on 6/28/2005 8:53 AM

            The e-mail account does not exist at the organization this message was sent to.  Check the e-mail address, or contact the recipient directly to find out the correct address.

            <telus.net #5.1.1>

The recipient policy has not been disabled to my knowledge.

the last, I have nothing set for unresolved recipients.

cashcomp
SembeeCommented:
If you haven't set those two options then Exchange will not send any email destined for the domain telus.net because Exchange thinks it is responsible for ALL email sent to that domain. Those two options will get Exchange to push out email for addresses that aren't local.

Simon.
cashcompAuthor Commented:
now I am fairly new at all of this and don't have the luxury of a manual.  do you mind me asking how I would go about setting those options?

thank you,

cashcomp
SembeeCommented:
There are no manuals for Exchange.
Most people get books or look at the white papers on Microsoft.com

Two settings.

ESM, Recipients, Recipient Policy.
Right click on the default and choose Properties.
Click on the "Email Addresses" tab, then choose the domain in question and click Edit.
Deselect the option "This Exchange Organisation is responsible for all mail delivery to this address".

Apply/OK out.

Second option
ESM, Admin Groups, <your admin group>, Servers, <your server>, Protocols, SMTP, Right click on the default Virtual Server and choose Properties.
Click on the "Messages" tab and enter the mail server of your ISP in the box "Forward all mail with unresolved recipients to host:".

Again apply/ok out.

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cashcompAuthor Commented:
sorry about the delays here.  Telus was having some internal issues regarding the local pipe.  looks like it's fixed now.  and your assistance worked like a charm.  simple enough instructions for this idiot to get it up and running smoothly.

thank you for your help, you definitely earned the points.

cashcomp
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.