Problem in deploying EJB to weblogic 8.1 from eclipse

hi,
i have developed an EJB as mentioned in the tutorial of eclipse EJB Development section. I have created a TraderBean and generated the rest of the classes and interface classes and deployment descriptor through XDoclet and deployed the bean through eclipse on bea weblogic, but the problem is, it doesnt deploy the bean with the JNDI name i assigned it in the deployment descriptor, bea weblogic assigns the JNDI name by itself.

I have also developed my client which calls my ejb bean but it couldnt lookup my EJB because it isnt deployed with the JNDI name i gave it.

How can i make the ejb deployed to bea with the my JNDI name?? Below i am attaching the weblogic-ejb-jar.xml and my client lookup methods.

Please reply ASAP

Thanks
Mak

**********weblogic-ejb-jar.xml**************
<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE weblogic-ejb-jar PUBLIC "-//BEA Systems, Inc.//DTD WebLogic 6.0.0 EJB//EN" "http://www.bea.com/servers/wls600/dtd/weblogic-ejb-jar.dtd">

<weblogic-ejb-jar>
 <description><![CDATA[Generated by XDoclet]]></description>
   <weblogic-enterprise-bean>
      <ejb-name>Trader</ejb-name>
      <stateless-session-descriptor>
      </stateless-session-descriptor>
      <reference-descriptor>
      </reference-descriptor>

      <jndi-name>firstEJB</jndi-name>
   </weblogic-enterprise-bean>
<!--
To add enterprise beans that you have deployment descriptor info for, add
a file to your XDoclet merge directory called weblogic-enterprise-beans.xml that contains
the <weblogic-enterprise-bean></weblogic-enterprise-bean> markup for those beans.
-->

</weblogic-ejb-jar>
********************************************

********** lookuphome***********************
//url is "t3://localhost:7001"

private TraderHome lookupHome() throws NamingException {
        Context ctx = getInitialContext();
        try {
           
          Object home = (TraderHome) ctx.lookup("firstEJB");
          // also tried ctx.lookup("ejb/firstEJB")
        
          return (TraderHome) PortableRemoteObject.narrow(home, TraderHome.class);
          //return (TraderHome) narrow(home, TraderHome.class);
         
        } catch (NamingException ne) {
          log("The client was unable to lookup the EJBHome.  Please make sure ");
          log("that you have deployed the ejb with the JNDI name "+
            JNDI_NAME+" on the WebLogic server at "+url);
          throw ne;
        }
    }


private Context getInitialContext() throws NamingException {
        try {
            // Get an InitialContext
            Hashtable h = new Hashtable();
            h.put(Context.INITIAL_CONTEXT_FACTORY,"weblogic.jndi.WLInitialContextFactory");
            h.put(Context.PROVIDER_URL, url);
            return new InitialContext(h);
          } catch (NamingException ne) {
            log("We were unable to get a connection to the WebLogic server at "+url);
            log("Please make sure that the server is running.");
            throw ne;
          }
    }
   
*******************************
imation3mAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ECollinCommented:
Hi,

are you sure that it's your EJB that is deployed inside weblogic ?

What is the jndi name that you see in your server for your EJB ?

Emmanuel

imation3mAuthor Commented:
Following is the console message when i start the server:

<Jul 6, 2005 1:56:22 PM PDT> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) Client VM Version 1.4.2_05-b04 from Sun Microsystems Inc.>
<Jul 6, 2005 1:56:23 PM PDT> <Info> <Configuration Management> <BEA-150016> <This server is being started as the administration server.>
<Jul 6, 2005 1:56:23 PM PDT> <Info> <Management> <BEA-141107> <Version: WebLogic Server 8.1 SP4  Mon Nov 29 16:21:29 PST 2004 471647
WebLogic XMLX Module 8.1 SP4  Mon Nov 29 16:21:29 PST 2004 471647 > 
<Jul 6, 2005 1:56:24 PM PDT> <Notice> <Management> <BEA-140005> <Loading domain configuration from configuration repository at /home/mahmood/Softwares/bea/weblogic81/server/bin/applications/config.xml.>
<Jul 6, 2005 1:56:27 PM PDT> <Notice> <Log Management> <BEA-170019> <The server log file /home/mahmood/Softwares/bea/weblogic81/server/bin/applications/myserver/myserver.log is opened. All server side log events will be written to this file.>
<Jul 6, 2005 1:56:30 PM PDT> <Notice> <Security> <BEA-090082> <Security initializing using security realm myrealm.>
<Jul 6, 2005 1:56:30 PM PDT> <Notice> <WebLogicServer> <BEA-000327> <Starting WebLogic Admin Server "myserver" for domain "mydomain">
<Jul 6, 2005 1:56:39 PM PDT> <Warning> <EJB> <BEA-010212> <The EJB 'Trader(Application: _appsdir_firstEJB_jar, EJBComponent: firstEJB)' contains at least one method without an explicit transaction attribute setting. The default transaction attribute of Supports will be used for the following methods: remote[sell(java.lang.String,int), buy(java.lang.String,int)]  >
<Jul 6, 2005 1:56:40 PM PDT> <Error> <Socket> <BEA-000438> <Unable to load performance pack. Using Java I/O instead. Please ensure that libmuxer library is in :'/home/mahmood/Softwares/bea/jdk142_05/bin:/home/mahmood/Softwares/bea/weblogic81/bin:/home/mahmood/Softwares/bea/weblogic81/server/bin'

<Jul 6, 2005 1:56:40 PM PDT> <Notice> <WebLogicServer> <BEA-000331> <Started WebLogic Admin Server "myserver" for domain "mydomain" running in Development Mode>
<Jul 6, 2005 1:56:40 PM PDT> <Notice> <WebLogicServer> <BEA-000360> <Server started in RUNNING mode>
<Jul 6, 2005 1:56:40 PM PDT> <Notice> <WebLogicServer> <BEA-000355> <Thread "ListenThread.Default" listening on port 7001, ip address *.*>
**********************************************************

The JNDI name in the JNDI Tree of weblogic is:
Bind Name:      _appsdir_firstEJB_jarfirstEJBTrader_EO
ECollinCommented:

in the jndi tree you should see a node for "firstEJB"
_appsdir_firstEJB_jarfirstEJBTrader_EO is just a technical component automaticaly bound by weblogic for your EJB.
No problem, you should access your EJB with "firstEJB"

Can you give us the exception trace occuring when your client tries to access the EJB please.

Emmanuel
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

imation3mAuthor Commented:
I dont see any node "firstEJB" in the JNDI tree. (i think eclipse no deploying in the way weblogic requires, is that the case?)

Following is the console message when i run the client

The client was unable to lookup the EJBHome.  Please make sure
that you have deployed the ejb with the JNDI name firstEJB on the WebLogic server at t3://localhost:7001
Unable to look up the beans home: While trying to lookup 'ejb.firstEJB' didn't find subcontext 'ejb' Resolved
***************************************************************************

Following is the console messages when i start the weblogic server from within eclipse

<Jul 7, 2005 8:45:01 AM PDT> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) Client VM Version 1.4.2_05-b04 from Sun Microsystems Inc.>
<Jul 7, 2005 8:45:02 AM PDT> <Info> <Configuration Management> <BEA-150016> <This server is being started as the administration server.>
<Jul 7, 2005 8:45:02 AM PDT> <Info> <Management> <BEA-141107> <Version: WebLogic Server 8.1 SP4  Mon Nov 29 16:21:29 PST 2004 471647
WebLogic XMLX Module 8.1 SP4  Mon Nov 29 16:21:29 PST 2004 471647 > 
<Jul 7, 2005 8:45:03 AM PDT> <Notice> <Management> <BEA-140005> <Loading domain configuration from configuration repository at /home/mahmood/Softwares/bea/weblogic81/server/bin/applications/config.xml.>
<Jul 7, 2005 8:45:07 AM PDT> <Notice> <Log Management> <BEA-170019> <The server log file /home/mahmood/Softwares/bea/weblogic81/server/bin/applications/myserver/myserver.log is opened. All server side log events will be written to this file.>
<Jul 7, 2005 8:45:09 AM PDT> <Notice> <Security> <BEA-090082> <Security initializing using security realm myrealm.>
<Jul 7, 2005 8:45:09 AM PDT> <Notice> <WebLogicServer> <BEA-000327> <Starting WebLogic Admin Server "myserver" for domain "mydomain">
<Jul 7, 2005 8:45:19 AM PDT> <Warning> <EJB> <BEA-010212> <The EJB 'Trader(Application: _appsdir_firstEJB_jar, EJBComponent: firstEJB)' contains at least one method without an explicit transaction attribute setting. The default transaction attribute of Supports will be used for the following methods: remote[sell(java.lang.String,int), buy(java.lang.String,int)]  >
<Jul 7, 2005 8:45:20 AM PDT> <Error> <Socket> <BEA-000438> <Unable to load performance pack. Using Java I/O instead. Please ensure that libmuxer library is in :'/home/mahmood/Softwares/bea/jdk142_05/bin:/home/mahmood/Softwares/bea/weblogic81/bin:/home/mahmood/Softwares/bea/weblogic81/server/bin'

<Jul 7, 2005 8:45:20 AM PDT> <Notice> <WebLogicServer> <BEA-000331> <Started WebLogic Admin Server "myserver" for domain "mydomain" running in Development Mode>
<Jul 7, 2005 8:45:20 AM PDT> <Notice> <WebLogicServer> <BEA-000360> <Server started in RUNNING mode>
<Jul 7, 2005 8:45:20 AM PDT> <Notice> <WebLogicServer> <BEA-000355> <Thread "ListenThread.Default" listening on port 7001, ip address *.*>
**************************************************************************
ECollinCommented:
The error message is after the lookup on the "ejb.firstEJB" bound name. Do you have the same message with "firstEJB" ?

imation3mAuthor Commented:
with firstEJB message is:

The client was unable to lookup the EJBHome.  Please make sure
that you have deployed the ejb with the JNDI name firstEJB on the WebLogic server at t3://localhost:7001
Unable to look up the beans home: Unable to resolve 'firstEJB' Resolved
ECollinCommented:
How did you deploy your ejb (admin console, auto deployment...) ?

Emmanuel
imation3mAuthor Commented:
Autodeployment through MyEclipse
ECollinCommented:
can you give us complete ejb-jar.xml and weblogic-ejb-jar.xml please.

Emmanuel
imation3mAuthor Commented:
*****************ejb-jar.xml******************************(it is present in META-INF folder)
<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE ejb-jar PUBLIC "-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 2.0//EN" "http://java.sun.com/dtd/ejb-jar_2_0.dtd">

<ejb-jar >

   <description><![CDATA[No Description.]]></description>
   <display-name>Generated by XDoclet</display-name>

   <enterprise-beans>

      <!-- Session Beans -->
      <session >
         <description><![CDATA[Description for Trader]]></description>
         <display-name>Name for Trader</display-name>

         <ejb-name>Trader</ejb-name>

         <home>com.bankislami.Trader.interfaces.TraderHome</home>
         <remote>com.bankislami.Trader.interfaces.Trader</remote>
         <ejb-class>com.bankislami.Trader.ejb.TraderSession</ejb-class>
         <session-type>Stateless</session-type>
         <transaction-type>Container</transaction-type>

      </session>

     <!--
       To add session beans that you have deployment descriptor info for, add
       a file to your XDoclet merge directory called session-beans.xml that contains
       the <session></session> markup for those beans.
     -->

      <!-- Entity Beans -->
     <!--
       To add entity beans that you have deployment descriptor info for, add
       a file to your XDoclet merge directory called entity-beans.xml that contains
       the <entity></entity> markup for those beans.
     -->

      <!-- Message Driven Beans -->
     <!--
       To add message driven beans that you have deployment descriptor info for, add
       a file to your XDoclet merge directory called message-driven-beans.xml that contains
       the <message-driven></message-driven> markup for those beans.
     -->

   </enterprise-beans>

   <!-- Relationships -->

   <!-- Assembly Descriptor -->
     <!--
       To specify your own assembly descriptor info here, add a file to your
       XDoclet merge directory called assembly-descriptor.xml that contains
       the <assembly-descriptor></assembly-descriptor> markup.
     -->

   <assembly-descriptor >
     <!--
       To specify additional security-role elements, add a file in the merge
       directory called ejb-security-roles.xml that contains them.
     -->

   <!-- method permissions -->
     <!--
       To specify additional method-permission elements, add a file in the merge
       directory called ejb-method-permissions.ent that contains them.
     -->

   <!-- finder permissions -->

   <!-- transactions -->
     <!--
       To specify additional container-transaction elements, add a file in the merge
       directory called ejb-container-transaction.ent that contains them.
     -->

   <!-- finder transactions -->

     <!--
       To specify an exclude-list element, add a file in the merge directory
       called ejb-exclude-list.xml that contains it.
     -->
   </assembly-descriptor>

</ejb-jar>
***************************************************************

**********weblogic-ejb-jar********************************(it is present at src level)

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE weblogic-ejb-jar PUBLIC "-//BEA Systems, Inc.//DTD WebLogic 6.0.0 EJB//EN" "http://www.bea.com/servers/wls600/dtd/weblogic-ejb-jar.dtd">

<weblogic-ejb-jar>
 <description><![CDATA[Generated by XDoclet]]></description>
   <weblogic-enterprise-bean>
      <ejb-name>Trader</ejb-name>
      <stateless-session-descriptor>
      </stateless-session-descriptor>
      <reference-descriptor>
      </reference-descriptor>

      <jndi-name>firstEJB</jndi-name>
   </weblogic-enterprise-bean>
<!--
To add enterprise beans that you have deployment descriptor info for, add
a file to your XDoclet merge directory called weblogic-enterprise-beans.xml that contains
the <weblogic-enterprise-bean></weblogic-enterprise-bean> markup for those beans.
-->

</weblogic-ejb-jar>
********************************
ECollinCommented:
Your DD seem to be OK.

do you get an error message from weblogic when deploying your ejb ?. (Be sure to have your logging threshold set to INFO)

Emmanuel
imation3mAuthor Commented:
no error message, it says sucessfully deployed. but when i try to open the xml file by clicking on their name in the descriptor tab under EJB Modules node -> _appsdir_firstEJB_jar, it gives me the error message "Could not read descriptor file." for both the xml files
imation3mAuthor Commented:
and when i click on the "Testing" tab under the same EJB Modules node it gives me the following msg:

This page allows you to test remote EJBs to see whether they can be found via their JNDI names.

There are no EJBs defined in this module.
ECollinCommented:
ok,

the jar file should not be ok according to the EJB spécification.
Be sure to have both deployment descriptors in the META-INF directory at the root of the jar file. (be careful, names are case sensitive)

Can you give us the content of the jar file please. (just a list of files and dirs)
Emmanuel

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
imation3mAuthor Commented:
i dont know where i can set the "logging threshold to INFO" can u please tell me, i am new to weblogic app server
imation3mAuthor Commented:
ok i found the "Stdout Severity Threshold" and i changed it to INFO, following is wat i get when i start the server:

<Jul 7, 2005 2:59:25 PM PDT> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) Client VM Version 1.4.2_05-b04 from Sun Microsystems Inc.>
<Jul 7, 2005 2:59:26 PM PDT> <Info> <Configuration Management> <BEA-150016> <This server is being started as the administration server.>
<Jul 7, 2005 2:59:26 PM PDT> <Info> <Management> <BEA-141107> <Version: WebLogic Server 8.1 SP4  Mon Nov 29 16:21:29 PST 2004 471647
WebLogic XMLX Module 8.1 SP4  Mon Nov 29 16:21:29 PST 2004 471647 > 
<Jul 7, 2005 2:59:26 PM PDT> <Notice> <Management> <BEA-140005> <Loading domain configuration from configuration repository at /home/mahmood/Softwares/bea/weblogic81/server/bin/applications/config.xml.>
<Jul 7, 2005 2:59:29 PM PDT> <Notice> <Log Management> <BEA-170019> <The server log file /home/mahmood/Softwares/bea/weblogic81/server/bin/applications/myserver/myserver.log is opened. All server side log events will be written to this file.>
<Jul 7, 2005 2:59:30 PM PDT> <Info> <Security> <BEA-090149> <The server security configuration has been loaded from /home/mahmood/Softwares/bea/weblogic81/server/lib/SecurityDefaultConfig.xml>
<Jul 7, 2005 2:59:31 PM PDT> <Info> <Security> <BEA-090516> <The RoleMapper provider has preexisting LDAP data.>
<Jul 7, 2005 2:59:31 PM PDT> <Info> <Security> <BEA-090516> <The Authorizer provider has preexisting LDAP data.>
<Jul 7, 2005 2:59:31 PM PDT> <Info> <Security> <BEA-090516> <The Authenticator provider has preexisting LDAP data.>
<Jul 7, 2005 2:59:31 PM PDT> <Info> <Security> <BEA-090093> <No pre-WLS 8.1 Keystore providers are configured for server myserver for security realm myrealm.>
<Jul 7, 2005 2:59:31 PM PDT> <Notice> <Security> <BEA-090082> <Security initializing using security realm myrealm.>
<Jul 7, 2005 2:59:31 PM PDT> <Notice> <WebLogicServer> <BEA-000327> <Starting WebLogic Admin Server "myserver" for domain "mydomain">
<Jul 7, 2005 2:59:31 PM PDT> <Info> <WebLogicServer> <BEA-000214> <WebLogic Server "myserver" version:
WebLogic Server 8.1 SP4  Mon Nov 29 16:21:29 PST 2004 471647
WebLogic XMLX Module 8.1 SP4  Mon Nov 29 16:21:29 PST 2004 471647  (c) 1995, 1996, 1997, 1998 WebLogic, Inc.
 (c) 1999, 2000, 2001 BEA Systems, Inc.>
<Jul 7, 2005 2:59:31 PM PDT> <Info> <WebLogicServer> <BEA-000215> <Loaded License : /home/mahmood/Softwares/bea/license.bea>
<Jul 7, 2005 2:59:31 PM PDT> <Info> <RJVM> <BEA-000570> <Network Configuration for Channel "myserver"
 Listen Address             *
 Public Address             N/A
 Http Enabled             true
 Tunneling Enabled       false
 Outbound Enabled       false
 Admin Traffic Enabled       true>
<Jul 7, 2005 2:59:33 PM PDT> <Info> <XML> <BEA-130036> <Initializing XMLRegistry.>
<Jul 7, 2005 2:59:33 PM PDT> <Info> <JDBC> <BEA-001135> <Initializing the JDBC service.>
<Jul 7, 2005 2:59:33 PM PDT> <Info> <JDBC> <BEA-001137> <Initialization complete.>
<Jul 7, 2005 2:59:33 PM PDT> <Info> <Connector> <BEA-190000> <Initializing J2EE Connector Service>
<Jul 7, 2005 2:59:33 PM PDT> <Info> <Connector> <BEA-190001> <J2EE Connector Service initialized successfully>
<Jul 7, 2005 2:59:33 PM PDT> <Info> <IIOP> <BEA-002014> <IIOP subsystem enabled.>
<Jul 7, 2005 2:59:34 PM PDT> <Info> <JMS> <BEA-040090> <Deployed 5 default connection factories.>
<Jul 7, 2005 2:59:34 PM PDT> <Info> <JMS> <BEA-040305> <JMS service is initialized and in standby mode.>
<Jul 7, 2005 2:59:34 PM PDT> <Info> <HTTP> <BEA-101128> <Initializing HTTP services.>
<Jul 7, 2005 2:59:34 PM PDT> <Info> <HTTP> <BEA-101133> <Initializing Web server myserver.>
<Jul 7, 2005 2:59:34 PM PDT> <Info> <HTTP> <BEA-101052> <[HTTP myserver] Initialized>
<Jul 7, 2005 2:59:34 PM PDT> <Info> <HTTP> <BEA-101135> <myserver is the default Web server.>
<Jul 7, 2005 2:59:34 PM PDT> <Info> <J2EE> <BEA-160037> <J2EE service initializing.>
<Jul 7, 2005 2:59:35 PM PDT> <Info> <Deployer> <BEA-149207> <Initializing.>
<Jul 7, 2005 2:59:36 PM PDT> <Info> <Deployer> <BEA-149059> <Module console of application console is transitioning from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149060> <Module console of application console successfully transitioned from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149059> <Module uddi of application uddi is transitioning from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149060> <Module uddi of application uddi successfully transitioned from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149059> <Module uddiexplorer of application uddiexplorer is transitioning from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149060> <Module uddiexplorer of application uddiexplorer successfully transitioned from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149059> <Module wl_management_internal1 of application wl_management_internal1 is transitioning from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149060> <Module wl_management_internal1 of application wl_management_internal1 successfully transitioned from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149059> <Module wl_management_internal2 of application wl_management_internal2 is transitioning from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149060> <Module wl_management_internal2 of application wl_management_internal2 successfully transitioned from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149059> <Module console of application console is transitioning from prepared to active on server myserver.>
<Jul 7, 2005 2:59:37 PM PDT> <Info> <Deployer> <BEA-149060> <Module console of application console successfully transitioned from prepared to active on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <HTTP> <BEA-101047> <[ServletContext(id=10514061,name=console,context-path=/console)] WebServiceServlet: init>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149059> <Module uddi of application uddi is transitioning from prepared to active on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149060> <Module uddi of application uddi successfully transitioned from prepared to active on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <HTTP> <BEA-101047> <[ServletContext(id=32879502,name=uddi,context-path=/uddi)] WebServiceServlet: init>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149059> <Module uddiexplorer of application uddiexplorer is transitioning from prepared to active on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149060> <Module uddiexplorer of application uddiexplorer successfully transitioned from prepared to active on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <HTTP> <BEA-101047> <[ServletContext(id=22007572,name=uddiexplorer,context-path=/uddiexplorer)] WebServiceServlet: init>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149059> <Module wl_management_internal1 of application wl_management_internal1 is transitioning from prepared to active on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149060> <Module wl_management_internal1 of application wl_management_internal1 successfully transitioned from prepared to active on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <HTTP> <BEA-101047> <[ServletContext(id=5185929,name=wl_management_internal1,context-path=/wl_management_internal1)] WebServiceServlet: init>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149059> <Module wl_management_internal2 of application wl_management_internal2 is transitioning from prepared to active on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149060> <Module wl_management_internal2 of application wl_management_internal2 successfully transitioned from prepared to active on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <HTTP> <BEA-101047> <[ServletContext(id=7655982,name=wl_management_internal2,context-path=/wl_management_internal2)] WebServiceServlet: init>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149208> <Initialization Complete.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <JTA> <BEA-110441> <Opening transaction log with driver version "j1.0" and synchronous write policy "Cache-Flush". For information on synchronous write policies, refer to the weblogic.management.configuration.ServerMBean javadoc or console online help.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <JDBC> <BEA-001138> <Resuming the JDBC service.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <JDBC> <BEA-001140> <Resume complete.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <JMS> <BEA-040108> <User connection factory "DefaultXAConnectionFactory" is started.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <JMS> <BEA-040108> <User connection factory "QueueConnectionFactory" is started.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <JMS> <BEA-040108> <User connection factory "MessageDrivenBeanConnectionFactory" is started.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <JMS> <BEA-040108> <User connection factory "DefaultConnectionFactory" is started.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <JMS> <BEA-040108> <User connection factory "TopicConnectionFactory" is started.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <JMS> <BEA-040306> <JMS service is active now.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <HTTP> <BEA-101129> <Initializing the Web application container.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <HTTP> <BEA-101238> <HTTP log rotation is size based for the Web server: myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <HTTP> <BEA-101051> <[HTTP myserver] started>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <WebService> <BEA-220031> <The server does not support reliable SOAP messaging.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <WebService> <BEA-220027> <Web Service reliable agents are started on the server.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149209> <Resuming.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <HTTP> <BEA-101133> <Initializing Web server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <Deployer> <BEA-149059> <Module firstEJB of application _appsdir_firstEJB_jar is transitioning from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:38 PM PDT> <Info> <EJB> <BEA-010008> <EJB Deploying file: firstEJB.jar>
<Jul 7, 2005 2:59:39 PM PDT> <Warning> <EJB> <BEA-010212> <The EJB 'Trader(Application: _appsdir_firstEJB_jar, EJBComponent: firstEJB)' contains at least one method without an explicit transaction attribute setting. The default transaction attribute of Supports will be used for the following methods: remote[sell(java.lang.String,int), buy(java.lang.String,int)]  >
<Jul 7, 2005 2:59:39 PM PDT> <Info> <Deployer> <BEA-149060> <Module firstEJB of application _appsdir_firstEJB_jar successfully transitioned from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:39 PM PDT> <Info> <Deployer> <BEA-149059> <Module firstEJB of application _appsdir_firstEJB_jar is transitioning from prepared to active on server myserver.>
<Jul 7, 2005 2:59:39 PM PDT> <Info> <EJB> <BEA-010009> <EJB Deployed EJB with JNDI name firstEJB.>
<Jul 7, 2005 2:59:39 PM PDT> <Info> <Deployer> <BEA-149060> <Module firstEJB of application _appsdir_firstEJB_jar successfully transitioned from prepared to active on server myserver.>
<Jul 7, 2005 2:59:39 PM PDT> <Info> <Deployer> <BEA-149210> <Resumed.>
<Jul 7, 2005 2:59:39 PM PDT> <Info> <Management> <BEA-141187> <Java system properties are defined as follows:
bea.home = /home/mahmood/Softwares/bea
file.encoding = UTF-8
file.encoding.pkg = sun.io
file.separator = /
java.awt.graphicsenv = sun.awt.X11GraphicsEnvironment
java.awt.printerjob = sun.print.PSPrinterJob
java.class.path = /home/mahmood/Softwares/bea/jdk142_05/lib/tools.jar:/home/mahmood/Softwares/bea/weblogic81/lib/weblogic_sp.jar:/home/mahmood/Softwares/bea/weblogic81/lib/weblogic.jar:/home/mahmood/Softwares/bea/weblogic81/server/lib/weblogic_sp.jar:/home/mahmood/Softwares/bea/weblogic81/server/lib/weblogic.jar
java.class.version = 48.0
java.endorsed.dirs = /home/mahmood/Softwares/bea/jdk142_05/jre/lib/endorsed
java.ext.dirs = /home/mahmood/Softwares/bea/jdk142_05/jre/lib/ext
java.home = /home/mahmood/Softwares/bea/jdk142_05/jre
java.io.tmpdir = /tmp
java.library.path = /home/mahmood/Softwares/bea/jdk142_05/bin:/home/mahmood/Softwares/bea/weblogic81/bin:/home/mahmood/Softwares/bea/weblogic81/server/bin
java.naming.factory.initial = weblogic.jndi.WLInitialContextFactory
java.naming.factory.url.pkgs = weblogic.jndi.factories:weblogic.corba.j2ee.naming.url
java.protocol.handler.pkgs = weblogic.utils|weblogic.utils|weblogic.net
java.runtime.name = Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version = 1.4.2_05-b04
java.specification.name = Java Platform API Specification
java.specification.vendor = Sun Microsystems Inc.
java.specification.version = 1.4
java.util.prefs.PreferencesFactory = java.util.prefs.FileSystemPreferencesFactory
java.vendor = Sun Microsystems Inc.
java.vendor.url = http://java.sun.com/
java.vendor.url.bug = http://java.sun.com/cgi-bin/bugreport.cgi
java.version = 1.4.2_05
java.vm.info = mixed mode
java.vm.name = Java HotSpot(TM) Client VM
java.vm.specification.name = Java Virtual Machine Specification
java.vm.specification.vendor = Sun Microsystems Inc.
java.vm.specification.version = 1.0
java.vm.vendor = Sun Microsystems Inc.
java.vm.version = 1.4.2_05-b04
javax.rmi.CORBA.PortableRemoteObjectClass = weblogic.iiop.PortableRemoteObjectDelegateImpl
javax.rmi.CORBA.UtilClass = weblogic.iiop.UtilDelegateImpl
javax.xml.rpc.ServiceFactory = weblogic.webservice.core.rpc.ServiceFactoryImpl
javax.xml.soap.MessageFactory = weblogic.webservice.core.soap.MessageFactoryImpl
jmx.implementation.name = JMX RI
jmx.implementation.vendor = Sun Microsystems
jmx.implementation.version = 1.0
jmx.specification.name = Java Management Extensions
jmx.specification.vendor = Sun Microsystems
jmx.specification.version = 1.0 Final Release
org.omg.CORBA.ORBClass = weblogic.corba.orb.ORB
org.omg.CORBA.ORBSingletonClass = weblogic.corba.orb.ORB
org.xml.sax.driver = weblogic.apache.xerces.parsers.SAXParser
org.xml.sax.parser = weblogic.xml.jaxp.RegistryParser
os.arch = i386
os.name = Linux
os.version = 2.6.8-24-default
path.separator = :
sun.arch.data.model = 32
sun.boot.class.path = /home/mahmood/Softwares/bea/jdk142_05/jre/lib/rt.jar:/home/mahmood/Softwares/bea/jdk142_05/jre/lib/i18n.jar:/home/mahmood/Softwares/bea/jdk142_05/jre/lib/sunrsasign.jar:/home/mahmood/Softwares/bea/jdk142_05/jre/lib/jsse.jar:/home/mahmood/Softwares/bea/jdk142_05/jre/lib/jce.jar:/home/mahmood/Softwares/bea/jdk142_05/jre/lib/charsets.jar:/home/mahmood/Softwares/bea/jdk142_05/jre/classes
sun.boot.library.path = /home/mahmood/Softwares/bea/jdk142_05/jre/lib/i386
sun.cpu.endian = little
sun.io.unicode.encoding = UnicodeLittle
sun.os.patch.level = unknown
user.country = US
user.dir = /home/mahmood/Softwares/bea/weblogic81/server/bin/applications
user.home = /home/mahmood
user.language = en
user.name = mahmood
user.timezone = US/Pacific
vde.home = /home/mahmood/Softwares/bea/weblogic81/server/bin/applications/myserver/ldap
weblogic.Name = myserver
weblogic.RootDirectory = /home/mahmood/Softwares/bea/weblogic81/server/bin/applications
weblogic.management.discover = false
weblogic.mbeanLegalClause.ByPass = false

<Jul 7, 2005 2:59:40 PM PDT> <Info> <Management> <BEA-141052> <The application poller has started for the development server.>
<Jul 7, 2005 2:59:40 PM PDT> <Error> <Socket> <BEA-000438> <Unable to load performance pack. Using Java I/O instead. Please ensure that libmuxer library is in :'/home/mahmood/Softwares/bea/jdk142_05/bin:/home/mahmood/Softwares/bea/weblogic81/bin:/home/mahmood/Softwares/bea/weblogic81/server/bin'

<Jul 7, 2005 2:59:40 PM PDT> <Info> <Socket> <BEA-000440> <NativeIO Disabled. Using Java I/O>
<Jul 7, 2005 2:59:40 PM PDT> <Notice> <WebLogicServer> <BEA-000331> <Started WebLogic Admin Server "myserver" for domain "mydomain" running in Development Mode>
<Jul 7, 2005 2:59:40 PM PDT> <Notice> <WebLogicServer> <BEA-000360> <Server started in RUNNING mode>
<Jul 7, 2005 2:59:40 PM PDT> <Notice> <WebLogicServer> <BEA-000355> <Thread "ListenThread.Default" listening on port 7001, ip address *.*>
<Jul 7, 2005 2:59:40 PM PDT> <Info> <Management> <BEA-140009> <Configuration changes for the domain have been saved to the repository.>
<Jul 7, 2005 2:59:40 PM PDT> <Info> <Configuration Management> <BEA-150007> <The booted configuration /home/mahmood/Softwares/bea/weblogic81/server/bin/applications/config.xml has been backed up at /home/mahmood/Softwares/bea/weblogic81/server/bin/applications/config.xml.booted.>
<Jul 7, 2005 3:01:37 PM PDT> <Info> <HTTP> <BEA-101047> <[ServletContext(id=10514061,name=console,context-path=/console)] actions: init>
<Jul 7, 2005 3:01:39 PM PDT> <Info> <WebLogicServer> <BEA-000213> <Adding address: 0:0:0:0:0:0:0:1 to licensed client list>
imation3mAuthor Commented:
when i turned on the Stdout Severity Threshold to "INFO" and corrected the location of weblogic jar to META-INF
the Testing tab under EJB Module shows me the message " The EJB Trader has been tested successfully with a
JNDI name of firstEJB" but in the JNDI tree it gives shows me both "_appsdir_firstEJB_jarfirstEJBTrader_EO" and "firstEJB" under the myserver node
but when i lookup from client its gives me the same message :

The client was unable to lookup the EJBHome.  Please make sure
that you have deployed the ejb with the JNDI name firstEJB on the WebLogic server at t3://localhost:7001
Unable to look up the beans home: While trying to lookup 'ejb.firstEJB' didn't find subcontext 'ejb' Resolved

*************
heres the jar structure:

com/bankislami/Trader/ejb/TraderBean.class
com/bankislami/Trader/ejb/TraderSession.class
com/bankislami/Trader/interfaces/Trader.class
com/bankislami/Trader/interfaces/TraderHome.class
META-INF/ejb-jar.xml
META-INF/MANIFEST.MF
META-INF/weblogic-ejb-jar.xml
ECollinCommented:
As you can see in the log your EJB is deployed !

<Deployer> <BEA-149060> <Module firstEJB of application _appsdir_firstEJB_jar successfully transitioned from unprepared to prepared on server myserver.>
<Jul 7, 2005 2:59:39 PM PDT> <Info> <Deployer> <BEA-149059> <Module firstEJB of application _appsdir_firstEJB_jar is transitioning from prepared to active on server myserver.>
<Jul 7, 2005 2:59:39 PM PDT> <Info> <EJB> <BEA-010009> <EJB Deployed EJB with JNDI name firstEJB.>
<Jul 7, 2005 2:59:39 PM PDT> <Info> <Deployer> <BEA-149060> <Module firstEJB of application _appsdir_firstEJB_jar successfully transitioned from prepared to active on server myserver.>
<Jul 7, 2005 2:59:39 PM PDT> <Info> <Deployer> <BEA-149210> <Resumed.>

try again to connect to your ejb

Emmanuel
ECollinCommented:
don't use ejb.firstEJB but firstEJB !! in your lookup

Emmanuel
imation3mAuthor Commented:
yea its working when i use the name "firstEJB", but dont u think it shuld be under the ejb node in the JNDI tree
and not in the server node?

Thanks for the support guys, to whome i should give the points :D ?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java App Servers

From novice to tech pro — start learning today.