WMI Error 0X80070005 (Access is denied) from WBEMTEST

I would like to discover machine details using a tools (PlateSpin PowerP2V) that is based on WMI, but always i receive an error that the "Access is denied".
The machine that I would like discover as Win XP SP1 and Win XP SP2 the other, Firewall disabled,
WMI service is running, DCOM is enabled, RPC service is running, Remote Registry is running, File and Print Sharing for Microsoft Networks is enabled. Both are Virtual Machines in a VMware GSX server.

If I test the WMI with the command WBEMTEST from my main server (Win2003 Srv), I put the name of the machine
in the Namespace (i.e. \\TIMEAS\root\cimv2 ), and the appropriate credentials hostname\LocalAdmin and password
(the machine aren't in a domain).
When I click Connect I got the error message:
Number: 0x80070005
Facility:  Win32
Description: Access is denied

Any idea how the resolve this?
fpifferiniAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chalapaCommented:
check the following link
http://support.microsoft.com/default.aspx?scid=kb;en-us;884573
let me know the details


chalapathi
fpifferiniAuthor Commented:
I've tried the workaround suggested in the KB884573, but the problem persist.
(I don't have made a reboot of the machine...it's necessary?)

Do you know how to find the Fix proposed in this KB and how is named?
chalapaCommented:
Download windows xp post sp2 and update chek the following link

http://www.softpedia.com/get/System/OS-Enhancements/RyanVM-Windows-XP-Post-SP2-Update-Pack.shtml
chalapathi
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

sramesh2kCommented:
fpifferini,

Configuring the DCOMCNFG.EXE may be needed. See:
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/wmisdk/wmi/connecting_through_windows_firewall.asp

<quote>

The 0x80070005 error occurs when this privilege is not set.

</quote>
2hypeCommented:
Try this.

Click Start -- Run
Type wmimgmt.msc and press Enter

A window should open up.  In the left pane it should say WMI Control (Local).  Right click that and select properties.  Select the Security Tab.  Select the Root Folder and Press the Security Button.  Give appropriate Permissions.
fpifferiniAuthor Commented:
Tried the suggested task from  2hype   and    sramesh2k  but seams that they don't resolve the problem...
The permissions was OK.
I would like the try to apply the Post SP2 patches suggested by  chalapa  ,but I don't know how...
I've the  .cab file...what should I do?
2hypeCommented:
Try this.

Go to Start -- Control Panel -- Administrative tools -- Services

Scroll Down to Windows Managment Instrumentation and Stop the Service

Migratet to C:\Windows\System32\WBEM and delete the Repository Folder.

Go Back to Services and Start the Windows Managmet Instrumentation.  Wait about 10 min and the Respository Folder should be recreated.  Rebooting the Machine usually speeds the process up.

After the folder is recreated, try to see if it works now.

I had a program that collected Inventory From My computers through WMI and sometimes I would get an error trying to query the computer.  The above worked for me.
sramesh2kCommented:
Another comprehensive repair method for WMI

Repairing and re-registering the WMI:
http://windowsxp.mvps.org/repairwmi.htm

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fpifferiniAuthor Commented:
:-(
no way....repair WMI don't resolve my problem...
other suggestion?
fpifferiniAuthor Commented:
Find the solution:  MS KB307874
http://support.microsoft.com/default.aspx?scid=kb;en-us;307874

The Advanced Shared mode was not enabled.
sramesh2kCommented:
fpifferini,

Glad you found the answer. And thanks for posting back. You may request for a refund for this question, and convert this to PAQ.
LpragerCommented:
fpifferini,

Can you tell me where you found the "Advanced Shared" mode. It does not seem to be referenced in the article.
fpifferiniAuthor Commented:
LpragerCommented:
Yes, I could not find the term "Advanced Shared" in the document. It refers to Simple File Sharing and how to tun it off. Is this what you mean by "Advanced Shared"?
fpifferiniAuthor Commented:
If you disbale "Simple File Sharing" you have Advanced Sharing....
wardkraftmisCommented:
DialaFix http://www.softpedia.com/progDownload/Dial-a-fix-Download-27328.html
This is a handy little tool..  If your in MIS and not using this, you should be.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.