Windows 2000 Users get Blue Screen when trying to access published apps

Reference the thread below to see where I started:

http://www.experts-exchange.com/Networking/Citrix/Q_21479110.html


I have successfully rolled back my SP4 upgrade to SP3, and now I am having the original problem I was having after the initial SP4 upgrade.  All of my Windows XP Professional clients can load the Citrix apps through Program Neighborhood successfully, but the Windows 2000 clients only load blank blue backgrounds when they try to load any application.

I've tried updating a 2000 client to the latest ICA32 client software and get the same result.  I can load the applications successfuly from the Windows 2000 Servers hosting the Citrix applications, but not the Professional workstations that need to recieve them.  I already searched Citrix KB and found the following article:

http://support.citrix.com/kb/entry!default.jspa?categoryID=118&externalID=CTX107051&fromSearchPage=true

This does not solve my problem as I do not even have the indicated registry entry in the 2000 registry on the professional machines.  Further, I did make Widows Updates to HALF my 2000 workstations, but ALL of them cannot connect properly.

Help....I have an entrie firm out of business until I get this back up and I'm trying to avoid the $400.00 incident for Citrix support.

James
LVL 9
jamesreddyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ITDharamPresidentCommented:
Perhaps it is just a coincidence that all the 2000 machines are acting up.  How many are you talking about?

Have you tried deleting the users profile on your citrix servers and then have them reconnect?
jamesreddyAuthor Commented:
Got it.  It was a dumb mistake on my part.  The support document I listed aboive had to be done on the servers, not the clients.  Once I changed that registry entry, the 2000 Pro machines worked great.

As far as how many???  About 17...but all 5 XP boxes worked fine.  Very wierd error, but the above article fixed it.
ITDharamPresidentCommented:
Darned...I had actually thought to make sure you did it on the server.

Well, at least you got it fixed.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

itenginerdCommented:
As an uninterested EE member who happened to find this Q because I have the same problem, this looks like a classic for PAQ w/ refund.  Asker answered his own Q w/o help from experts...

$0.02 from the peanut gallery.

(j)
James
jamesreddyAuthor Commented:
No objection.  Meant to submit this to be closed anyway.
itenginerdCommented:
Oh, just for 2 more cents worth.., Citrix now has a patch out that may address this problem.  It's a Post-SP4 (Citrix SP4, not MS SP4) for Metaframe XP.  Can also be installed on CPS 3.0.  I think it was released mid-July, but I may be off a month.

Installing that hotfix solved our problems, which were very similar to jamesreddy's.

(j)
James
moduloCommented:
PAQed with points refunded (500)

modulo
Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.