IE 6 Unable to search using search engine

I have a Windows 2000 Pro Machine that is unable to search using any of the search engines.   I have determined that be problem is with a Browser helper object called wingyb.bho.  I have removed the registry entry for this but every time you reboot the entry comes back.  I have tried running Spybot, adaware, and Microsoft Spyware but nothing seams to remove it or even Identify it.

Any Ideas?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hi sbock100,

You can also use ToolbarCop
and remove that unwanted BHO.
Then go to start > run > msconfig , go to startup tab and disable all entries there except firewall or antivirus that you must have got. Restart the machine and see if that BHO comes up again. if not , enable each application in that startup tab and figure out the application responsible for this.

Use CWShredder
It is able to clean entries not found with the tools you used.
Leandro IaconoSenior Premier Field EngineerCommented:
You should try to remove the entry in safemode.

The reason why the entry keeps on poping up is that the worm (running in the background as you delete the entry) re-registers itself again and again ...

In safe mode, only vital processes and services run, and so when removing the registry key, the bug won't be running in the background, thus succesfully deleting the entry disabiling it on startup ...

I would also recommend deleting the file while in safe mode. The registry entry should state where the file is. If the full path isn't stated its becuase its in a system folder such as "system32". If all these fail, you can search for it using windows search tool.

If you find no results, make sure that you have disabled the "hide hideen and system files" in folder options...

If all of this fails, post back up and I'll try to guide you in a more specific way.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.