Cisco 837 Bridge / Spanning Tree Protocol question

Hi,
I have a new Cisco 837 ADSL/Router/Switch that I have connected to my SBC DSL internet account.  I have static IP and have setup connectivity to SBC's network by configuring a bridge to their network.  The configuration works and I have connectivity to the internet, but I'm noticing that the Cisco router is sending out a Spanning Tree Protocol message approximately every 2 seconds.  This doesn't seem like it would be a normal condition to me.  Is it?  I have attached my current config below as well as the STP message captured from ethereal.

My question is:  Is this normal or do I need changes to my config to correct this issue?

Thanks,

Kevin


Ethereal output:
==================================
      1 0.000000    Cisco_42:1d:14        Spanning-tree-(for-bridges)_00 STP      Conf. Root = 32768/00:13:c3:42:1d:14  Cost = 0  Port = 0x8006
      2 2.000133    Cisco_42:1d:14        Spanning-tree-(for-bridges)_00 STP      Conf. Root = 32768/00:13:c3:42:1d:14  Cost = 0  Port = 0x8006
      4 4.000129    Cisco_42:1d:14        Spanning-tree-(for-bridges)_00 STP      Conf. Root = 32768/00:13:c3:42:1d:14  Cost = 0  Port = 0x8006


Cisco 837 config:
===================================================

Current configuration : 1298 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname rwc-1
!
enable secret 5 $1$.48J$mNUuDQC0FIUV9USBYKyR51
!
no aaa new-model
ip subnet-zero
no ip routing
no ip domain lookup
ip dhcp excluded-address 10.11.12.1
!
ip dhcp pool dhcp-1
   network 10.11.12.0 255.255.255.0
   default-router 10.11.12.1
   dns-server 206.13.28.12 206.13.29.12
!
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
 no ip address
 no ip route-cache
 bridge-group 1
 hold-queue 100 out
!
interface ATM0
 no ip address
 no ip route-cache
 no atm ilmi-keepalive
 pvc 0/35
  encapsulation aal5snap
 !
 dsl operating-mode auto
 bridge-group 1
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 speed auto
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
ip classless
ip http server
no ip http secure-server
!
bridge 1 protocol ieee
!
line con 0
 no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
!
end
kzerberAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zometCommented:
Hi

Bridges use spanning tree to prevent network loops when there is more then 1 link between bridges .
if your lan has bridges ( switches , bridge routers , bridge on os etc)
it is best to keep the spanning tree.
it is also keep newrok out of loops if you connect 2 bridge nics one to each other ( not a smart move )
if your network is flat with no chance for loop you can disable the spanning tree.
set spantree  'portnumber'   disable

eran

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.