internal users cant access internet

Ok, I'm having trouble with my internal users trying to access the internet.
What could I be missing?  

Here is a diagram:
http://www.streetneeds.com/uploads/ot/Drawing1.jpg

In the gateway router, I'm allowing 192.168.1.0 to be NATTED

In the PIX, I'm allowing 192.168.3.0 to be NATTED.

dissolvedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JFrederick29Commented:
On the PIX, are you actually NAT'ing the 192.168.3.0 addresses to 192.168.1.0 addresses or are you passing them through with the same addresses using a static or NAT 0 ?  Is DNS setup correctly on your inside hosts?  Have you tried reaching a website via an IP address?  Can you post the config off the gateway router and PIX?
dissolvedAuthor Commented:
I cant access anything via IP from internal networks.


Internal router:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Internal_router
!
enable secret 5 $1$9Oi.$oYj0Q38ZGJSvMdzclwyQi.
!
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
ip ssh time-out 120
ip ssh authentication-retries 3
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.2.2 255.255.255.252
 full-duplex
description Connected to PIX
!
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Ethernet1/0
 ip address 192.168.3.1 255.255.255.0
 full-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip http server
ip pim bidir-enable
!
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password
 login
!
end

dissolvedAuthor Commented:
PIX:

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xIsrlcAkUmuvQSHs encrypted
passwd JjCY8dtQbv7delLq encrypted
hostname pix
domain-name spira
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_in permit icmp any interface outside echo-reply
access-list outside_in permit icmp any interface outside unreachable
access-list outbound_policy deny tcp any any eq ftp
access-list outbound_policy permit ip any any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 192.168.1.2 255.255.255.240 <-----connected to gateway
ip address inside 192.168.2.1 255.255.255.252  <------connected to internal router
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.3.0 255.255.255.0 0 0
access-group outside_in in interface outside
access-group outbound_policy in interface inside
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt noproxyarp inside
telnet 192.168.3.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 60
console timeout 0

terminal width 80

Cryptochecksum:dff7b6e2e53becd9c2deee61fc2d8e7a
: end
JFrederick29Commented:
You're missing a route on the PIX to the 192.168.3.0 subnet:

route inside 192.168.3.0 255.255.255.0 192.168.2.2

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dissolvedAuthor Commented:
thats right, the pix has to know how to get back to me. DUH!

Thanks for the help.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.