Seting Up SMTP on IIS with a dsl

I have Server 2003 pack 1
with IIS 6.0
with SBC DSL

I have an ap that automatically sends passwords through the smtp service when requested by customers.
I would like to know the correct settings for the "Default SMTP virtual server" needed to get the mail out of the Queue.

SBC Techs and the Application techs are of no help and it is driving me nuts 2 days later.

Robb Hueston

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Open IIS->Right Click SMTP Server Node->Properties->Delivery Tab->Outbound Security Button->Basic Authentication and give your username and password->OK->Advanced Button->In Smart Host give SMTP server name. The SMTP server name would depend on where you are. You can find it out here...
burckley3Author Commented:
When i try to enter>

Advanced Button->In Smart Host give SMTP server name
I get and error message that states

"Can not set smarthost to a local domain"

What server name are you trying to enter?
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

burckley3Author Commented:
Can you ping from the server?
burckley3Author Commented:
What else is there in the tab? Could you setup the outbound security? Click on the Domains under SMTP. What is listed there?
burckley3Author Commented:
Under the properties Tab (Default SMTP Virtual Server) you have tabs
General - Access - Messages - Delivery - LDAP routing - Security

I could setup Outbound Security

Click on the Domains under SMTP. What is listed there? >
Listed is (Merlin) which is the server name and
Delete and repeat the above process.

Next to the Smart Host there is a checkbox "Attempt direct ..." Make sure to uncheck that.
burckley3Author Commented:
I uninstalled and installed the SMTP server and set everything up from scratch.  
The mail now leaves the Queued folder but ends up in the badmail folder

Here is the message that i get in the Badmail folder when i convert to a .txt file

Merlin is my server name


From: postmaster@merlin
Date: Tue, 5 Jul 2005 17:10:30 -0500
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
X-DSNContext: 7ce717b1 - 1378 - 00000002 - C00402EF
Message-ID: <SxPpmrWkG00000003@merlin>
Subject: Delivery Status Notification (Failure)

This is a MIME-formatted message.  
Portions of this message may be unreadable without a MIME-capable mail program.

Content-Type: text/plain; charset=unicode-1-1-utf-7

This is an automatically generated Delivery Status Notification.

Delivery to the following recipients failed.

Content-Type: message/delivery-status

Reporting-MTA: dns;merlin
Received-From-MTA: dns;merlin
Arrival-Date: Tue, 5 Jul 2005 17:09:53 -0500

Final-Recipient: rfc822;
Action: failed
Status: 5.4.0

Content-Type: message/rfc822

Received: from mail pickup service by merlin with Microsoft SMTPSVC;
       Tue, 5 Jul 2005 17:09:53 -0500
From: <>
To: <>
Subject: Password Change Notification
Date: Tue, 5 Jul 2005 17:09:53 -0500
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
Message-ID: <MERLINsFCIo4JNp5tHY00000004@merlin>
X-OriginalArrivalTime: 05 Jul 2005 22:09:53.0859 (UTC) FILETIME=[4566E130:01C581AE]

Your password for accessing our web site has been changed to: gctsuisa.


It seems that either you don't have Smart Host or have Attempt Direct Delivery checked.
burckley3Author Commented:
After reconfiguring this a million times I figured out the solution.  You might keep this for future customers that have this problem.


I pinged my isp’s SMTP server ( to get the ip address.  []


In the Default SMTP server settings I made the following adjustments right clicking and going to the properties.

(Access Tab)


>check box for (Basic Authentication)

Default Domain set as



(Delivery Tab)

“Outbound Security button”

check box for (Basic Authentication)


user name and password


“Advanced Button”

Fully-qualified Domain name as


Smart Host was set as the

Smtp servers ip address in brackets



That was it …


Sending emails fine now.
PAQed with points (250) refunded

Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.