Linux installation - screen goes blank

I stole this computer from my grandmother and thought I'd install Linux. Why not learn a new thing?

CPU: Pentium III 450 MHZ
Motherboard: Microstar MS-6163
Display Adaptor: ATI 3D Rage pro

I tried to install a couple of Linux distributions on it: Red-Hat 9.0 and Mandrake 10.1

What happens on both Installations is:
1. I Get the first screen telling me to press <ENTER> to install.
2. The installation is telling me loading…. Whatever…
3. The screen does that 'pling' sound (like the one when switching to a 3D game mode).
4. I get a blank screen – end of story.

I tried to install it in all the other modes – text, expert, kernel etc… but nothing – same scenario.

Any Idea where to start looking?

Thanks!
eyal_baroukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

csgeekpyroCommented:
Your problem is that the installer is trying to load X11 (a complicated piece of hardware dependent code in itself) and something is going wrong.

You could try a gentoo (www.gentoo.org) install...it doesn't try to do anything like that until you actially try to set up X11.

Seriously though, I've used gentoo for years and one of the main draws for me is no klunky X11 based installer.  I get to do everything myself (using Stage1 anyway) and I really like having a mental log of everything done to my system.  As long as you read the install guide (if you want to use linux, you NEED to read documentation) installing gentoo is as painless (tho more interactive) as any other distro install with a klunky X11 installer like redhat/fedora/mdk.
Duncan RoeSoftware DeveloperCommented:
Slackware also installs without X - it even has choices of install flavour from "expert" all the way to "novice".
http://www.slackware.org
owensleftfootCommented:
He said he has tried the install in text mode - Xwindows has nothing to do with the problem.

When you get to your blank screen during the install, walk through the virtual terminals by holding down the alt key while trying the function keys from F1 to F6. You should be able to find out exactly what the problem is.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

rindiCommented:
When you startup the install CD, try passing the nofb (No Framebuffer) option, or similar. Look for something that sounds similar. Also give the noacpi option. It may look similar to this:

linux nofb noacpi

If I may make a suggestion, don't use RH9, this is an old and not anymore supported distro. It is better to use fedora-core 4, which is the successor and current version of RH9.

http://fedora.redhat.com/
eyal_baroukAuthor Commented:
Thanks owensleftfoot but "walk through the virtual terminals by holding down the alt key while trying the function keys from F1 to F6" didn't do anything not on mandrake nor RH.
eyal_baroukAuthor Commented:
Thanks rindi,
I took notice of your advice about RH-9.0 and will not use that dist.
So I am left with mandrake 10.1. which I tried to install again before I go to try the dists offterd by csgeekpyro and duncan_roe.

As you suggested, I typed:
linux nofb noacpi
and got the same result the - blank screen.
I even went and typed:
text nofb noacpi
(not that knew what I was doing...) but with the same result.

Maybe there is something seriously wrong with the computer's hardware.
Win-98 seems to work well on it though (previously installed).
rindiCommented:
With mandrake also try options like vgalo, expert, noapic, vga16, noauto.

And you could also try using a different jernel, like alt0 or alt1.
eyal_baroukAuthor Commented:
I tried:

expert noauto
text noauto

And all the rest of them - no go.
It goes loading alt0.....
and that's it.

What is jernel? What command do I need to type?

memtest went OK though. Just thought you might like to know :-)
Maybe I should return the machine to granny. Besides, I think she might be missing her mahjong.
Duncan RoeSoftware DeveloperCommented:
I would give Slackware a go first. It simply does not mess with the console. At least up to 10.0, it did not even offer a GUI install.
rindiCommented:
Jernel is a typo, sorry, it should read kernel. They are started with alt0 and alt1.
doomtrooperCommented:
boot option vga=ask

might help if the installer boots with framebuffer support
eyal_baroukAuthor Commented:
I tried all the options after vga=ask still nothing.

I am now trying slackware 10.1 but getting the blank screen again.

Just to make sure, should I run fdisk before I install it or is it part of the installation?
rindiCommented:
Are you using an LCD or a CRT monitor? Do you by any chance have another VGA card you could try this PC with? The distributions use their own version of fdisk during the installation.
Duncan RoeSoftware DeveloperCommented:
I downloaded and tested slackware 10.1 and AFAICS it leaves the monitor in standard VGA (DOS) mode. Ok I didn't actually invoke the monitor's menu to check refresh rates, I suppose I could if that would help.
How soon do you get the blank screen? Do you see the isolinux (boot) dialogue?
eyal_baroukAuthor Commented:
rindi,
I have tried a different VGA card and I still get the same thing. Now I'm looking for a P-III motherboard. Maybe that's where the problem lies.
Tried on both mandrake and slackware.

duncan_roe,
I will stick to slackware 10.1 for now.
What I get is:
1. It boots from the CD.
2. I get- boot:
3. I press <ENTER> to load the default bare.i kernel (I also tried other options)
Form here it starts going very quickly so I'm not sure what it prints
4. The installation program prints:
      loadin ….. /kernels/bare.i ...........bzimg
      loading….. initrd.img................
5. I think I managed to read: linux ok and a blurry list.
6. The screen says: cling
7. The screen goes blank.
rindiCommented:
Can you try using a different display? To me this sounds as if it can't handle the refresh rate the video card is outputting.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Duncan RoeSoftware DeveloperCommented:
I have to agree with rindi - try another monitor. I did the experiment with checking refresh rates, and if there is a variation during the slackware boot process then it's tiny.

Initial BIOS screen (checks memory & IDE drives): Horiz 31.6KHz Vert 60.2Hz
Subsequent BIOS screens (you may not have these) and all Slackware screens H31.6 V 70.4 or 70.5 (measurements would vary)
Measurements are by the monitor - I press the button on it that brings up the on_screen menu to change brightness contrast, picture geometry &c. On-screen display includes refresh rates.
eyal_baroukAuthor Commented:
Tried another monitor and with no luck.

I have given up on the idea of installing linux for now. I think the computer I am trying to install it on has some serious hardware problems which I don't have the time nor the patience to deal with.

Thanks for all the suggestions. I will split the points between you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.