Roaming profile files won't go away after being deleted!

I am using roaming profiles & Folder Redirection with Server 2003 & XP. Everything seems to be working fine except when a user deletes a file, log off, log back on - the file is back!

I took a look at the below post:

I disabled offline files but it didn't solve my problem. It only got rid of the annoying blue swirlies on the icons and a message that was coming up every once in a while that a machine was suddenly offline. While that is all well and good, my users are getting downright MAD that they can't delete files from their desktop. Many of them use the desktop as a temporary staging area for files used during the day and deleted at the end of the day so now their desktop is filling up and they can't delete files.

If I want to get something to STAY deleted, I have to delete it from the desktop (which deletes it off the server) then I have to go into the Documents & Settings folder and find the matching profile on the computer and delete it there.

I had thought that was the point of a roaming profile!?!? To not have to worry about anything local on the machine.

I would assume that deleting the local profile when the user logs off using a GPO would take care of the problem but I am worried about what happens if the server goes down or something happens the user can't work.

Any suggestions? Please?

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Which folders are u redirecting?

Remember that the roaming profiles do not copy back to the server they just update the differences.
There is a new feature in Windows 2003 Server group policy, the delete of roaming cache! you can find it with GP editor in Computer configuration - administrative templates - user profiles and enable it. That is the one way to do it. Remember to enter the gpudate /force command in prompt mode to avoid several restarts.

the other way is to configure the registry of the workstations one by one take a look at the link
mjinxedAuthor Commented:
I am redirecting all three: My Docs, Desktop, Application Data. I thought that with roaming profiles if you turned off Offline Files then there was no local profile.

I guess it is not the local profile being there that bothers me. It is that I can't delete files without manually deleting it in both locations. Is it just a defect in roaming profiles that you can't delete files? Or is there a setting somewhere to allow it without turning off local caches?


Since you use redirection for Desktop then there should not be a desktop folder in documents and there a desktop folder??

I guess that there must be something wrong with the redirection!
Are u applying redirection through policy? Are u applying it correctly???

Try to exclude desktop and any other folder you redirerect from roaming

Check out :;en-us;814592
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

I had the exact same problem. Here is what i did to fix it:

Go into GPO

User Configuration/Windows Settings/Folder Redirection/Desktop

Set Basic Redirection and Redierct to the local userprofile location

Next: Make sure you have set the path in: Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Set Path for TS Roaming Profiles


Computer Configuration\Administrative Templates\System\User Profiles

I have the following settings:
Delete Cached copies of roaming profiles - Disabled
Only allow local user profiles - Disabled
Waite for remote user profile - Enabled
Add the Administrators Security Group to roaming user profiles - Enabled

That should be it. If this doesn't work then their is a GPO setting somewhere I have overlooked. The way I tested mine is that i log into TS and create a file via RDP ( I am also watching two folders on the server, 1. Local User Profile\Desktop 2. Roaming Profile\Desktop) When i create the file on my desktop it will create the file in the Local User Profile. Then when i log off it will copy it to the Roaming Profile. Then when i log on they are both there, when i delete the file it will delete from the Local Profile and then when i log off it will delete from the Roaming Profile.

Let me know if you need more assistance
mjinxedAuthor Commented:
You said:

" Next: Make sure you have set the path in: Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Set Path for TS Roaming Profiles "

Would this be in the following format?:


mine is just \\server\folder

no %username% - I set that when i create a user
mjinxedAuthor Commented:
I performed all the steps you outlined and it made no changes to the situation. I did gpupdate on the server and gpupdate /force on the client and then logged out last night then loggedback in this morning. and my deleted files were back again.

It appears that the desktop that I see and work with is the version sitting on the server. I know this because if I add or delete a file from the desktop, the changes are reflected in the server copy of the desktop, not the local one. However, when I log out and back in or reboot, any files I added are added to the local profile and any files I deleted that still reside in the local desktop folder are copied back to the server desktop folder.

Why doesn't the server copy of the desktop update the local copy of the desktop to let it know a file was deleted so that the local copy of the profile will delete it too??

I exported my terminal server GPO settings here:

Take a look at them and see if that helps. Save the file if you want, i wont leave it out there forever.

I know exactly what you are talking about, that is the exact problem I was having with the desktop. I am just not sure which settings i changed to make it work. Have a look at the policy and i will also continue to look.


mjinxedAuthor Commented:
umm....That link just gives me a bunch of garbage there something special I am supposed to do?


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mjinxedAuthor Commented:
I'm sorry, I  haven't had time to address this issue lately, other bigger projects have taken up my time. I accepted the answer as I believe it is there but havn't had the time to look yet. I have actually found that it must be something I changed from default because I am setting up another domain and the problem does not exist in that domain with the default configuration. Roaming Profiles & Folder Redirection behave as they should so something I changed at some point had to cause it.

Thank you, for all the great information!

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.