DLink ADSL [ DSL-502T ] router setup for RH 9

Hi Experts,

i m a newbie for linux and would really appreciate if someone can direct me to drivers of the product and steps to configure the same.

i searched the dlink site and net for drivers but didnt find any.

your help is highly appreciated.

thanks and regards

-keval
contactkevalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jonesy2kCommented:
You shouldn't need any drivers if you connect to it via the ethernet interface...
Just give your pc an ip address on the same range, and set the router as the default gateway.
Let me know if you need more detail....
Jonesy
jonesy2kCommented:
You can download manuals and install guides from here:
http://www.dlink.com.au/Default.aspx?ArticleID=730
Jonesy
contactkevalAuthor Commented:
for every website the browser gives following error msg.

"www.site.com could not be found. Pls. check the name and try again"

what are the steps to check internet connectivity
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

contactkevalAuthor Commented:
here is the output of /sbin/ifconfig command

$ /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:08:A1:6B:3C:C0
          inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1240 (1.2 Kb)  TX bytes:684 (684.0 b)
          Interrupt:11 Base address:0x4c00
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:321 errors:0 dropped:0 overruns:0 frame:0
          TX packets:321 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:21494 (20.9 Kb)  TX bytes:21494 (20.9 Kb)
jlevieCommented:
My suspicion is that DNS services and/or the default gateway isn't correctly set up. What is the contents of:

/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg-eth0
/etc/resolv.conf

What is the output of the command 'netstat -nr'?
contactkevalAuthor Commented:
thanks jlevie for taking interest in my query. pls. find the information as you requested.

/etc/sysconfig/network
NETWORKING=yes
HOSTNAME=localhost.localdomain
                                                                               
/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
USERCTL=no
PEERDNS=no
TYPE=Ethernet
                                                                               
/etc/resolv.conf
search localdomain
                                                                               
What is the output of the command 'netstat -nr'?
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0

jlevieCommented:
Presumably, your DLink router is at 192.168.1.1 and it has handed out a correct default route in the DHCP negotiation. However, in /etc/sysconfig/network-scripts/ifcfg-eth0 you have "PEERDNS=no", which causes the system to ignore any offer of DNS servers that might be present in the DHCP negotiation. And in fact, there are no name servers listed in /etc/resolv.conf, which is why you can't browse sites by name.

If the DLink is configured to provide name server data during DHCP negotiation, removing "PEERDNS=no" from /etc/sysconfig/network-scripts/ifcfg-eth0 and executing 'service network restart' (or rebooting) may be all that you need do. However, some routers like this have their own DNS proxy that doesn't work well with anything except windows. In that case you need to leave "PEERDNS=no" enabled and manually include a nameserver line in /etc/resolv.conf, specifying the IP of your service provider's DNS servers.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
contactkevalAuthor Commented:
Thanks a ton jlevie.  you have not just resolved my problem but also shared your knowledge with entire EE commnunity. its people like you who keeps such forums alive and make things work.

i removed "PEERDNS=no" from /etc/sysconfig/network-scripts/ifcfg-eth0 and it worked. first thing i am doing after getting online is thanking you. i sincerely appreciate your contribution and hard work.

thanks

-keval
jlevieCommented:
And thank you for your most generous compliment. As you may know the Experts here do this on a volunteer basis and their only reward is the points and any positive comments a questioner may leave. Seeing that sort of compliment is enough reward for me...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.