another "network cable unplugged" problem

I hate to ask it, cause I've seen it asked alot on this site, but I cant view most of the answers....

I just got my DSL hooked up, with an adsl modem (d-link 300g) [no drivers needed] and no router, and I am constantly getting that error, when my cable is most definitely plugged in. I have the latest drivers on my network card, I've tried another ethernet cord, and setting the media type of my nic to everything and I still get the error. The odd thing is that after I plug in and out my ethernet cable a dozen or so times the LAN connection will enable and I can sometimes connect to the internet (as I am now). Many times however after the LAN is enabled my internet will either say it timed out, a connection could not be made, ppp settings are wrong, or the phone line is busy, or it may connect and then not work. Also when it does connect it is very unreliable, as it will suddenly stop working. I am using pppoe to connect. I was also given software (that hasnt worked at all) to connect but when I called my isp earlier they said not to use it. Any advice will be appreciated.
fejy182Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

r-kCommented:
A failing dsl modem is one possibility. You can set your network card to use 10 mbps and see if that helps any (try both half and full duplex). I would also test with a third network cable just in case. If at all possible try a different DSL modem, even on a temporary basis. (Does any other PC or laptop work with that same dsl modem and cable?)
cooleditCommented:
hi, there

It does seems like mentioned above a faulty modem or the cable.

1. Try a different cable known to be good. if this does not fix
2. If you have another machine an old one you could try a linux OS with PPOE If this does not work and the cable now is known good the problem lies with your ISP

Cooledit
reedsrCommented:
check power features on the network connection, do not allow the computer to turn the device off to save energy
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

rikke_vpCommented:
Hi fejy182,

the way I would test it is explained below:

* Link a hub or other network device to the other end of your cable coming from your Network Interface Card (NIC)
* If you're not getting any errors about cable or connection problems it could be the modem/router or one of the ports on it, if possible use another port...

* When getting the error check your lights on the modem/router to chech that it has sync... If so its not been down so check your LAN port on the router/modem. If the sync led is down contact your isp... They can monitor how stable your conn is.

* Check your VPI/VCI settings in the modem/router... These should be in range of your providers settings ( for belgium its 8/35 )

* Try using the dial software delivered by M$... 3rth party soft is most likely not as good... (no I do not like Bill :)

If still getting errors
* Try to use another cable like sugested above...

If still getting the error
* Reset your modem/router to factory defaults or do a firmware upgrade...

If still getting errors
* Watch your event viewer when you get an error and post the events concerning your error back here since I'm running out of solutions with so less info ;)

Regards,
Rikke Van Puymbroeck

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rikke_vpCommented:
Hehe,

also check that your ISP's local network is on PPPoE instead of PPPoA... Most of the network are directly on ATM level for performance reasons. PPPoE is only needed when signal conversion on the ISP network is needed. Finally everything go's on the ATM's...

Regards,
Rikke
fejy182Author Commented:
I contacted my ISP this morning, and they tested my modem, it worked 100%, so they gave me a new network card, turns out there was a bad soulder on my motherboard's network card. It's been working perfectly ever since. Thanks for the input.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.