KERBEROS_V4 rejected as an authentication type

i am trying to use FTP in an shell script.


i created a following program

#!/bin/sh
HOST='172.29.32.202'
USER='oracle'
PASSWD='syntel_123'
FILE='file.txt'

ftp -n $HOST <<END_SCRIPT
quote USER $USER
quote PASS $PASSWD
put $FILE
quit
END_SCRIPT
exit 0


I have also tried creating the file .netrc
machine MCK_SRV_2
login oracle
password syntel_123

but still it gives the same error.


Thanks in advance

Regards

manish
manishfromukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SkegeCommented:
Hello manishfromuk,

Try to change the ftp part:

ftp -n <<EOF
open 172.29.32.202
user oracle pass syntel_123
put $FILE
EOF

I dont know if this helps, but you can test :)

BR.
Lauri

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sigel1Commented:
A program called expect can do the job.
Use http://www.linuxlots.com/~barreiro/spain/expect/expect_tut-8.html examples.
jlevieCommented:
The problem here is that one end of the FTP connection is using a Kerberized tool. My guess would be that it is the local machine that has a Kerberized ftp client. That will happen if the OS install was "Everything". The solution is to remove the Kerberos package that includes the ftp client that won't work except from within a Kerberos environment.

What does 'rpm -q --whatprovides /usr/bin/ftp' and 'rpm -qa | grep krb' return/
sigel1Commented:
I don't belive in RPMs.
Can you connect by hand, and just not by script?
beatingerCommented:
I have the same problem.  After installing Red Hat Fedora Core 2 "Everything", not I cannot connect to a local machine in the same network.  This is what happens:

[root@copia-linux beatinger]# ftp 10.1.252.196
Connected to 10.1.252.196.
220 GlobalSCAPE Secure FTP Server (v. 3.0)
500 Protocol not supported.
500 Protocol not supported.
KERBEROS_V4 rejected as an authentication type
Name (10.1.252.196:root): download
331 Password required for download.
Password:
230-Login OK. Proceed.
230 Eden Hosting DOWNLOAD Area.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> cd Linux
550 Permission denied.
ftp> dir
227 Entering Passive Mode (10,1,252,196,109,140).
550 Permission denied.

I desparately need to be able to connect to the FTP server to retrieve RPMs I need to install.  How can this be fixed?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.