firefox - disabled button not working

<form name="myform" action="" method="post" style="margin:0px 0px 0px 0px;">
<p><input type="text" value="" name="property_search" onKeyUp='this.form.submit.disabled=(this.value=="");' style="width:95px;">
<input type="submit" name="submit" value="Find" disabled></p>

cant seem to get this working in firefox

any ideas?
LVL 16
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

That works in my Firefox

What problems do you experience?

ellandrdAuthor Commented:
the button isnt disabled...

ellandrdAuthor Commented:
the button should be disabled until the user starts typing into the textfield
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

The button is disabled when I try your code and when I open the page

Could it be cache problems?
ellandrdAuthor Commented:
>>Could it be cache problems?

i'll clear my cache...
ellandrdAuthor Commented:
no still not disabled
Michel PlungjanIT ExpertCommented:
Works in my 1.0.4 under win2k too
ellandrdAuthor Commented:
well not for me??

getting confused and worried
ellandrdAuthor Commented:
you can see my screen dump here...

total visitors is ok, but online is blank, for batalf, the search button is still not disabled for me...
Have you tried clicking the button? The appearance remains the same in FF but it is still disabled. You might add the following to your CSS:

input[disabled] {
      color: #888;

To set the text color for a disabled input and maintain the appearance of a disabled button.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
This is indeed strange.

The submit button is still disabled in my Firefox. The only "error" I can find is that you use the name "submit" on your button. "submit" is a reserved word used to submit the form. So that button should be renamed.

something like

<form name="myform" action="" method="post" style="margin:0px 0px 0px 0px;">
<p><input type="text" value="" name="property_search" onKeyUp='this.form.submitButton.disabled=(this.value=="");' style="width:95px;">
<input type="submitButton" name="submitButton" value="Find" disabled></p>
ellandrdAuthor Commented:
ok im well confused, ive just got my boss to view the page in firefox and its working fine, but yet when i view it, its not disabled... clearing cache in firefox:

this is what im doing:

tools>options>privacy>cache>click clear>OK...

dont see anything taken a long time ot clear, not like IE, were i could be waiting for a minute for the cache to clear...
ellandrdAuthor Commented:
that code has made 2 textfields now...:

ellandrdAuthor Commented:
if you typ in the first textfield, the second textfield is enabled. if clear 1st field of text, 2nd is disabled
Sorry, the line

<input type="submitButton" name="submitButton" value="Find" disabled></p>

should be

<input type="submit" name="submitButton" value="Find" disabled></p>

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.