Intermittant inability to access web pages/internet...

Since upgrading to XP home service pack two I have a problem where web browsing and email (pop3/smtp) suddenly decide not to work.

Once the problem starts happening, I get  messages like "the page cannot be displayed" from internet explorer (6.0.2900.2180.xpsp_sp2_gdr.050301-1519)

The problem then exists until I either uninstall the ethernet card and re-install it (with identical drivers) or I re-boot the machine.

It sometimes doesn't happen for a while. Internet can be working absoulutely fine and dandy, then all of a sudden for no apparent reason the dreaded "the page cannot be displayed" page comes up again, and there's nothing I can do but hop a re-boot will solve it...

when the problem exists, I've done things like 'nslookup' 'tracert' and 'ping -a' from the command prompt, all of which work PERFECTLY the DNS server seems to be there and giving the correct info, I can ping IP addresses with a '-a' and get the full name of the system. But outlook email comes up with all sorts of pop3 errors and like I say internet explorer won't browse.

Any help GRATEFULLY received!

Dave.
DaveEEAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DaveEEAuthor Commented:
Forgot to add I even uninstalled SP2 and reinstalled it. Problem still exists, but seems OK with SP1.
DaveEEAuthor Commented:
I reset all the winsock, re-did the lan connection using the wizard.
Everything came up absolutely fine & working like greased lightening, and then again all of a sudden... Bang, a load of web page images show place holders instead of pictures, everything slows down, then things get worse until back to "the page cannot be displayed" message whichever web page I try to look at.
With this state of NOT working at all, I've tried:
>netdiag /test:winsock /v

Output of which is below

  Gathering IPX configuration information.
    Querying status of the Netcard drivers... Passed
    Testing Domain membership... Passed
    Gathering NetBT configuration information.
    Gathering Winsock information.

    Tests complete.


    Computer Name: PAT
    DNS Host Name: PAT
    DNS Domain Name: (null)
    System info : Windows 2000 Professional (Build 2600)
    Processor : x86 Family 15 Model 2 Stepping 9, GenuineIntel
    Hotfixes :
        Installed?      Name
           Yes          KB873333
           Yes          KB873339
           Yes          KB883939
           Yes          KB885250
           Yes          KB885835
           Yes          KB885836
           Yes          KB886185
           Yes          KB887472
           Yes          KB887742
           Yes          KB888113
           Yes          KB888302
           Yes          KB890046
           Yes          KB890175
           Yes          KB890859
           Yes          KB891781
           Yes          KB893066
           Yes          KB893086
           Yes          KB893803v2
           Yes          KB896358
           Yes          KB896422
           Yes          KB896428
           Yes          KB898461
           Yes          Q147222
           No           ServicePackUninstall


Netcard queries test . . . . . . . : Passed

    Information of Netcard drivers:

    ---------------------------------------------------------------------------
    Description: Intel(R) PRO/100 VE Network Connection
    Device: \DEVICE\{AADCEF90-3C77-4D40-B116-A6CEA714858E}

    Media State:                     Connected

    Device State:                    Connected
    Connect Time:                    00:17:09
    Media Speed:                     100 Mbps

    Packets Sent:                    1795
    Bytes Sent (Optional):           0

    Packets Received:                111
    Directed Pkts Recd (Optional):   99
    Bytes Received (Optional):       0
    Directed Bytes Recd (Optional):  0

    ---------------------------------------------------------------------------
    [PASS] - At least one netcard is in the 'Connected' state.



Per interface results:

    Adapter : Local Area Connection
        Adapter ID . . . . . . . . : {AADCEF90-3C77-4D40-B116-A6CEA714858E}

        Netcard queries test . . . : Passed


Global results:


Domain membership test . . . . . . : Passed
    Machine is a . . . . . . . . . : Standalone Workstation
    Netbios Workgroup name . . . . : MSHOME
    Dns domain name is not specified.
    Dns forest name is not specified.
    Domain Guid. . . . . . . . . . : {00000000-0000-0000-0000-000000000000}
    Logon User . . . . . . . . . . : CRC
    Logon Domain . . . . . . . . . : PAT


NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
        NetBT_Tcpip_{AADCEF90-3C77-4D40-B116-A6CEA714858E}
    1 NetBt transport currently configured.


Winsock test . . . . . . . . . . . : Passed
    The number of protocols which have been reported : 14
        Description: MSAFD Tcpip [TCP/IP]
            Provider Version   :2
            Max message size  : Stream Oriented
        Description: MSAFD Tcpip [UDP/IP]
            Provider Version   :2
        Description: RSVP UDP Service Provider
            Provider Version   :6
        Description: RSVP TCP Service Provider
            Provider Version   :6
            Max message size  : Stream Oriented
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{AADCEF90-3C77-4D40-B116-A6CEA714858E}] SEQPACKET 0
            Provider Version   :2
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{AADCEF90-3C77-4D40-B116-A6CEA714858E}] DATAGRAM 0
            Provider Version   :2
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{A27036D5-899C-4D91-A62A-7351A691F4D6}] SEQPACKET 1
            Provider Version   :2
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{A27036D5-899C-4D91-A62A-7351A691F4D6}] DATAGRAM 1
            Provider Version   :2
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{899C04F7-BD79-45F7-90D7-2E8615CCBD0C}] SEQPACKET 2
            Provider Version   :2
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{899C04F7-BD79-45F7-90D7-2E8615CCBD0C}] DATAGRAM 2
            Provider Version   :2
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{9C91060B-D430-4DA6-944B-1A1AC8501D62}] SEQPACKET 3
            Provider Version   :2
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{9C91060B-D430-4DA6-944B-1A1AC8501D62}] DATAGRAM 3
            Provider Version   :2
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{BF77D5F6-9EE6-4318-B526-DB964A8C5AB4}] SEQPACKET 4
            Provider Version   :2
        Description: MSAFD NetBIOS [\Device\NetBT_Tcpip_{BF77D5F6-9EE6-4318-B526-DB964A8C5AB4}] DATAGRAM 4
            Provider Version   :2

    Max UDP size : 65507 bytes


The command completed successfully


------------------------------------------


I've tried a few other things like command line:

>netsh winsock reset catalog

Again, everything gets cleaned up and re-set, only to run for a while until it suddenly internet explorer returns to "the page cannot be displayed".  and I'm stuck once again.

Is anyone out there able to help?
DaveEEAuthor Commented:
More information, as I'm sure you will all be asking the questions...

I have & run adaware SE Personal & Spybot

The connection is via a cable router to broadband set-top box modem. Other PC's on same router have no problems. Plus I've taken the routher out of the equation completely and connected the PC directly to the set-top box modem. STILL get exactly same problem.

I have tried turning firewall off. STILL get exactly same problem.

(I want to bump up the points to hopefully get a quicker answer on this, but I can't find how to do that now!!!)

Dave.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

DaveEEAuthor Commented:
Looks like I'm gonna be the only one posting to my OWN question!
More info.
The problem occurred again and while the problem was there, I tried to update the spybot data files and got the following error:

Error retrieving update info file!
Socket Error #10055
No buffer space available


Does this help cast any light on a possible cause?

conradieCommented:
Have you tried restarting the DNS client service when this happens? Does this temporarily resolve the issue?

conradieCommented:
command line:

net stop "dns client
net start "dns client

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DaveEEAuthor Commented:
That had no effect either.
Although it does seem to come up with the error page a bit faster than it did!!!!
DaveEEAuthor Commented:
Hmmmm... watch this space...
When I did the stop & start of the DNS client, I didn't re-boot.

Now that I've re-booted, it seems to be working *** SO FAR ***

So, keep fingers crossed... but a few days ago it worked for nearly a full day with loads of use, and then all of a sudden... again for no apparent reason... just stopped working.

So, let's see how long it lasts... I'll see if I can manage to upset it again.

conradieCommented:
DaveEE-

I didnt really expect that to fix the problem, and it likely wont. I was just suggesting that to troubleshoot and see what happens. If the issue remains feel free to try and take the points back and we can try figure out the issue.

Thanks for the points anyway, though! : )

DaveEEAuthor Commented:
Well the only other thing that happened is I removed and re instated the firewall, and as I was doing that my virus program found - and removed - a trojan horse attached to the windows firewall program...
So maybe that was the cause...

Seems to be fine now..

Dave.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.