Exchange databse won't mount

Hi,
I recently crshed my server with an unclean shutdown.  I had to reinstall the OS and rebuild my server to the state it was in prior to me touching it.  My exchange 2k3 database files survived because they are on another paartition.  When I reinstalled exchange, I cut the new database files and pasted the old ones back in and tried to remount with no luck.  i then tried eseutil /p, as well as removing the log files and tried to remount once more.  I still get an error message when i try to mount.  The only database I can mount is the new one exchange created when I reinstalled.  how do I get the old DB to mount again?
firemanrobAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David WilhoitSenior Consultant, ExchangeCommented:
Well, reinstalling Exchange may have broken you, depends on how you did it. Did you restore your AD to it's previous state, or was AD not touched? If you renistalled Exchange, did it reinstall cleanly, and did you reapply the current SP level? that could make a difference.
firemanrobAuthor Commented:
I reinstalled ad with the same users and permissions as it had before.  The current service packs have been reinstalled as well.  If I can't get the old DB back, is there a way to extract the mailbox or the data from the mailbox?
BlevinsM3Commented:
Kidego is right. When you reinstalled Exchange, you would have had to use the /disasterrecovery switch to make sure that the installation grabbed all the correct config information so that you could mount up the databases. A /p is a last resort operation that should only be done when the following conditions are true:
1. Your database is in an inconsistent (dirty shutdown) state.
2. You do not have a good backup.
3. You cannot play through the logfiles to make your DB consistent due to missing or corrupted logfiles.

If you have a database that is inconsistent (which you can find out by doing an eseutil /mh and looking to see what Shutdown State says), and you have properly re-installed Exchange, then when you try to mount the DB you should get some helpful error messages that, when fed into the Knowledge Base, will point you in the right direction. I'm assuming you don't have a backup, and thats why you did the /p. It also sounds like you may have just reinstalled Exchange as though it was a brand new organization, is that correct?
Also, supply us with some of the error messages (from the Event Log) that you are getting.

Good luck!
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

eatmeimadanishCommented:
When you setup the Exchange site, make sure that three things exist.  The Domain, Computer name, and Site name are exactly the same.  You can not mount a store unless these are right.  I would obtain a new freshly recovered store (both the EDB and the STM files), and not run Eseutil.  I would just cut the log files out and try mounting.  If this doesn't work, use the eseutil to determine the state (eseutil /g), if it is in a dirty shutdown you may need to recover (eseutil /r).  If all else fails, run eseutil /p /createstm file.  

http://support.microsoft.com/default.aspx?scid=kb;en-us;317014
David WilhoitSenior Consultant, ExchangeCommented:
If you simply recreated the AD, instead of restoring the AD from backup, then your users don't have a connection to that old mailbox store, even if you get it to come up. Certain things have to go exactly right, and it doesn't sound like humpty dumpty got put back together in order :) (sorry, bad joke)

Tell me how you restored AD...
Exchange_AdminCommented:
What is the exact error messages you are getting when trying to mount the stores?
Pop up errors and event log errors please.
firemanrobAuthor Commented:
I am getting error id c1041724
eatmeimadanishCommented:
It sounds like you only restored your EDB file and not your STM file as well.  In this case follow the below.

Eseutil /i - bypass the database and streaming file mismatch error:

The /i option ignores the signature mismatch error in the check phase if
the
database and streaming file do not match each other. The database and
streaming
file will receive new signatures in the repair phase. Without using this
option,
repair will terminate immediately once the database and streaming file
mismatch
error occurs.

From the Command Line Run:

  eseutil /p <database name> /i
BlevinsM3Commented:
Do you have enough space on your logfile drive and the drive where your database is?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
firemanrobAuthor Commented:
Ok, I got the old public store to mount by clicking "this databse can be overwritten by a restore".  It is not working with the mailbox store though.
firemanrobAuthor Commented:
none of the suggested eseutil functions are fixing it.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.