Public and Private Network Adapters on Windows 2003 Server

I have a Windows 2003 Server with three network adapters, configured as such:

NIC #1
IP: 10.0.0.3
Mask: 255.255.255.0
Gateway: 10.0.0.1


NIC #2
IP: 55.44.23.92
Mask: 255.255.255.248
Gateway: 10.0.0.1

NIC #3
IP: 55.44.23.93
Mask: 255.255.255.248
Gateway: 10.0.0.1

NIC #2 and NIC #3 are connected to the internet. NIC #1 is connected to the internal LAN. The router IP for the public NICs is 55.44.23.89.

When I ping 55.44.23.92-93 from another machine on the internal LAN, I cannot reach these public IPs. However, I can reach the public router IP at 55.44.23.89. The LAN is connected to the Internet through a Small Business Server 2003 which has a DSL connection through a Linksys firewall with NAT.

I had a similar config on Windows 2000 server that worked. What am I doing wrong here?

nhdigitalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SoyYopCommented:
You may have to set up routing... Have you installed remote access and routing services? Or set up one of the interfaces a shared internet connection (you can manually set a fixed Ip on this one later so don't have to use 192.168.xxx.xxx)


There's a way to do it without Routing and remote access services. I've never tested it, but here is a link:

http://www.windowsnetworking.com/j_helmig/w2kprout.htm#w2000

Note: This is for routing, not for NAT. Your IP schema must ve valid. But as you have been doing it before, I think you know what you want...

If you need more advacned options, check:

http://www.microsoft.com/technet/prodtechnol/windowsserver2003/library/ServerHelp/e009461a-2ab3-420c-9d3b-7c6b2aaa0ecb.mspx

Luck,
sreeraoCommented:
Hi Nhdigital,
I guess you posted a similar question in the webdev area too? Anyway, I have posted my comments there too. I wanted to know if you were able to open up the RRAS console to configure the routes?!
Also in case of a multi-homed server like yours, if you are trying to route the external IP addressed NICs traffic through the 55.44.x.x gateway, you should put that in the NIC2 and 3. Then you have to configure the static routes for the same.

Hope this helps.
-Sree
nhdigitalAuthor Commented:
It is correct that I had to put in the 55.44.xx gateway for both external cards and 10.0.0.1 for the internal card. Microsoft claims that this doesn't work for multihomed but it seems to.

The key is to have the 55.44.xx gateway as the default gateway as in ROUTE PRINT. The way to do this is to give it a Metric of 1, and give the 10.0.0.1 gateway a lower metric.

Static routes were not necessary.
sreeraoCommented:
Glad that it worked out. I realized it when I did it on my test server. Anyway, looks like you got it working.

Regards.
-Sree

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nhdigitalAuthor Commented:
Thank you for your advice. It did get me pointed in the right direction.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.