Windows 2000 DHCP Problems

Seems starting yesterday my Windows 2000 DHCP Server is not handing out addresses to clients anymore. There has been no network/hardware/software changes to really cause it to stop functioning, so I am stuck When looking at the DHCP server it is fully functioning and has no errors in either the DHCP or system event logs; you wouldn't even know there is a problem. But when our workstations are trying to renew or get a IP address, the broadcast is timing out saying no DHCP server is responding. I have attempted restarting the service, restating the server, and even installing the DHCP service on a different server, and still the clients are timing out.

We know its a DHCP problem becuase assigning a static IP address is successful and everything then works fine. I am guessing it has to do with some sort of network issue or something else possibly messing with the broadcast, but I have run out of ideas on what it could be. If anybody has had this problem before or has some DHCP troubleshooing ideas, it would be greatly appreciated. Thanks for the help.
argylechaiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

craylordCommented:
Do the clients get any address? 169.xxx.xxx.xxx or 127.* or ?

We had dhcp problems at a site. The problem was a small netgear router/switch that some users were connecting to. It had a dhcp server running. Post the address the clients are getting.
Leandro IaconoSenior Premier Field EngineerCommented:
As craylord in some way stated, this is probably due to a router.

Did you recently install a router on the network? some routers don't forward dhcp broadcast packets to other portions of the network were your dhcp server would be ...

Does you dhcp server have a firewall installed on it?

jdraggiCommented:
Sounds like the DHCP server does not think that it is authorized to send out IPs.

Make sure that you right click on the DHCP server and choose authorize.

If this just started to happen, you may not be releasing the IPs from the cache... make sure that the IPs in the active window are actually leased...  If not you may have to flush the DHCP server.

Hope that helps!
--John
Become a Microsoft Certified Solutions Expert

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

r-kCommented:
This happened to us a while back. The problem was that the DHCP database got corrupted due to unknown reasons (probably a bug in Windows). The solution was to delete that scope in DHCP manager and then create a new scope with the same params (note them down before deleting, just in case). Has been working fine since then.

HTH.
Leandro IaconoSenior Premier Field EngineerCommented:
all very good suggestions...
argylechaiAuthor Commented:
The clients do get addresses: 169.254.xxx.xxx, but of course the original scope before the DHCP server died was different (192.168.xxx.xxx)

I have attempted to delete and recreate the scope, but still have the same problem. The DHCP server is also authorized to send out IPs, no firewall is installed on our DHCP server. We have no routers on this network either, let alone one introduced in the past few days.

Any other ideas or ways to test and see if the DHCP service is even receiving the requests? The logs say nothing as of now. Thanks for the help.
jdraggiCommented:
ok, then you are missing the basics

the reason why the 169.254.x.y addresses is because that is the default.

Check the DHCP server properties to make sure that you have it bound to the network card that is attached to the network that is supposed to be giving out the IPs  (right click on DHCP server, choose properties).

--John
Leandro IaconoSenior Premier Field EngineerCommented:
ok .. lets see what he says ...

Are you positive there are no routers between the clients and server?
argylechaiAuthor Commented:
I guarentee you there are no routers between the clients and servers. This is a very simple network with no outside connections at all.

The DHCP server properties is listing it bound to the correct (and only) network card, so no luck with that.

If you think of any other possible ideas, let me know. Thanks for the help with this issue.

jdraggiCommented:
Have you tried to uninstall the DHCP server and reinstall it?

Have you tried to set an IP manually and then ping the server?

Have you tried a different switch?

Have you made sure that your switch VLAN is the same for both the server and clients?

--john
argylechaiAuthor Commented:
I have uninstalled and reinstalled the DHCP server on the original server, and also installed it on a different server in the network closet. I have no problems with the network if we have static IPs.

And it is looking like some sort of Network/LAN issue. I took another server and installed DHCP on it and hooked it up to the network back by the workstations, and it is handing out IP addresses to all the workstations fine. I need to do some more tests making sure all workstations can talk to this DHCP server, then attack what is causing the network disruption (which seems to be only affecting DHCP, nothing else).
jdraggiCommented:
You are giving out DHCP IPs from a network card which has the same IP/Subnet range correct?

--john
argylechaiAuthor Commented:
Yes, the IPs are all correct.

Seems that our main switch could be the problem. As stated before I can get a DCHP address on one side of our network, but I just tested out other workstations spanning across a few switches, and they are not successful in receiving addresses. Not sure why this is because we have made zero changes to these switches. I will be logging into them shortly and seeing if I can resolve the issue there.
jdraggiCommented:
Do you have VLANs setup?  You may not have your trunk ports setup correctly.

--John
Leandro IaconoSenior Premier Field EngineerCommented:
As I suggested, I was lamost sure it had to be a router or in your case a switch problem.

The swtich or "routers, as I called them" (boxes lets say) got to be blocking DHCP traffic ... check out and see if UDP ports 67 are blocked ..

Checkout this link also ... http://support.microsoft.com/?kbid=168455 - even though it doesn't specificly apply to your case, you could somehow fit in ...  
NetminderCommented:
Closed, no points refunded.
Netminder
Site Admin

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.