RPC/HTTPs not again Exchange 2003

I am having a real peculiar RPC over HTTPS problem.  I have spent a good
deal of time looking things over and everything seems to be configured
correctly. I will list what I have done so far.  Exchange 2003 SP1 Windows
2003 SP1

First install the RPC over HTTPs module through add remove programs

Use the RPC/HTTPs tab on the server properties under System manager to
configure my single server as backend.  It did give me an error stating that
RPC/HTTPs would not work since I did not have a front end server, but
everyone seems to think this is normal.

Created a certificate for IIS issued to mail.odysseynetworking.com

Created an internal DNS zone named odysseynetworking.com for internal name
resolution to function properly.  AKA assigned private IP address A records
to my internet addresses.

Went over the regkeys for RPCproxy and valid port.  below is the values
Valid ports =
courier:100-5000;courier:6001-6002;courier.odyssey.internal:6001-6002;mail.odysseynetworking.com:6001-6002;courier:6004;courier.odyssey.internal:6004;mail.odysseynetworking.com:6004
"
NSPI= "ncacn_http:6004"

I have installed the certificate chain on the test PC.

Configured Outlook 2003 running on Server 2003 SP1 to use
mail.odysseynetworking.com as its RPC proxy.  Configured the mutual
authentication as msstd:mail.odysseynetworking.com.  Set RPC proxy to be
used for fast and slow networks.

When I run the outlook /rpcdiag it will always connect with TCP/ip

When I run rpcping.exe with the following switches, I am prompted for a
password followed by:
Response from server received: 401
Client is not authorized to ping RPC proxy

E:\Program Files\Support Tools>rpcping -t ncacn_http -s
mail.odysseynetworking.c
om -o RpcProxy=mail.odysseynetworking.com -P "administrator,odyssey,*" -H
2 -u 10 -a connect -F 3 -v 3 -E -R none

From the looks of things this should be a problem with a password or user
not existing.  I have tried with my personal account as well as the
administrator account.  I feel like there is a setting somewhere that says
not just how to setup RPC/HTTPs but also whether it is enabled or disabled
or something such as that.  It also goes without saying that it does not
work with outlook/rpcdiag either. If anyone can help please do.  To make
sure I am not crazy I have duplicated this setup on two servers, and the
result is the same on either.

I just hope it isn't some answer like the fix for this will be incorporated
into SP2.  The funny thing is at one point in time I had RPC/HTTP setup on
one of the exchange servers and it worked fine.  I may have forgoten
something I did it has been a long day.

mrlullabyeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mrlullabyeAuthor Commented:
Wouldn't you know.  After going over all of these settings and taking a few minutes to write this post, I rebooted and it magically worked.  Well it wasn't exactly magic, Here is what I suspect happened.

When I copied the registry keys to create this email I noticed that each registy data had a single space at the end of the line, so I took those out.  I tested it after removing the reg keys, but it had no effect.  On reboot though it seems to have made a world and a half of difference.  Sorry for the chaos maybe it will help someone else out.

Please close the thread
LunchyCommented:
Closed, 250 points refunded.
Lunchy
Friendly Neighbourhood Community Support Admin

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.