Terminal Server Home Directories

Hi guys,

We have an AD 2003 domain.
All users have a normal user home directory (not TS home directory) in their AD user account properties.
I dont want their normal user home directory (H: drive) to be mapped when they log on to Terminal Servers.

So this is what I did.
I placed the Terminal Servers into their own OU.
I created a GPO for the Terminal Servers, disabled the User Config, and enabled Loopback Policy Processing on the Computer Config for this GPO. In this Computer Config, I enabled TS User Home Directory to point to D:\Tsusers.

Now, when users log on to these Terminal Servers, their normal user home directory H: drive is still being mapped.
No home directories created in d:\tsusers.

Do I have to run the chkroot.cmd command to create a ROOT DRIVE on each Terminal Server, in addition to setting the TS User Home Directory in Group Policy?

If I do, then in Group Policy where I enabled Terminal Server Home Directory of d:\tsusers, do I also need to put the drive letter that I assigned as the ROOT DRIVE by running the chkroot.cmd command?

Any help here as to why the normal home drive is still being mapped instead of using the TS home drive would be greatly appreciated.

Simon
LVL 1
Simon336697Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

colin_harfordCommented:
WHat if you create a script that normally mounts the home drive to H, put in it with an exception if the server is the ts server.  

What you have set atm, is a setting to apply to the entire ad specific system.  It's not like you can go, on this machine I want the users username to be bob, and on the ts to be bob1.

CH


Simon336697Author Commented:
Hi Colin!
Thanks for your help.
But what you have described is not quite right.
What I have set up atm does NOT apply to the entire AD.
That is why I placed the Terminal Servers into their own OU, and configured a GPO just for these Terminal Servers.
So that anyone who logs on to these Terminal Servers, will not get their normally applied user gpos when they DONT log on to Terminal Servers.
The issue I have is that when users log on to non Terminal Servers, everything is as it should be. Their normal home directories as defined in AD are executed. The problem is that the SAME home directory is mapped when logging on to a Terminal Server, so there is some issue with my group policy or permissions on my created home directory path on the terminal server.

Thanks anyway for your help.
oBdACommented:
Have you tried simply entering the local path in the user's profile in ADUC, in the "Terminal Services Profile" tab? By default, if you leave this field empty, the regular home drive will be used, which is what's happening at the moment. Once you define the local folder in the user's profile, the local path should be used.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.