Intranet access issues with Firefox

Hi,

I currently use IE6 and Firefox 1.0.4. With IE, I can access the intranet sites without problem.
But not with Firefox.

I have the same settings in both browsers (proxy, etc...).

I've indicated not to pass through the proxy for intranet addresses.

When I type about:config in address field of Firefox, I can set a value for the parameter "network.automatic-ntlm-auth.trusted-uris" (I found this on Internet). I did it, but again, does not work.

When I enter the intranet address under this form: http://intranet_site, it says:
"The requested URL could not be retrieved
Unable to determine IP address from host name for intranet_site
DNS Domain 'intranet_site' is invalid: Host not found (authoritative).
..."

This works perfectly with IE.

Anyway, instead of writing the name, I enter the IP address for intranet_site, then it tries to connect it. This takes a while and at the end, indicated that it cannot connect to the site.

Where is the problem actually? Firefox, network, proxy, ....?
Again, with IE, no problem.

Thanx for your help.
Wongy
LVL 1
WongyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

WongyAuthor Commented:
Additional info:

When I enter directly the IP address in the address field, I get the following. Let's assume the intranet IP address is 111.112.113.114 (just an example), the internet address is 155.156.157.157, and the proxy port for http is 80.

"ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: NONE://155.156.157.158:80http://111.112.113.114/

The following error was encountered:

    * Read Error

The system returned:

    (131) Connection reset by peer

An error condition occurred while reading data from the network. Please retry your request."
amit_gCommented:
The way it is it doesn't seem like ntlm-auth problem. Can you ping the intranet_site? How about cmd->

telnet intranet_site 80
GET /
GET / HTTP/1.1

What do you get

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD><TITLE>You are not authorized to view this page</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=Windows-1252">
...
...
WongyAuthor Commented:
Hi,

I can ping the intranet site. Again, with IE, it works.

However I cannot telnet it. I get this:

"Connecting To intranet_site...Could not open connection to the host, on port 80: Connect failed"
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

amit_gCommented:
What if you used the IP of intranet_site ...

telnet xx.xx.xx.xx 80
WongyAuthor Commented:
Actually, if I telnet intranet_site without mentioning the port, then I get this:

SunOS 5.8

login:

And obviously, I do not have any login nor password for this to access it this way...
amit_gCommented:
Not without the port but with the IP instead of name i.e. use

telnet xx.xx.xx.xx 80

instead of

telnet intranet_site 80

where xx.xx.xx.xx is IP of intranet_site
WongyAuthor Commented:
telnet xx.xx.xx.xx ==> I get this:

SunOS 5.8

login:


telnet xx.xx.xx.xx 80 ==> I get a black screen (nothing).
amit_gCommented:
After the blank screen type

GET /
<PressEnterKey><PressEnterKey>

Do you get anything? telnet again and type

GET / HTTP/1.1
<PressEnterKey><PressEnterKey>

What is the result?
WongyAuthor Commented:
telnet xx.xx.xx.xx 80 gives the black screen. Then I type (but I cannot see what I type): GET /
and it gives: Connection to host lost

I telnet again, I type: GET /HTTP/1.1
and I get:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML><HEAD>
              <TITLE>404 Not Found</TITLE>
</HEAD><BODY>
<H1>Not Found</H1>
The requested URL /HTTP/1.1 was not found on this server.<P>
</BODY></HTML>

Connection to host lost.
amit_gCommented:
It should have been
GET / HTTP/1.1

But that is not required. The point is that it works with IP but not with name.

Open connection settings both in IE and FF. You have a proxy. Is it manually entered or auto-detect? In IE you must be having bypaas proxy server for local address. Do the same in FF. You need to put the IP address in the list.
WongyAuthor Commented:
I have the same configuration in IE and FF as far as the proxy settings are concerned.
The proxy settings are not automatically detected, but explicitely set.
I have indicated a list of IP addresses (local addresses) where I should not go through the proxy in both IE and FF...
amit_gCommented:
Add the name (intranet_site) also in the list.

Do you have system administrator? Ask him to have a look and find out why you could not do

telnet intranet_site 80

while you could do

telnet xxx.xxx.xxx.xxx 80
WongyAuthor Commented:
The name is already added in the list.

And actually whether I do this: telnet intranet_site 80, or that: telnet xx.xx.xx.xx 80, I get the same result.
I typed wrongly the port earlier...
amit_gCommented:
Your original question says ...

When I enter the intranet address under this form: http://intranet_site, it says:
"The requested URL could not be retrieved
Unable to determine IP address from host name for intranet_site
DNS Domain 'intranet_site' is invalid: Host not found (authoritative).
..."

What does the FF report now (when telnet works via name and ip)? Also revertback the change that you did to the "network.automatic-ntlm-auth.trusted-uris". Without this FF should present a input box for the longin and password.

Also try the site both ways

http://intranet_site
http://xxx.xxx.xxx.xxx
WongyAuthor Commented:
I reverted back the FF parameter.

http://intranet_site works now like a charm (although it was not working before changing the parameter... do not understand).

http://xxx.xxx.xxx.xxx does not work
"ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: NONE://xxx.xxx.xxx.xxx:80http://yyy.yyy.yyy.yyy/

The following error was encountered:

    * Zero sized reply

Squid did not receive any data for this request."
amit_gCommented:
That seems to be from proxy. What is xxx... and yyyy... ? Is one of this a proxy?

BTW, isn't your problem solved?
WongyAuthor Commented:
yyy.yyy.yyy.yyy is the Ip address of intranet_site
xxx.xxx.xxx.xxx is the external IP address (the one we see from Internet)

Actually the problem is not solved, since I cannot access intranet sites when typing their IP addresses (they do not all have a name like intranet_site).

Btw, when I add intranet_site to "network.automatic-ntlm-auth.trusted-uris", it works again...

...
amit_gCommented:
I thought you were trying to access it using either the name or IP but the IP was always internal. So does it work for internal IP? What is intranet_site resolved to? Internal or external IP? Can you use telnet (port 80) for the external IP as well?

And again does it works both ways from IE?
WongyAuthor Commented:
Apparently I was not clear enough.

I'll to be clearer now.

We have some intranet sites. Some of them have a name (like intranet_site). Others have just an IP address.

With IE, whether I type the IP address or the name, I can access the site.
With FF, now if I type the name, it works. If I enter the IP address, it does not work (cf. the error messages posted above).

I have the same proxy configuration for IE and FF. The list of intranet sites for which the proxy should not be used, is also the same for both browsers.
amit_gCommented:
For some reason the proxy is still being used for the IP in question. Is the IP listed in the list for which proxy should not be used. The list should be comma separated. You will have to list the IP even if the name is listed. Make sure the IP is correct.
WongyAuthor Commented:
The IP is also listed ans is correct.

Maybe it is simply a bug in Firefox...?
amit_gCommented:
I don't think so. This is very simple thing and with so many versions already out, if it were a bug it would have been reported and fixed.
WongyAuthor Commented:
Well...

I fully deinstalled Firefox and installed it back.

The result: I cannot access any of the intranet sites (whatever the address I type: intranet_site or xxx.xxx.xxx.xxx).
I can even not access 127.0.0.1, nor localhost. I get this : "Forbidden - You don't have permission to access / on this server."

With IE: still no problem...
amit_gCommented:
>>I fully deinstalled Firefox and installed it back.

Did you configure the proxy manually again? Do you get 403 from web server or a message from proxy?
WongyAuthor Commented:
I indeed configured the proxy manually (I took the same config than in IE).

I have a web server installed on my PC, but when I type 127.0.0.1 or localhost I get a 403 error but not from my web server... The information on the server is as follow: "Apache/x.x.xx Server at some_address Port xxxxx"
And I cannot ping some_address...

I restarted my web server, but no change.

Again, no way to access intranet sites...
amit_gCommented:
And this time you did not change network.automatic-ntlm-auth.trusted-uris?

Do you get 403 from web server or a message from proxy?

Can you access localhost from IE?
WongyAuthor Commented:
This time I did not touch network.automatic-ntlm-auth.trusted-uris.

I get 403 from proxy.

I can access localhost from IE.
WongyAuthor Commented:
I found something:

In Firefox, if I select the option "Direct connection to Internet", or "Automatic detection of proxy settings", I can access my local web site (by typing whether localhost or 127.0.0.1), and also any of the intranet sites (typing intranet_site or their IP addresses).
But then I have no access to Internet anymore.

And if I select "Manual configuration", I get access to Internet, but not to my local web site nor the intranet sites...

In IE, the selected option is "Manual configuration of proxy", and I can access any of the sites (local, intranet, www).
WongyAuthor Commented:
It looks like Firefox is not able to bypass the proxy when I select "Manual configuration of proxy"...
WongyAuthor Commented:
OK. I found the root of the problem.

I said earlier that the proxy settings for Firefox were the same than for IE. And that was the issue actually.
Indeed, in IE the list of sites for which the proxy should be bypassed are semi-colon (;) separated, whereas in Firefox, they should be comma (,) separated.

Secondly, in IE you can define an IP-range for which the proxy is bypassed, this way: 192.168*
That does not work with Firefox.

So now, in FF, I can access any of the sites (local, intranet, www). But I can not define a range (I have to enter the IP addresses one by one in the box "No proxy for").

Thus, how to define an IP-range in Firefox?

amit_gCommented:
Well it would have been easier for both you and me, if you read the comments more carefully. Please check http:#14489194 ...

"...The list should be comma separated..."

anyway :)

Range can be given like this ...

192.168.1.0/24

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WongyAuthor Commented:
Yeah, you're right... It seems that I overlooked this... Sorry :)

For the range definition, how can I do something like this: 192.168.*.*?
Because in your example, it is similar to 192.168.1.* but not to 192.168.*.*

Thanx.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.