Can't connect to Terminal Server

I am having a problem with a Win98 Box using Remote desktop. Whenever i try to connect to the Terminal Server (Win200 Server) I get the following message:

"The remote computer disconnected the session because of an error in the licensing protocol. Please try connecting to the remote computer again or contact your server administartor"

I use the IP address of the server to connect to it. I pinged the address and got back all replys back. The other users that have Win98 and WinXP boxes connect with no problem. This happen here and there.

Where should I start looking?
LVL 1
Albert1809Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeeTutorretiredCommented:
Take a look at this page:

http://www.microsoft.com/technet/prodtechnol/windowsserver2003/library/ServerHelp/159e6ff8-4edb-43fd-8767-3d9858897e2c.mspx

Here is the quotation from there for that particular error message:

The remote session was disconnected because there were network problems during the licensing protocol. Please try connecting to the remote computer again.
Cause:  The terminal server might not be able to locate the license server.

Solution:  Perform the following steps:

1.
 Verify that the license server is correctly installed.
 
2.
 Verify that the Terminal Server Licensing service is running on the license server.
 
3.
 Verify that the client, the terminal server, and the license server can communicate by ensuring that Domain Name System (DNS) is configured correctly on each computer. To do this, run the ping command from each computer to each computer using the IP address, FQDN, and the NetBIOS name. If any of the ping commands fail, verify the DNS configuration on the network.
 
4.
 On the terminal server, set a preferred licensing server to connect to. You can do this by using the registry, a Windows Management Instrumentation (WMI) script, or, in Windows Server 2003 with Service Pack 1, you can use Group Policy settings or Terminal Server Configuration.
 

See also:  Install Terminal Server Licensing; Set preferred Terminal Server license servers; Terminal Server license server roles

Cause:  The license server might be running Windows 2000, and it might be configured to prohibit anonymous connections, except by resources that have been explicitly granted access to the server.

Solution:  On the Windows 2000 license server, do one of the following:

Caution

Incorrectly editing the registry may severely damage your system. Before making changes to the registry, you should back up any valued data on the computer.

• In the registry, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\RestrictAnonymous, and set the RestrictAnonymous registry key to a value of 1 or 0.
 
• In Local Security Policies, open the appropriate policy and, in the console tree, navigate to Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options. Then, enable either Do not allow enumeration of SAM accounts and shares (equivalent to a RestrictAnonymous value of 1 or None) or Rely on default permissions (equivalent to a RestrictAnonymous value of 0).
 

Notes

• If the license server is a member of an Active Directory domain and a conflicting security setting is configured for the license server in Group Policy, the Group Policy setting overrides the local security setting. In this case, to ensure that the security setting that you want to apply takes effect, configure the setting in Group Policy.
 
• In Windows Server 2003, you cannot set RestrictAnonymous to a value of 2 to prohibit anonymous connections. If you need to prohibit anonymous users from being granted the same access that is granted to members of the Everyone group, you must use the new Everyone Network access: Let Everyone permissions apply to anonymous users setting in Local Security Policies.
 

Solution:  If the previous solution does not resolve this problem, create a backup of the MSLicensing registry key and its subkeys on the client, and then remove the original key and subkeys by doing the following:

1.
 On the client, navigate to the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing.
 
2.
 Click MSLicensing.
 
3.
 On the Registry menu, click Export Registry File.
 
4.
 In the File name box, type mslicensingbackup, and then click Save.
 
5.
 If you need to restore this registry key in the future, double-click mslicensingbackup.reg.
 
6.
 On the Edit menu, click Delete, and then click Yes to confirm the deletion of the MSLicensing registry subkey.
 
7.
 Close Registry Editor, and then restart the computer.
 

When the client is restarted, the missing registry key is rebuilt.

Caution

Incorrectly editing the registry may severely damage your system. Before making changes to the registry, you should back up any valued data on the computer.

See Also:   How To Use the RestrictAnonymous Registry Value in Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=38561)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.