Command Prompt

I have a Standard 2003 server with one hard drive and i partioned it into 2. Well when i go to the command prompt i am not able to get to that drive which is the d: drive. How do i get to that?

This is what i did

1. cd c:\        enter
2. cd d:\        enter


It doesnt give any kind of error it just keeps going to the c: drive after i put in that command??

Thanks
_JJ_Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mcp_jonCommented:
JJ,

You can´t do " cd C:\ " nor " cd D:\ "

Just type "D: followed by Enter "

Did it work ??

Best Regards !
_JJ_Author Commented:
i just tried again like you had it and it came back like this

c:\
d:\

c:\


It displayed the d: drive right below the c: drive for a split second and then went back to the c: drive??
mcp_jonCommented:
Strange !

Can you run CHKDSK or Scandisk against the disk ?

Best Regards !
OWASP: Threats Fundamentals

Learn the top ten threats that are present in modern web-application development and how to protect your business from them.

NJComputerNetworksCommented:
Can you see the D: drive in Computer management or through Windows explorer?

When you run CHKDSK, do it like this:

chkdsk d: /f
_JJ_Author Commented:
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>cd c:
C:\Documents and Settings\Administrator

C:\Documents and Settings\Administrator>cd c:\

C:\>cd d:
D:\

C:\>


I copied and pasted it right from the command prompt.. I cannot get to the d:\ drive to run the chkdsk or scandisk.
_JJ_Author Commented:
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>cd c:\

C:\>chkdsk d: /f
The type of the file system is NTFS.

Chkdsk cannot run because the volume is in use by another
process.  Chkdsk may run if this volume is dismounted first.
ALL OPENED HANDLES TO THIS VOLUME WOULD THEN BE INVALID.
Would you like to force a dismount on this volume? (Y/N)

This is what happend. I did not choose anything because i am really not sure on what exactally this means
mcp_jonCommented:
Can you go to the Computer Management Console, and goto the Disk Management ?

Can you state the Volumes you see, and what type they are ?

Best Regards!

_JJ_Author Commented:
I have the (c:) drive that is the (system) which says Healthy and then right next to it is the New Volume (d:) dirve that says Healthy also

They are both in the Disk 0 slot and they are Basic disks
mcp_jonCommented:
Do you have Data on the D: Disk ?

If not, delete the Partition and recreate it, as Primary! Then Format it !

Try to do the " d: " again and post how you're going !

Best Regards !
_JJ_Author Commented:
I have a data base and alot of important things on the d: drive so i cant touch it.
NJComputerNetworksCommented:
Would you like to force a dismount on this volume? (Y/N)


Just click Y.

Running Chkdsk on a volume other than the boot volume
When you use the /f or /r parameters on a volume other than the boot volume, Chkdsk must lock the volume for exclusive use before it can repair errors. If the volume has open files or programs, Chkdsk displays the following message:

Chkdsk cannot run because the volume is in use by another process. Chkdsk may run if this volume is dismounted first. ALL OPEN HANDLES TO THIS VOLUME WOULD THEN BE INVALID. Would you like to force a dismount on this volume? (Y/N)

If you press the Y key, Chkdsk attempts to close all handles and lock the volume. If Chkdsk is successful in locking the volume, the repair process begins. The duration of the repair process is determined by the number of files and folders on the volume and the level of damage, if any.

If Chkdsk cannot lock the volume, or if you press the N key, you can specify that you want to check the volume by running Autochk the next time the computer restarts. For more information about Autochk, see "Running Autochk When the Computer Restarts" later in this chapter.

NJComputerNetworksCommented:
or press N and specify that you want to check the volume on next reboot....
_JJ_Author Commented:
Thanks. Do you think it might have errors on it then and that is the reason it will not work through the command prompt? I will set it to run then on the next reboot.
NJComputerNetworksCommented:
Not sure...it sounds pretty wierd...are you databases working?  Can you access the D: through Windows Explorer?

You can also try this command to see if there are any errors without fixing them (i think)

chkdsk d:

mcp_jonCommented:
Mark for check on next Reboot !

Reboot !

Worked ?

Best Regards !
_JJ_Author Commented:
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>cd c:\

C:\>chkdsk d:
The type of the file system is NTFS.
Volume label is New Volume.

WARNING!  F parameter not specified.
Running CHKDSK in read-only mode.

CHKDSK is verifying files (stage 1 of 3)...
File verification completed.
CHKDSK is verifying indexes (stage 2 of 3)...
Index verification completed.
CHKDSK is verifying security descriptors (stage 3 of 3)...
Security descriptor verification completed.

 135807463 KB total disk space.
  18887408 KB in 26689 files.
     10620 KB in 1817 indexes.
         0 KB in bad sectors.
    157279 KB in use by the system.
     65536 KB occupied by the log file.
 116752156 KB available on disk.

      4096 bytes in each allocation unit.
  33951865 total allocation units on disk.
  29188039 allocation units available on disk.

C:\>


Looks ok right?
NJComputerNetworksCommented:
looks good...when did this problem start?  Can you access the D: in Windows Explorer? Are your database working?

Run the SET command and post the results (just go to command prompt and type SET)
_JJ_Author Commented:
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>set
ALLUSERSPROFILE=C:\Documents and Settings\All Users
APPDATA=C:\Documents and Settings\Administrator\Application Data
CLASSPATH=C:\PVSW\BIN\PVJDBC2X.JAR;C:\PVSW\BIN\PVJDBC2.JAR
ClusterLog=C:\WINDOWS\Cluster\cluster.log
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=DENVER2003
ComSpec=C:\WINDOWS\system32\cmd.exe
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\Administrator
LOGONSERVER=\\DENVER2003
NUMBER_OF_PROCESSORS=2
OS=Windows_NT
Path=C:\PVSW\BIN;C:\Program Files\Support Tools\;C:\PROGRAM FILES\WINDOWS RESOUR
CE KITS\TOOLS\;C:\WINDOWS\SYSTEM32;C:\WINDOWS;C:\WINDOWS\SYSTEM32\WBEM;C:\PROGRA
~1\CA\COMMON\SCANEN~1;C:\PROGRA~1\CA\ETRUST\INOCUL~1;c:\lnhelper\support
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 15 Model 2 Stepping 9, GenuineIntel
PROCESSOR_LEVEL=15
PROCESSOR_REVISION=0209
ProgramFiles=C:\Program Files
PROMPT=$P$G
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\WINDOWS
TEMP=C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp
TMP=C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp
USERDNSDOMAIN=HOSPITALCOOPERATIVE.COM
USERDOMAIN=HOSPITALCOOPERA
USERNAME=administrator
USERPROFILE=C:\Documents and Settings\Administrator
VSL=C:\PVSW\BIN
windir=C:\WINDOWS

C:\Documents and Settings\Administrator>

Not sure when it started i just tried using it today for something and wouldnt work. The databases are running just fine on there. We use that drive everyday.
_JJ_Author Commented:
I forgot D: works just fine from windows explorer as well
_JJ_Author Commented:
Going to try and increase the points on this since it has grown into a bigger problem
2hypeCommented:
when you go to the command prompt you are typing cd D: Rather than Just D

When I type cd D: - I get the same respones as you do.  So one can only assume this is what it does for that command.

Copy and paste form command prompt (this is what you are doing)

C:\Documents and Settings\administrator>cd L:
L:\

C:\Documents and Settings\administrator>

Copy and paste from what you should be doing (not you should not enter cd L:, it should just be L:) cd stands for change directory.  You are chaning a Drive therefore you do not use the cd command.

Go to command prompt and just type D:  (my example using a L: Drive) (command prompt shown below)

C:\Documents and Settings\administrator>L:

L:\>

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
_JJ_Author Commented:
That worked. Thanks man
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.