Speedup HP 650C Designjet Printer

Here is a questions for those who have good memories.  I have an old HP 650C designjet printer I use for plotting drawings.  I know, it is probably 10 years old, but it works great for what I need.  Why get rid of a perfectly fuctional printer if it still does what is needed.  I use AutoCAD and Windows XP Pro.

I have one frustration with it.  It is slow to spool the file to the printer.  I use the parallel port for sending from the computer to the printer.  It takes a long time to send a plot to the printer.  It is about 5 minutes per megabyte.  I have extra memeory in the printer.

Anyone have some suggestions on how to speed up the plotter's reception of the plot file?

Thanks.

Rich
rlewistxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MrBillisMeCommented:
We a have retired DesgnJet450c (because it was very slow) and an active DesignJet500 and both are parallel cable to a print server and yes they do take quite a while to spool. That spooling process my be slower due to your local PC. What are you running?
newuser4Commented:
HP DesignJet 650c should support ehnanced parallel modes like ECP which offers faster communication with the printer.

To use this modes you have to:

- check if your pc supports them, open Device Manager under Windows Xp and make sure that expanding "Ports" item Lpt1 is shown as "Ecp printer port". If it is set as "Printer port" or "Parallel port" at boot time hit "Del" key, enter in bios setup and under "Advanced Configuration" you will find a voice like "Parallel port mode", select Ecp, save and reboot.

- check the parallel cable, it cannot be longer than 10 feet and it must be ieee 1284 compliant.

Ecp mode offers a transfer rate of 2 megabyte/sec while standard parallel port speed is 150 kbytes/sec.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rlewistxAuthor Commented:
I checked the System Drivers and the parallel port is running in ECP mode.

My parallel cable is 15 ft. long.  It is printed on the side as 1284 compliant.

Do I have to do anything to get the 2 mb/sec rate, or is it the default.

My computer is a P3 800 mhz system.  I need to update it, can't just yet.

I remember at a former employer they had a 650C and I thought it spooled much faster.  Maybe my memory is bad.  They no longer have the printer so I can't check it.
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

newuser4Commented:
Hp specifically states that paralle cable cannot be longer than  10 feet, don't you have a shorter cable to test with?

Ecp mode automatically sets up port speed, no user intervention is required.

I have just two suggestions:

- in printer properties, between spooler options try selecting "start printing after last page has been spooled" and as spooling format choose "raw";

- in the printer control panel set the print quality as "Final" .
rlewistxAuthor Commented:
Thanks for the info.  

My plotter is too far away from the CPU to use a shorter cable.  I don't have a shorter one to test it with.

Wouldn't it need to be "start printing after last page has been spooled" anyway?  It has to wait until the entire plot is received or it wouldn't get everything.  My plotter doesn't start printing until the entire plot has spooled out.

I have it set to draft mode.  Would making it final mode make it spool faster?  If it did, it would plot slower and use more ink.

MrBillisMeCommented:
I don't think changing from draft would help but that point about the cable lenght is interesting. A faster PC might help but you're still running it thru a slow cable. You might test the cable length idea but just moving the plotter closer for your test to see if that is the problem. Run the same job near and far.

Good Luck.
newuser4Commented:
"Start printing after last page is spooled" is an option you will find  in Advanced tab, under printer properties.

When you create a print job the application sends data to printer driver and once this process has been completed printing process begins.
This doesn't mean that conversion between Windows metafile and printer language has been terminated, unless the mentioned option has been enabled driver works in parallalel with the spooler, reducing disk space used to store temporary data but increasing cpu load.
Moreover, if Emf format has been selected spooler will have to convert data to printer language before sending it to the printer, causing further delay.

Provided that you have enough disk space (100 Mbytes should be sufficient to store an A2 plot at 600 dpi) spooling the entire file and selecting Raw format(properties -> Advanced -> Print processor) grants the best performance.
EdanCommented:
Move the printer closer to the PC and try printing with a shorter cable. If it runs faster, maybe this cable would work:
http://www.tigerdirect.com/applications/SearchTools/item-details.asp?EdpNo=1219598&CatId=471

Make sure you order the correct length.
rlewistxAuthor Commented:
The last comment reminded me I needed to close out the question.  I haven't solved the problem.  I gave the points to newuser4 because he gave a detailed answer and it is probably right, I just can't move the printer closer right now.  The cable from Edan was only 6 ft. long.  Now that I know there is a prduct out there I will look for a longer one.  I thought I should close the question out though and not wait.

Thanks all!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.