Error moving mailboxes between 2 Exchange 2003 servers

Here's my situation, a customer has purchased new and better hardware for a new mailbox server.  Both the new and old server are running Windows 2003 Exchange 2003 on the same domain.  When attempting to move a test mailbox from the old server to new we get the following error in the log
progress code="0" milliseconds="2360">Connecting to destination server.</progress>

- <summary isWarning="false" errorCode="0xc1050000">

  You do not have permission to log on. The MAPI provider failed. Microsoft Exchange Server Information Store ID no: 8004011d-0519-00000000

- <details>

I've followed a few articles related to the above error, we've tried with a newly created test mailbox as well.  The account we are using has full Exchange admin permissions, as well as full control to the mailboxes.  The test mailboxes are not disabled and have the Self role as the associated external account.  One thing of note, on the new server the System Attendant mailbox is missing from ESM but the store is mounted and running the cleanup agent did not make it appear.  Also during the mailbox move it is generating a 1022 error in the app log "logon failure on database".  Another action that was taken was rebuilding the RUS which did not help either.
Thanks
LVL 1
EpurchaseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

eholland99Commented:
Have you tried using Exmerge.exe to export the mailbox and import it into the new location?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
e2k3tekCommented:
The 1022 error is received when users are trying to log on to their mailbox while it is being moved. No worries there.

Check this out, it does say it's for Exchange 2000 but should be try for Exchange 2003 as well:

http://support.microsoft.com/default.aspx?scid=kb;en-us;317338

CT
EpurchaseAuthor Commented:
I will try both of the above this week, was hoping to use Exmerge as a last resort.
Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.