Dell D610 and RIS problem

I have created a RIS in windows 2003 and in the same time made an image from a dell d610 to the ris. Everything works fine.
When I try to roll out the image from ris to another d610 it says that the image doesnt have the netdrives of the pc.
Any ideas about this?
damixaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

damixaAuthor Commented:
Yes I did and everything went find during the image creation. when i try to boot from nic card it prompts out the window ask for user admin and password and than once it begins installing windows it says that the image doesnt contain the drivers for the netcard and the installation stops.
Mince69MeatCommented:
after the initial boot from the NIC it then switches over to text-mode setup witch dose not know about your NIC you need to supply drivers for RIS to connect

http://support.microsoft.com/?kbid=315279

Mick
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

mzamarripaCommented:
Dell Lattitude D610's generally have 2 NIC's...  one internal and a wireless NIC.  Sounds like your image is looking for the wireless drivers.

Have you tried both of these drivers?
damixaAuthor Commented:
I tried what mice69meat suggested but still the same error. I followed the procedure in the microsoft page without any luck and about the nics that true d610 has 2 nic but it initialized only from the internal one as im out of the wireless connection.
Mince69MeatCommented:
Let’s back track
So you browse the network to your RIS server \\YourServer\REMINST\Setup\English\Images\YourImigeName\ and in here you should have 2 folders one called $oem$ and the other is I386
The $oem$ should have this structure \$oem$\$1\Drivers\NIC\ and in the NIC folder you should have the NIC drivers only no other folders (to keep it simple)

And in your .sif file located here \\YourServer\REMINST\Setup\English\Images\YourImigeName\i386\templates\
(Browse the network to make shore you have edited the right one)
You should have something like this

[data]
floppyless = "1"
msdosinitiated = "1"
OriSrc = "\\%SERVERNAME%\RemInst\%INSTALLPATH%\%MACHINETYPE%"
OriTyp = "4"
LocalSourceOnCD = 1

[SetupData]
OsLoadOptions = "/noguiboot /fastdetect"
SetupSourceDevice = "\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"

[Unattended]
    UnattendMode=FullUnattended
    OemSkipEula=Yes
    OemPreinstall=Yes
    OemPnPDriversPath=\Drivers\NIC
    TargetPath=\WINDOWS
    DriverSigningPolicy=Ignore
    Filesystem=ConvertNTFS
    ExtendOEMPartition=0
    OverwriteOemFilesOnUpgrade=No


damixaAuthor Commented:
That one worked after i reinstall the RIS but i get this problem now

File iastor.sys caused unexpected error (21) at line 3540 in
d:\xpsprtm\base\boot\setup\setup.c

and the setup closes
Mince69MeatCommented:
On first impressions it looks like it's looking at the CD-ROM and the location should be a unc path like \\YourServer\REMINST\Setup\English\Images\YourImigeName\i386\

Look at how the image was prepped as it look like its setup for a unattended installation from a CD

Look at the bottom of this page at Riprep Rules and Restrictions section
http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/Default.asp?url=/resources/documentation/Windows/XP/all/reskit/en-us/prbc_cai_ogbp.asp

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mince69MeatCommented:
Have you resolved this

Mick,
damixaAuthor Commented:
Thanks for your help, unfortunately I gave up and return to the classic ghost:) but thanx for ur help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.