OWA 2003 Issues On Windows Server 2003

Simply put, it appears that OWA 2003 is completely broken on my SERVER.  Below is a screenshot of what the window looks like when you login using ANY browser, including the one that's actually on the SERVER.  

http://www.kakusplace.com/owa_mess.jpg

First thing to note is that the Theme is missing entirely.  It appears to be running in basic mode and not premium mode, but I have NOT choosen this or specified it.  

About 90% of the icons at the top of the screen do nothing, they will show an exclamation point in the lower left hand side of the browser when clicked.  This appears to be a javascript error.  To be more specific, the NEW button does nothing, the Address Book button does nothing.  If you read a message, clicking REPLY does nothing.  

I have spent well over 6 hours checking permissions, re-setting directory security, etc.  I compared it to another WORKING OWA 2003, and from what I can tell all the settings are identical, of course with the exception that the domain is different.  

One thing I am un-sure of, is how easy would it be to re-install just OWA on the server.  Or, maybe someone can give me some troubleshooting tips that I haven't already tried.  I wish I could write down EVERYTHING that I have tried already, but that would take up a whole page in itself to type.

Thank you very much!   I'm stumped at the point, outside of re-installing something to fix this issue.
KrocodileAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KevNetCommented:
Have you tried re-setting the OWA folders?
KevNetCommented:

Try applying or re-applying SP1 for Exchange 2003.
Reset the OWA folders:

http://support.microsoft.com/default.aspx?kbid=883380

Other than that, Re-run exchange setup with the /disaterrecovery switch.


 
Seelan NaidooMicrosoft Systems AdminCommented:
Are you using Forms Based Authentication, when logging in via OWA?

Its seems like its either IIS, or the ISA server thats publishing OWA?

Are you using Win2k and ISA2k / W2k and ISA2k4 / Win2k3 and ISA2k / Win2k3 and ISA2k4 ?

Do you have a systemstate backup [you can get the IIS metabse from it] or a recent backup of IIS/inetpub/wwwroot]

If not, try installing exchange on a temp machine [not on the network], then copy the default exchange directories in IIS, to removable media like CD/Tape/DVD/memory stick.

Rename the old inetpub directory, and copy the new inetpub directory to your server. Restart the server. Hopefully that should do it.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KrocodileAuthor Commented:
We have already tried resetting the OWA folders and re-applying sp1 wich had no effect. We have not tried installing exchange on a temp machine copy the default exchange directories in IIS and copy the new inetpub directory to your server. Were gona try this next.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.