OWA SSL Page cannot be displayed after trying almost everything

As everyone else I too am having issues with OWA SSL,

I have looked at all hte articles I can find on this gone through various step by steps, from petri.il, mcseexchange.org, MS Kb and various others.

I have installed a Enterprise CA, the certificate was succesfully implemented into OWA,Configured SSL on the default web page and enabled form based auth,  a first attempt brought up the SSL warning box and then went straight to Page cannot be displayed. I checked everything over and over again same thing, change back to normal works fine, recreated the OWA virtual dir in IIS and now even worse, no certificate warning come up it goes straight to Page cannot be displayed. Change back to normal and it works great. I am not going through a firewall and trying this locally.

Any ideas will be a great help.

I have already checked some of these pages

http://www.msexchange.org/tutorials/Securing-Exchange-Server-2003-Outlook-Web-Access-Chapter5.html
http://support.microsoft.com/default.aspx?kbid=883380
http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21049319.html
http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21201491.html?query=OWA+SSL+page+cannot+be+displayed&clearTAFilter=true
http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21412746.html?query=OWA+SSL+404&clearTAFilter=true
http://www.petri.co.il/configure_ssl_on_owa.htm
http://www.petri.co.il/configuring_forms_based_authentication_in_exchange_2003.htm



LVL 12
ColinRoydsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ColinRoydsAuthor Commented:
I have just checked and when SSL is enabled I do get the certificate prompt when trying to access it from outside the firewall, which is good, but after that still only page can not be displayed.

ColinRoydsAuthor Commented:
Problem solved by using Firefox to test the page, it showed a corrupt certificate, removed certificate and requested a new one problem solved.

LunchyCommented:
Closed, 500 points refunded.
Lunchy
Friendly Neighbourhood Community Support Admin

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.