Configuring VLANS with Cisco 3508 and getting line protocol up.

Hi all,

I need some help getting my 3508 up and running.  We just purchased it to expand the fiber runs coming from the plant IDF's and so far i can go into any of my 3524's, 3550's or core 4000 switch and get instant connectivity.  What i am trying to do now is take those fiber runs and patch them all to this 3508 and them send them to the core switch.

I have a management VLAN which is VLAN1.  All of my routers and switches are on this VLAN for management purposes but data etc seems to pass over it as well just fine.  I have 2 other VLANS on my core switch VLAN10 which is for phones (we hace VoIP) and then VLAN20 for data.

Ok so again I can take a 3524 switch with a fiber module in it and plug into the fiber in interface gigabitethernet 0/1 and then patch gigabitethernet 0/2 to the core switch and things hum right along perfectly.  However if i take that same connection or any for that matter and connect to my 3508 i cannot get them to talk at all.  All i get is VLAN1 is up, Line protocol is down.  (not administratively down).

Here is the config from the 3508 minus the password etc...

Current configuration:
!
version 12.0
no service pad
no service timestamps debug uptime
no service timestamps log uptime
service password-encryption
!
hostname MDF_2_3508G
!
ip subnet-zero
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,10,20,1002-1005
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface VLAN1
 ip address 192.168.1.12 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN10
 description Voice
 no ip directed-broadcast
 no ip route-cache
!
interface VLAN20
 description Data
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
ip default-gateway 192.168.1.1
logging trap debugging
logging 10.0.0.254
snmp-server engineID local
snmp-server community blahblahblah RO
!
line con 0
 password 7 024C4A722F575F15
 login
 transport input none
 stopbits 1
line vty 0 4
line vty 5 15
login
!
end

As you can see all i want to do is get things talking over VLAN1.  for instance i took my spare 3524 and have these both on my desk.  I have them connected to eachother via fiber both on interface gigabitethernet 0/1.  Now if i take my 3524 into the server room and tap it into any other switch at all via fiber it instantly comes up and works and accesses everything.  Sorry for the long post but i will put my 3524 config here also because maybe there is something obvious as to why it works and my 3508 doesn't.  Here is my 3524 config minus all the ethernet port stuff to minimize space.  I will just put one of them and then the 2 gigabit ethernet interfaces etc.

sh run
Building configuration...

Current configuration:
!
version 12.0
no service pad
no service timestamps debug uptime
no service timestamps log uptime
service password-encryption
!
hostname MDF_3
!
no logging console
enable password
!
ip subnet-zero
!
 interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport mode trunk
 switchport voice vlan 10
 spanning-tree portfast
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface VLAN1
 ip address 192.168.1.6 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
logging trap debugging
logging 10.0.0.254
snmp-server engineID local
snmp-server community blahblahblah RO
!
line con 0
 login
 transport input none
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end

Thanks in advance and hope someone can help me.  I have to have this up and running by Monday.

Maestro2be
maestro2beAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tmesiasCommented:
do a show vlan and copy here.
grbladesCommented:
> All i get is VLAN1 is up, Line protocol is down.  (not administratively down).
Where do you get this? What are you showing which tells you this message?

Can you post an output of 'show int GigabitEthernet0/1'
JFrederick29Commented:
Your VLAN1 interface is shutdown in the config:

interface VLAN1
 ip address 192.168.1.12 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 shutdown
^^^^^^^

Try this:

switch>enable
switch#config term
switch(config)#interface vlan1
switch(config-if)#no shutdown

Your VLAN20 is shutdown also.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

maestro2beAuthor Commented:
Thanks for responses.  Here is all the required answers.

Firstly thanks for the response but i have many times tried bringing up the interface with the no shut command and it instantly says, "link state changed to UPDOWN".  so it comes up and instantly goes back down so that isn't doing the trick.

I do get a GREEN status indicator between the two fiber links that is constantly blinking and looks just as if it were up and running correctly.  Just an FYI.

Here is a paste of SH INT GIGABITETHERNET 0/1 on the 3508:

GigabitEthernet0/1 is up, line protocol is up                                  
Hardware is Gigabit Ethernet, address is 000b.46f1.7841 (bia 000b.46f1.7841)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not set
Auto-duplex (Full), 1000Mb/s, media type is SX
output flow-control is off, input flow-control is off
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:02, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 1000 bits/sec, 1 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
620 packets input, 52906 bytes, 0 no buffer
Received 616 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 598 multicast, 0 pause input
76 packets output, 15939 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

Here is paste of my SH VLAN on the 3508:

MDF_2_3508G#sh vlan                  
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
10   Voice_VLAN                       active
20   Data_Vlan                        active
1002 fddi-default                     active
1003 trcrf-default                    active
1004 fddinet-default                  active
1005 trbrf-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 trcrf 101003     4472  1005   3276   -        -    srb      0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trbrf 101005     4472  -      -      15       ibm  -        0      0

VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
1003 7       7       off

I just dont understand why the interfaces on this 3508 just keep shutting back down the second i bring them up.  The 3524 works perfectly and integrates instantly into the network.  I get green status lites and i get a link is up but line protocol is down so I hope this is something simple.  I sure hope this helps as this has to be up and running today and im getting a little upset they dont have a smartnet so i could just make the call and be done with it.  So my solving this is up to the experts here.  Please let me know if yo need anything more.

Maestro2be
tmesiasCommented:
Can I have you, logging to terminal session, and a console cable connected to your 3508, and the switch disconnected from the network, issue a show tech, then debug spanning tree events.  Connect the switch let the link do what it's going to do.  undebug all. then show tech. and then paste the results here.
maestro2beAuthor Commented:
Ok thanks all for the input but i got it working and figured it out.  First off, a 3508 can only have one active VLAN interface up at one time.  So that is why VLAN10 was up and 1 and 20 was down.  I shutdown VLAN10 and VLAN1 instantly came up and started working perfectly.  Since i had done all the VLAN management on the 4500 core switch i deleted everything from the 3508 and kept just the VLAN1.  That was all i had to do.  I have now got the entire company up from a 100 to 1000 backplane now which is making them extremely happy.  Performance is great now.

Thanks again for trying to help me though.
grbladesCommented:
no objections
moduloCommented:
Closed, 500 points refunded.
modulo
Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.