Really messed up my box... /bin/sh: relocation error: /bin/sh: symbol __memcpy_chk, version GLIBC_2.3.4 not defined in file libc.so.6 with link time reference..

I was trying to update some packages on my main linux host box and now about 99% of the programs have stopped running, all showing the same error of /bin/sh: relocation error: /bin/sh: symbol __memcpy_chk, version GLIBC_2.3.4 not defined in file libc.so.6 with link time reference

HELP!

I have not the slightest clue how to fix this and I really don't want to reload this box as it has quite a bit of custom config done.

Thanks!

Keith
sirebralAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sirebralAuthor Commented:
This is a fedora core 3 box btw...
ravenplCommented:
Get the newest glibc package and install.
Since I suppose You can't do it with up2date, or download and do rpm -U(same error I suppose), try find a system with newer glibc than Yours, and just copy it over.
Next, update with up2date.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sirebralAuthor Commented:
Is there a possibility that YUM backed up the old config/files as I am unable to login to the box from my location and my only access at this point is webmin's file manager.  I could potentially go down to the colo tomorrow, yet getthing this box back online ASAP is key.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

utarnCommented:
This because your GLIBC version is not supported. I mean you may setup same package(which has newer version than ) from another linux distribution.

If so, you will have to download your update program original website (which is not from another distribute such as redhat ES 4).

Otherwise, try up2date
ravenplCommented:
YUM rather haven't back Your file up. Sorry. And sorry to say, that it may end in installing new system over it.
You need to do what I and utarn said: You need glibc 2.3.4 at least.
It's just You may find it hard to install/copy binaries, becouse You can't get access to the machine. If the webFM allows You to change system files, try copy glibc libraries from other FC3 or FC4 installation.
rindiCommented:
You can use webmin's file manager to copy the files to the box...
xDamoxCommented:
Before you do reinstall just give it a shot at running yum install glibc
jlevieCommented:
Your glibc is messed up (wrong version or a botched upgrade). My guess is that you "upgraded" a version of glibc not meant fro Fedora Core 3, meaning one not from the FC3 errata. The fix for this is to revert to the original glibc or the one in the FC3 updates.

Unfortunately I don't think you'll be able to do this except from a boot from CD since the tools needed to re-install glibc are linked against glibc and won't work at present.
utarnCommented:
I think you may want to update your glibc.If so, don't try to use package from another distribution because it's not designed for your linux. The best way is you can use Up2date or you may go to your linux distribution website and download from there only.
sirebralAuthor Commented:
Nothing seemed to work, I really screwed it up royally, so I wiped the box, installed Fedora 4 and restored my data.. took me about a day to get it all back but we're running again.  Have to be more careful with YUM from now on :) - Thanks for the suggestions.

Keith
rindiCommented:
Well, yum has worked well so far for me... It normally looks for the correct dependencies and only applies the update if that doesn't kill the rest of the system, or then you will probably have to enter something explicitly. How did you use yum when you updated those packages?
sirebralAuthor Commented:
Yum -y install <package>, in this case I was trying to do the kernel.
rindiCommented:
I usually do a Yum update, that updates all packages including the kernel, or you can do yum update <package> to update a single package. This still looks for the dependencies which also need to be updated.
Maybe the -y was a bad idea, as normally yum will show you everything that gets installed and what gets deinstalled in the process, and you then have a 2nd chance to review your actions...
jlevieCommented:
> It normally looks for the correct dependencies and only applies the update if that doesn't kill the rest of the system

That's correct and Yum will do the right thing if its list of repositories only contains packages meant to be used on that particular Linux Distro and version. The danger with yum or apt-get is including repositories not specific that your Linux distro/version. in that case either may install an incompatible package while trying to resolve a dependancy.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.