Linux doesn't recognize all of my RAM

Hello,

I have a PC running Debian Sarge with a 2.6 kernel. There is 1.25 GB of RAM installed and the BIOS recognizes it. However, Linux only recognizes 885 MB. I have tried adding mem=1280 to the GRUB configuration but that didn't change anything. Any help you can provide is appreciated.
LVL 3
delgadojAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Duncan RoeSoftware DeveloperCommented:
Do a "make xconfig" or "make menuconfig" in the Linux source directory and look for an option regarding memory size. at 2.6.12.2 building for x86-64 I can no longer see one, but I know I used to.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
delgadojAuthor Commented:
I recompiled the kernel with the High Memory Support option set to 4GB and when it came back up it recognized all the RAM. Thanks a lot.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.