blank child field in subform

Hi,  I have a subform within a form, I have the master/child fields setup but the child field always shows empty.  New records work, (the child field appears when adding a record) the new records show up in the table.  But when I try to view the existing records, no records appear.  I have the relationship defined as one to many with referential integrety 'on'.  Can you help me figure this out please?  I'm tryed everything I can think of and then some.
Sarah_AvalonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

thenelsonCommented:
What are the tables, fields and the type of fieldsfor the master and child?
puppydogbuddyCommented:
If your intended child field is an unbound control, it won't appear on the list...you have to type it in so that Access will know it is the intended child link.
Sarah_AvalonAuthor Commented:
The tables involved are:
(parent) ProcessUnit - has field processPK
(child) Layer - has foregin key fields LprocessPK and LmaterialPK
(child of child) Material - has field materialPK

I have the following setup:
I have text boxs in Layer bound to materialPK and processPK
In PorcessUnit form I have the master link field set to processPK and child link field set to LprocessPK

As I said above; I have the relationships defined as one to many with referential integrety 'on'.  I've tried every possible config with no luck.

What's so wierd is that records are added sucessfully from subForm Layer, just don't show up when I try to view all records.

Thanks so much for your help!
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

puppydogbuddyCommented:
So the records show up when you display the subform by itself, but not when you display the subform as part of the main form??? Then, most likely you have one or more of the properties on your main form set incorrectly.  Check the following settings on your main form:

filters?
allow edits?

subform control (is part of main form)
            what do you show as source object?
             also, click the master and child buttons again; make sure the list hasn't changed.

Also, make sure you've got no filters imbedded in your code behind the main form.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sarah_AvalonAuthor Commented:
Hi agian,  Now that you mention it, I tested the subform (Layer) and I get the same behavior; I can add to the table but it won't show me the records in the table, (except those I've just added in that session).  It's as if the recordset is empty when the form opens.  This is killing me, I know how to do this but in this case it won't work.  I have the form set as follows:

Oh my &%*&^!!!! I just figured it out!  I don't get this though....  I changed the form setting to Data Entry = NO. I've noticed that in all my other forms that's what it says and if I ever changed it things didn't work. So I've always left it at NO, don't know how or why it was set to YES this time.  But this has never made sence to me; shouldn't Data Entry be set to YES if you want to input data??? Gezzzz!  Thanks!

thenelsonCommented:
Data entry means enter data NOT edit data, so data entry = Yes means this form is entering new data not editing existing data.  It will only give you a blank (new) record to enter data into.
puppydogbuddyCommented:
Sarah,
Thanks for the points.  I was just going to explain to you why data entry= Yes was the cause of your problem, but I see that thenelson has already given you the answer.  The important thing is that you got your problem solved.
Sarah_AvalonAuthor Commented:
Thanks thenelson and thanks puppydogbuddy!!!  You guys are awsome.

Sarah
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.