WSUS Shows no client PC's

I was previously running SUS on our PDC. I have now installed WSUS, can login and update it etc., however none of our client machines are connecting to it.

I am wondering do I need to tell the clients to connect to the pdc on port 8530 through group policy, or is there a step I have missed altogether?

In group policy I have told the clients the Windows Update server is at http://pdcname

Any thoughts/tips would be brilliant,

Thanks very much,

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hi H4Inf

Did you configure the WSUS server to use port 8530 during the installation?  If so, change the Windows update server location in the group policy to http://pdcname:8530 If however you installed as standard, then your problem lies elsewhere.
Once your WSUS update server is fully updated itself - (this is imperative if you want pcs to register properly) check the retry times on the policy - I have mine set to 4 hours, auto notify for installation.
Post your Group policy settings if you are still having issues.

hope this helps

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
I think I have the same problem, which I asked a question about here;

I believe mine is setup at :8530, as I have to connect to server:8530 to admin WSUS.

My question was more about where exactly i am supposed to be setting these group policies though. :-)

Anyway, I'll keep an eye on this question also in case it solves my problem. :-)
H4InfAuthor Commented:
Hmm I have reviewed the event-log on the clients and they all seem to say:

Unable to connect: Windows is unable to connect to the Automatic Updates service and therefore cannot download and install updates according to the set schedule. Windows will continue to try to establish a connection.

I have removed SUS and WSUS, then reinstalled WSUS so it was the default site.. Still no clients connect and all report this message.
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

H4InfAuthor Commented:
and my Group Policy Settings:

Configure Automatic Updates Enabled
Configure automatic updating: 4 - Auto download and schedule the install
Scheduled install day:  0 - Every day
Scheduled install time: 04:00
No auto-restart for scheduled Automatic Updates installations Disabled
Specify intranet Microsoft update service location Enabled
Set the intranet update service for detecting updates: http://boss 
Set the intranet statistics server: http://boss 
Take a look at the question I posted, as I managed to get mine working in the end.

I changed the site to http://<ip of server>:8530 and that seems to be what fixed it in the end.
H4InfAuthor Commented:
I have changed it to the IP and i'll see how that goes.

I just found something in my default domain policy which may have been causing trouble:

This setting allows you to remove access to Windows Update.

If you enable this setting, all Windows Update features are removed. This includes blocking access to the Windows Update Web site at, from the Windows Update hyperlink on the Start menu, and also on the Tools menu in Internet Explorer. Windows automatic updating is also disabled; you will neither be notified about nor will you receive critical updates from Windows Update. This setting also prevents Device Manager from automatically installing driver updates from the Windows Update Web site.

This setting was enabled... I would think though that if no user was logged in, it shouldn't affect it?

I have disabled it anyway to see what happens.
H4InfAuthor Commented:
Aha! Well one of those settings fixed it. Thanks!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.