0x4 error with Scheduled Task

I keep getting a 0x4 error when running a scheduled task on my W2K box The task will run if I manually run the batch file. The task copies files from a second computer to the local computer, the share is working. I have a second set of computers with the same batch file that WORKS. I have checked the permission on both sets and they are the same. The batch file and the scheduled task is setup under a user with administrative rights. I have restarted the service but still get a 0x4 error when running.

Any thoughts or tips on troubleshooting would be appreciated
duficyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ComputronCommented:
Open scheduled tasks >>click advanced >> view log

That should provide more details. Its possible you need to be an Administrator to run it. That can be changed as well.

You could also use the AT to schedule tasks. Here is an explanation
http://support.microsoft.com/default.aspx?scid=kb;en-us;313565
duficyAuthor Commented:
Thanks yeah I tried that get the same respose. "task exited with code of 4" Is AT more robust ? Or give better error messages ?
Zamba1Commented:
Is that a windows error code that the task scheduler returns (0x4 would be "The system cannot open the file") or is this the result code your batch returns?

AT is the predecessor of the scheduled tasks and was mainly used in NT4 times. You shouldn't use it anymore with Windows 2000 or higher.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ComputronCommented:
All I can think of are the permissions. Are the logins between the two the same ?  Are there any local policies on the non-working workstations ?



>> AT is the predecessor of the scheduled tasks and was mainly used in NT4 times. You shouldn't use it anymore with Windows 2000 or higher.

You may want to tell Mister Softy that. The link is specific for Win2K
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.