ASP Smart Upload error

iceman_16
iceman_16 used Ask the Experts™
on
hello guys,
 
      I'm having a problem with uploading and deleting file in a folder, but before it works properly and runs smoothly. I think the errors comes out when I click "PERMISSIONS WIZARD" and so on.. in IIS Manager after that I cannot save and delete files in a folder. Is there any solutions.

  By the way, I'm Windows XP - IIS v5.1

 Error: ' UPLOADING
 aspSmartUpload.File (0x80040460)
 Unable to save file (Error 1120)

  I need your help asap. Im very much appreciated all your efforts. Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Don't use the permissions wizard.  Just set the permissions yourself.
The IUSR account needs NTFS write rights.  You do that at the file system level using Windows Explorer.

Commented:
Two things:

(*) From IIS, for the Virtual Directory and only for the folder where ASPUpload saves (for security reasons, restrict only in this folder), Right Click properties and select Write Also.  For security reasons, ensure that EXECUTE is not enabled in this folder.

(*) Windows Explorer -> Navigate to the folder, Select IUSR_<machinename> and IWAM_<machinename> and enable Write Permission for these accounts in Security tab.

Now you can upload.

Did this help you?

Author

Commented:
thanks a lot for the comments kiddanger and deepaknet. I really appreciate all your answers. I try to do that all your suggestions but the same thing, it doesnt change anything. I can't upload file.

     How do i bring back uploading and deleting files when i just click the PERMISSIONS WIZARD accidentally and so on.. is there any solutions. Help!

iceman_16
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

iceman...

What exactly did you do?  Do you know how to assign NTFS permissions at the file system level?

Author

Commented:
kiddanger

         I just accidentally click the PERMISSIONS WIZARD and so on... and then something change I can't save and delete upload files. Do you know on how to go back in IIS 5.1

         I do not know on how to assign NTFS permissions at the file system level. Can you give me instructions on how to assign it?Thanks

iceman_16
Open Windows Explorer and go to the folder you need to set permissions on, right click on the folder name, choose properties, select the security tab and make sure the IUSR_computername account has modify rights.

Commented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:
Accept kiddanger's comment {http:#14585216} as answer.

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Huji
EE Cleanup Volunteer

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial