troubleshooting Question

CDO Send Mail Sudden is "Permission Denied."

Avatar of joemeadows
joemeadows asked on
Microsoft IIS Web Server
5 Comments1 Solution1441 ViewsLast Modified:
Greetings.  This is a weird one.

Suddenly, this morning, after years of no problems with sending CDONTS mail, my IIS 5.0 Web Server with Windows 2 K server started popping up an error message (800a0046) "Access denied" with a reference to the line:

objMail.Send

The anonymous Internet User account still has full permission to all the mail root folders as it always has, and I even added that account to the Aministrator's Group account in the Web Server's local machine.  No change.  We did add ASP.NET functionality to the IIS server, but that was a while ago and CDONTS has worked just fine up to this morning.  We do have Secure Socket Layers (https) installed (this is a government Web server), but that's never been an issue on our Itranet.  

I tried sending a CDO email message with scripting and I get the error (80070005) "Access is denied."  HOWEVER...when I send an email on an .aspx page, calling the "System.Web.Mail" namespsace, the Web server sends the email.

Help!  I gotta get CDONTS or CDO to work again!    
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 5 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 5 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros