troubleshooting Question

Cisco 831 Router is not sending DNS information

Avatar of eposs2004
eposs2004 asked on
NetworkingHardware FirewallsDNS
1 Comment1 Solution684 ViewsLast Modified:
I am having to program a DNS Server information into each workstation becuase the Cisco Router is not sending that information.  Here is my setup.

Building configuration...

Current configuration : 4539 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname MALTEC
!
enable secret 5
!
username MALTEC password 7
ip subnet-zero
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool CLIENT
   import all
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   lease 0 2
!
ip urlfilter alert
ip audit notify log
ip audit po max-events 100
!
!
!
!
!
!
interface Ethernet0
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip access-group 120 in
 no ip route-cache
 no ip mroute-cache
 no cdp enable
 hold-queue 32 in
 hold-queue 100 out
!
interface Ethernet1
 ip address dhcp client-id Ethernet1
 ip access-goup 131 in
 ip nat outside
 duplex auto
 no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload
ip classless
ip http server
no ip http secure-server
!
!
logging trap debugging
logging 10.10.10.4
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
access-list 120 remark ==========Deny RFC 1918==========
access-list 120 deny   ip 172.16.0.0 0.15.255.255 any
access-list 120 deny   ip 192.168.0.0 0.0.255.255 any
access-list 120 remark ==========Prevent IP-Spoofing for loopback==========
access-list 120 deny   ip 224.0.0.0 0.255.255.255 any
access-list 120 remark ==========Exploited Ports==========
access-list 120 deny   udp any any eq tftp
access-list 120 deny   udp any any eq ntp
access-list 120 deny   tcp any any eq 135
access-list 120 deny   udp any any eq 135
access-list 120 deny   tcp any any eq 137
access-list 120 deny   udp any any eq netbios-ns
access-list 120 deny   udp any any eq netbios-dgm
access-list 120 deny   tcp any any eq 138
access-list 120 deny   tcp any any eq 139
access-list 120 deny   udp any any eq netbios-ss
access-list 120 deny   tcp any any eq 445
access-list 120 deny   udp any any eq 445
access-list 120 deny   tcp any any eq 593
access-list 120 deny   udp any any range 995 999
access-list 120 deny   tcp any any eq 1034
access-list 120 deny   tcp any any range 3127 3198
access-list 120 deny   udp any any range 3127 3198
access-list 120 deny   tcp any any eq 4444
access-list 120 deny   tcp any any eq 5554
access-list 120 deny   tcp any any eq 9996
access-list 120 deny   tcp any any eq 1494
access-list 120 permit ip any any log
access-list 131 remark ==========Computer Associates Access==========
access-list 131 permit ip host 213.35.101.4 any
access-list 131 remark ==========Deny RFC 1918==========
access-list 131 deny   ip 10.0.0.0 0.255.255.255 any
access-list 131 deny   ip 172.16.0.0 0.15.255.255 any
access-list 131 deny   ip 192.0.0.0 0.255.255.255 any
access-list 131 remark ==========Prevent IP-Spoofing for loopback==========
access-list 131 deny   ip 127.0.0.0 0.255.255.255 any
access-list 131 remark ==========Expoited Ports==========
access-list 131 deny   udp any any eq tftp
access-list 131 deny   udp any any eq ntp
access-list 131 deny   tcp any any eq 135
access-list 131 deny   udp any any eq 135
access-list 131 deny   tcp any any eq 137
access-list 131 deny   udp any any eq netbios-ns
access-list 131 deny   udp any any eq netbios-dgm
access-list 131 deny   tcp any any eq 138
access-list 131 deny   tcp any any eq 139
access-list 131 deny   udp any any eq netbios-ss
access-list 131 deny   tcp any any eq 445
access-list 131 deny   udp any any eq 445
access-list 131 deny   tcp any any eq 593
access-list 131 deny   udp any any range 995 999
access-list 131 deny   udp any any eq 1034
access-list 131 deny   tcp any any eq 1034
access-list 131 deny   tcp any any range 3127 3198
access-list 131 deny   udp any any range 3127 3198
access-list 131 deny   tcp any any eq 4444
access-list 131 deny   tcp any any eq 5554
access-list 131 deny   tcp any any eq 9996
access-list 131 remark ==========Permit all other traffic==========
access-list 131 permit icmp any any
access-list 131 permit tcp any any established
access-list 131 permit udp any eq bootpc any
access-list 131 permit udp any eq bootps any
access-list 131 permit udp any any eq bootpc
access-list 131 permit udp any any eq bootps
access-list 131 permit udp any eq domain any
access-list 131 permit ip any any log
access-list 131 deny   ip any any log
!
line con 0
 exec-timeout 120 0
 no modem enable
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 access-class 23 in
 exec-timeout 120 0
 login local
 length 0
!
scheduler max-task-time 5000
end
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 1 Comment.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 1 Comment.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros