troubleshooting Question

Updating a Mac's OS offline using 'packages' ....

Avatar of pugdog_fan
pugdog_fan asked on
Apple OSApple NetworkingMac OS X
4 Comments1 Solution345 ViewsLast Modified:
Question Pre-Amble (I wish I could make this a 1000 point question).

I have installed a fresh copy of Panther to my Mac (the end result is that my Mac ends up Mac OS 10.3.2 installed)

Can you tell me the CORRECT way to use the Apple website update to download all updates to my HD ...
So that later on OFFLINE I can update my system.  I want to KEEP the update files ... burn the to a CD,
so that later on I can take another Mac with 10.3.2 to the most current version OFFLINE.

End of Question Pre-Amble ....

My Question(s) ....

Background Information ....

I have tried and tried, but I can't come up with a working process to update the OS on Mac offline.

Here is the deal ... When you install the OS Panther (3 CD discs).  I only have to use 2 of the 3 discs because I have
changed some of the install options to make the installation finish faster.

When the OS is finsihed its install process, I see that the OS is 10.3.2
It is VERY easy at that point to simply using the update software opinion, and upgrade the OS to 10.3.9.

My problem is that at times, the network is VERY slow and/or I simply want to have all the files handy to
take a Mac from an inital 10.3.2 install and use my update files to make it 10.3.9 without even going online.
Once the OS is at 10.3.9, I would run another online update to make sure that 10.3.9 is up to date.

So, I've tried both trying an install of 10.3.2 from scratch, and then use the OPTIONS during the update process
to either install and download packages and JUST the download of packages.

I downloaded all 9 packages that make the OS go from 10.3.2 from 10.3.9.  I then tried to copy the packages to my USB pen drive.  I was going to burn them to a CD later on.  When I tried to COPY the packages from the hard drive to the pen drive, I got an error that said the files could not be copied (I forget the reason) ... but they copied over to the pen drive just fine.

I compared the files on the pen drive to the files on the hard drive and the seemed to be the same.  When I then moved the USB to a PC ... I transfered the files from the pen drive to the PC hard drive.  I then used Nero to 'burn' the NINE files to a CD-R.

I took the CD-R from the PC to a Mac with an install of 10.3.2 ..... I then used the CD to copy the 9 files off the CD to a newly created folder on the Mac HD.  When I double click on a file ... nothing happens .... but the installer program does launch ...

Nothing happens .... I have to force quit and reboot.

Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 4 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 4 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros