Link to home
Start Free TrialLog in
Avatar of wynbryant
wynbryant

asked on

VPN Configuration, Cisco PIX 501, WinServer 2003

having trouble with vpn configuration on cisco pix 501.  client error message (win xp) is 678: the remote computer did not respond.  

anything jump out in the configuration below?

current running config:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password
passwd
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list acl_out permit tcp any host <PUBLIC_IP_2> eq www
access-list acl_out permit tcp any host <PUBLIC_IP_2> eq https
access-list acl_out permit tcp any host <PUBLIC_IP_2> eq pptp
access-list acl_out permit tcp any host <PUBLIC_IP_2> eq 1721
access-list 101 permit ip 192.168.2.0 255.255.255.0 192.168.100.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside <PUBLIC_IP_1> <WAN_SUBNET>
ip address inside 192.168.2.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 192.168.100.50-192.168.100.100
pdm location 192.168.2.5 255.255.255.255 inside
pdm location 192.168.100.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) <PUBLIC_IP_2> 192.168.2.5 netmask 255.255.255.255 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 <ROUTER> 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 client configuration address local pptp-pool
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username user1 password *********
vpdn username user2 password *********
vpdn enable outside
terminal width 80
: end
[OK]
Avatar of Joesmail
Joesmail

What encryption are you using?
# vpdn group 1 ppp encryption mppe 40

Is it chap, pap, or mschap?

# no vpdn group 1 ppp authentication pap
# no vpdn group 1 ppp authentication chap
# vpdn group 1 ppp authentication mschap etc......or change this around to suite...

You may want your clients resolving addresses...
# vpdn group 1 client configuration dns 192.168.50.1....your dns
# vpdn group 1 client configuration wins 192.168.50.1...your wins
Avatar of wynbryant

ASKER

Ok, I'll see what that does.  Do you see anything in the config that would prevent the pix from listening for an incoming connection?  Doesn't appear to be getting to the authentication stage.
ASKER CERTIFIED SOLUTION
Avatar of Joesmail
Joesmail

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
still unable to connect...error 678-remote computer did not respond

if it helps:
xxx.xxx.xxx.109-router
xxx.xxx.xxx.110-pix
xxx.xxx.xxx.111-webserver

do i need to include access-group 101 in the outside interface?:
access-group 101 in interface outside



here's what I have now:

Building configuration...
: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxx encrypted
passwd xxx encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list acl_out permit tcp any host xxx.xxx.xxx.111 eq www
access-list acl_out permit tcp any host xxx.xxx.xxx.111 eq https
access-list 101 permit ip 192.168.2.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list 101 permit tcp any host xxx.xxx.xxx.110 eq pptp
access-list 101 permit gre any host xxx.xxx.xxx.110
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.110 255.255.255.240
ip address inside 192.168.2.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 192.168.100.50-192.168.100.100
pdm location 192.168.2.5 255.255.255.255 inside
pdm location 192.168.100.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) xxx.xxx.xxx.111 192.168.2.5 netmask 255.255.255.255 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.109 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe 40
vpdn group 1 client configuration address local pptp-pool
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username user1 password *********
vpdn username user2 password *********
vpdn enable outside
terminal width 80
Cryptochecksum:
: end
[OK]