Ghost 8.0 - Unable to establish contact with session <SessionName> error

enzogoy
enzogoy used Ask the Experts™
on
In our organization, we used Ghost 7.5 to Re-image or making an image through GhostCasting Server.  But ever since we upgrade our DHCP servers (2 of them) to Win 2003 Server, the Ghostcasting Server is not working anymore.  I thought the version 7.5 is not capable with win 2003 therefore I installed the version 8  to one of the administrator PC and try it again but the error still there.  Here is the error message:

Unable to establish contact with session <SessionName>.
Check that the GhostCasting Server application is ready to accept clients! (10030)

The funny thing is i'm able to use Ghost Console version 8 to Remote Install Client but not able to clone or re-image the client machine.
I also check on net to see what is the error 10030 mean.  They ask me to check the session name to make sure it right.  But i'm 100% sure that there is nothing wrong with the session name because I use only 1 session name since 2003.

So I think may be there is something wrong at the DHCP server, we need to do something there, but dont really know what is it.  I may be wrong.

Hope the experts could help me out of this.  If i'm not able to solve it, i may have to manually install more than 100 pcs by the end of this year.

Thanks in advance.

PS:  feel free to ask if you are not fully understand the problem, because english is not my first language. :)  Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Ron MalmsteadInformation Services Manager

Commented:
FIRST !...make sure you have the correct ndis driver for the NIC card, and that the boot floppy is good...

when you boot to the floppy you should see the link state...100mbps or 1000...whatever.  This means it's initialized correctly.

Now.....when you choose "multicasting"....you get an ip on the window...if not...then your DHCP is the problem.

Try to set the ip address manually, and exclude that ip from DHCP leases.

Make sure that IP is visible to the server your ghosting from.....ping it.

don't use spaces or symbols in session names....sometimes error out.


good luck.

Author

Commented:
hi xuserx2000

Yeah, i have the correct ndis driver for NIC card.

When i choose "Multicasting" i saw the ip on the window.  Ok, so are we able to eliminate the DHCP problem???

I try to set the ip add manually as 192.168.0.165 and exclude that it from DHCP leases and try to ping it, working fine.  But when i boot from floppy then get into Ghost ==> Multicasting and i saw it appears a different ip (192.168.0.167).  I think when we boot from floppy and running Ghost, it kills all of the setting and pick up the new ip address from DHCP server.

My session name is "image", the word is simple and for sure i wont type it wrong. :)

xuserx2000, any other suggestion?

Thanks
enzogoy
Hi!
I have excactly the same problem with no idiea to solve it!

I initiate the session with the console-application, the (pxe-booted) client gets the task-request (image-pull) with correct data (including the _exact_ session-name) - and fails with the discussed error!

This means - the connection between server and client _is_ existing (the client gets the task across the net via the connection!)!

pleas help!

greets
pete
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

Solved for me!

My server was protected by mcaffee virusscan enterprise 8 - after deactivating it (was coincidence - i experimented with the firewall) the client was able to connect and perform his tasks!

hth
pete

Author

Commented:
Hi pete

it's good, finally you know how to solve your problem. :)

Could you please tell me what did you do to solve it?  What do you mean for deactivating? do you mean uninstalling it?  Because my DHCP servers also a data server, therefore i really want the virusscan to be on it.  Is there anyway to go around it.

Hope to hear from you soon.

ta
enz
Hi enz!

> Could you please tell me what did you do to solve it?
You have to add the PXE- and the TFTP-server to the exclusion-list of the virusscan-block-rules .. that was my solution.

HTH
pete
In the VirusScan Console, Under Access Protection - You have to disable / delete the rules that prevent inbound / outbound IRC communication on ports 6666-6669. Evidentally, ghost is fond of those ports and McAfee is not.

Commented:
Actually you do not want to deactivate it - all you have to do is set an exclusion for Ghostsvr.exe. To do this open the VirusScan Console and double-click on Access Protection to open Access Protection Properties.  Select the Port Blocking tab and Edit the Prevent IRC communications on Port 6666 - 6669t. In the Excluded Proccess field, type Ghostsvr.exe and click OK. Do this for both rules - one being for the Inbound direction and the other being for the outbound direction.  As soon as I did this, it worked perfectly.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial