troubleshooting Question

How to setup CISCO 804 ISDN router to work with VPN

Avatar of rhan101277
rhan101277 asked on
VPN
11 Comments1 Solution543 ViewsLast Modified:
I have a cisco 804 and I am trying to get it to work with VPN, it looks like the peer computer quits responding.  I am sure it is something wrong with my setup.  I don't want to get a new IOS version im not sure how much that is, I read another post saying that someone else who had the exact setup as I got his going without a new IOS but it was his VPN server that changed.  Could someone please give very detailed directions on what I need to do to get this working it is extremely important, thanks for your prompt attention...

Here is my config

Current configuration:                      
!
version 12.0            
no service pad              
service timestamps debug uptime                              
service timestamps log uptime                            
service password-encryption                          
!
hostname Rogers_Router                      
!
enable sxxxxxxxxxxxxx.                                              
!
usernamexxxxxxxxxxxxx
dial-peer voice 1 pots                      
 call-waiting            
 ring 0      
 port 1      
 destination-pattern 67187                        
!
dial-peer voice 2 pots                      
 call-waiting            
 ring 0      
 port 2      
 destination-pattern 6718704                            
!
pots country US              
ip subnet-zero              
no ip source-route                  
!
ip dhcp pool DHCPPoolLAN_0                          
   network 192.168.0.0 255.255.255.0                                    
   dns-server 4.2.2.2 4.2.2.3                            
   default-router 192.168.0.100                              
!
ip name-server 4.2.2.2                      
ip name-server 4.2.2.3                      
isdn switch-type basic-ni                        
!
!
!
interface Ethernet0                  
 ip address 192.168.0.100 255.255.255.0                                      
 ip access-group 121 in                      
 no ip directed-broadcast                        
 no ip proxy-arp                
 ip nat inside              
!
interface BRI0              
 no ip address              
 no ip directed-broadcast                        
 encapsulation ppp                  
 dialer pool-member 1                    
 isdn switch-type basic-ni                          
 isdn spid1 xxxxxxxxxxxxxx                                  
 isdn spid2xxxxxxxxxxx                                  
 isdn incoming-voice modem                          
 ppp authentication chap pap callin                                  
 ppp multilink              
!
interface Dialer1                
 description ISP                
 ip address negotiated                      
 ip access-group 121 in                      
 no ip directed-broadcast                        
 no ip proxy-arp                
 ip nat outside              
 encapsulation ppp                  
 no ip split-horizon                    
 dialer remote-name Cisco1                          
 dialer idle-timeout 60                      
 dialer string xxxxxxxxxx                        
 dialer hold-queue 10                    
 dialer load-threshold 40 either                                
 dialer pool 1              
 dialer-group 1              
 pulse-time 0            
 ppp authentication chap pap callin                                  
 ppp chap hostname xxxxxxxxx                                  
 ppp chap password xxxxxxxxxxxxx                                    
 ppp pap sent-username xxxxxxxxxxxxxxxx                                                                  
 ppp multilink              
!
ip nat inside source list 18 interface Dialer1 overload                                                      
ip classless            
ip route 0.0.0.0 0.0.0.0 Dialer1                                
!
!
map-class dialer DialClass                          
access-list 18 permit 192.168.0.0 0.0.0.255                                          
access-list 121 permit tcp any eq 500 any                                      
access-list 121 permit udp any eq isakmp any
access-list 121 deny   udp any eq netbios-dgm any
access-list 121 deny   udp any eq netbios-ns any
access-list 121 deny   udp any eq 139 any
access-list 121 deny   tcp any eq 137 any
access-list 121 deny   tcp any eq 138 any
access-list 121 deny   tcp any eq 139 any
access-list 121 permit ip any any time-range TIME
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 login local
!
time-range TIME
 periodic daily 0:00 to 23:59
!
end
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 11 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 11 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros