Avatar of philodendrin
philodendrin asked on

Public Folder Permissions on Exchange 2003 - how to set on all subfolders

I have two users at our organization that create and manage public folders. We now have the need to add a third person who can create and edit the existing public folder store and all future public folders. For the life of me, I can't seem to find away to provide the new person with permission to rename or generally edit public folders, without going into each of the literally hundreds of public folders and adding her under the client permissions tab.

Is there a way to allow her "owner" type access to all public folders at the root level (including all subfolders)?

I must be missing something. Thanks...
Exchange

Avatar of undefined
Last Comment
philodendrin

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
marc_nivens

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
philodendrin

Marc,

Thanks for the tip. I had no idea that "propagate settings" was even an option. It worked on all but one directory. I get a message "access denied. Facility: win32. ID No. 80070005. Exchange System Manager."

Any help on why this error would appear on one directory, but work on all others would be appreciated.

The Public Folder Directory structure is pretty straightforward.... they have their public folders separated A-D, E-H, I-L, etc... The first grouping "a-d" is the one giving me headaches. It looks no different than any of the others... so, I'm stumped... yet again.

Thanks for the help thus far!
marc_nivens

Hmm... every time I have seen that error it was because the NTFS permissions on the pub were jacked becuase someone had been accessing the M: drive with a virus scan, backup, or similar activity.  There are other causes as well, which can be tedious to track down.  The easiest way to fix this is to create a new top level folder, move the a-d group underneath it, propagate the permissions, then move the group back.
ASKER
philodendrin

You were right again... the transfer to a new folder allowed me to set the permissions. I transferred everything back and now we're all set.

We definitely don't have a virus scanner doing anything with the M drive. We use Symantec Mail Security for Exchange 4.6 which has always been reliable. Backup Exec 9.1 backs up Exchange... we use Veritas's default exchange settings... so, it should be copacetic. It's strange that just one directory out of a dozen gave me that error. Oh well.. I'm not going to lose sleep over it.

Thanks for the solution. I'm constantly humbled by all of you experts!
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes