dma_int : status=0x51{DriveReady SeekComplete Error}

Following a power outage, when i tried to boot into my Red hat 9  ( i have a dual boot with Win NT ), i am unable to get to a login prompt.

The following is the error i get:

dma_int : status=0x51{DriveReady SeekComplete Error}
dma_int: error=0x40 {Uncorrectable Error}
end_request:i/o error , dev 03:05
mkrootdev : label / not found
Mounting root filesystem
mount: error 2 mounting ext3
....
Kernel panic: no int found try passing int= option to kernel


Even when using a rescue disk/install disk, it reaches this error and then hangs.

I tried using a knoppix/ubuntu live cd to run a fsck on this filesystem but they too are unable to process the same.

Since i cant get access to the prompt, i am unable to edit any files etc.

Is this a case of a irrecoverable hardware error or is there something that can be done to resolve this issue?
krtknAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ravenplCommented:
First try booting from liveCD distro (not rescue, which tries to use Your disk), and after that try repairing Your filesystem
(ie fsck /dev/hda5 # replace the device with Your one).
It will propably fail (but give it a shot), as 'end_request:i/o error , dev 03:05' suggest that there are bad blocks or even some hardware failure.
To scan for bads: badblocks -sv /dev/hda5

Also, try mounting the filesystem as ext2 (mkdir /mnt/mnt; mount -t ext2 /dev/hda5 /mnt/mnt)
All above run from the liveCD.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
krtknAuthor Commented:
Yeah, the fsck from the liveCD distro failed as you suspected.

However, i havent tried the other options u mentioned.

btw, Is badblocks a parameter for fsck or a command by itself?

I will try out the other option ( mounting as /ext2) and get back to you.

Thanks
krtknAuthor Commented:
i just found the answer to my "badblocks" query.....ignore that question...
Get Blueprints for Increased Customer Retention

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

krtknAuthor Commented:
Well.....the badblocks command showed up numerous bad blocks and looks like the segment of the drive housing the linux root filesystem had gone bad.

Is there yet a way for me to access data on the filesystem ? I tried linking badblocks with the e2fsck and running e2fsck( to repair bad blocks...-P option if i remember right) with the options related to bad blocks.

All of them failed.

I suspect that i have lost the filesystem and its contents for good. Is there any chance of recovery from this setup?

Thanks
ravenplCommented:
krtknAuthor Commented:
Yeah, will try out those. But i understand that it may or may not work. Anyways. I will close this query. Thanks for your help. Since most (actually all! ) of the steps you have suggested are logical and correct for this scenario, i will accept your answer. Thanks!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.